Windows 8.1 winload.efi error



  • Hello all,
    I am having an issue with deploying Windows 8.1 to devices. I can upload the image, register a device, and then create the download task for that device. I turn the PC on, boot to NIC and it downloads the image no problem.

    However, when the PC reboots it flashes the DELL boot screen and then shows me an error page and gives me 3 options. I have found that the issue is an error where the winload.efi is missing or corrupted. I DO HAVE A WORK AROUND FOR THIS.

    I have been able to pop in the OS dvd and boot to the CD drive (after turning off legacy boot and re-enabling secure boot) and open the troubleshooter to launch the command prompt. I type in 4 commands:
    bootrec /scanos
    bootrec /rebuildbcd (Here it finds C:\Windows and asks if I would like to use it. I of course say Yes)
    bootrec /fixmbr
    bootrec /fixboot

    and then exit the command prompt and turn off the PC. When I turn it back on, it boots up to Windows just fine.

    My question is that although I have a work around in place, is there something I did wrong with the original image, upload, or download that would cause this to happen? I have imaged 4 PCs this way off the master image I created and uploaded to our server. The workaround of doing the bootrec commands works great, I was just wondering if anyone had any ideas that could correct this for future devices I deploy within the school district. Thanks!



  • Yeah, I’m having the same issue too. Secure boot was turned off before i uploaded the image and I turned secure boot off before downloading image.



  • Hmmm… basically, no UEFI booting for now ? I thought iPXE was getting around it?
    I tried to load qemu+OVMF as I don’t have many UEFI-still enabled boxes, but I get [url]http://ipxe.org/err/2e0080[/url]


  • Senior Developer

    It sounds like an Issue I fight with on my windows 8 systems at work.

    While there’s an option to disable secure boot, it doesn’t truly turn it off.

    The easiest fix I could recommend for this is to switch over to a “pure” legacy style system meaning to clean the disk and make sure it loads in MBR fashion and the rest of the system just boots to legacy mode.

    While less than ideal, it’s the only option I have been able to ensure works everytime. It does mean more steps in that I have to tell the bios on every system to boot through legacy, but it works.



  • Tom,
    Yes, I have secure boot off. On the Dell Optiplex 3020 PCs we have, I have to turn off secure boot and enable legacy boot options to have the option to Boot to NIC. I have also left secure boot off when uploading and downloading the image, again due to needing to enable Legacy boot options, which will not work with secure boot on.

    After the device downloads the image and reboots, I turn it back on before windows has a chance to load the first time, and reboot the device. It still shows me the winload.efi error


  • Senior Developer

    When you uploaded the image did you turn off secure boot first? When you are downloading the image do you turn off secure boot? The process for Uefi imaging:

    Turn off secure boot
    Register and image system.
    After image before boot to OS turn back on secure boot.


Log in to reply
 

421
Online

38995
Users

10714
Topics

101713
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.