WOL issue fog 1.2.0



  • Hi,

    I am struggling with the wake-up function in FOG.
    if I use the function in fog nothing seems to happen.(tail -f /var/log/apache2/access.log)
    when I use the wol command manually ([url]http://…fog[/url] server ip…/fog/wol/wol.php?wakeonlan=00:1c:25:d1:xx:xx)
    the device will wake up. so it seem wol.php is working ok and I see it in the access.log.

    please advice.


  • Moderator

    @Lombard Please check if the primary MAC for the host is correct.





  • @Tom-Elliott Thanks Tom for this explanation! Since yesterday i have completely reinstall my fog server in 1.2.0.
    The wake on lan doesn’t work. My server is in the same VLAN that my client computer. I test wakeonlan directly in command line in the server and it works. My server fog is in a hyper-v environnement. I don’t understand beacause i work in different network with the same architectury and i never saw this problem.

    Thanks


  • Senior Developer

    @Lombard wake on lab is handled much differently in trunk than it had been for fog 1.2.0. It no longer has a special page to send the packets as it once had and therefore does not require the fog settings element. If fog is not working in your environment if have to guess a few things. First, Wol is trying to go across su nets. Wol is a layer 2 element in similar respect to multicast. If udp packets are trying to cross sub nets this is likely the reason it’s not working for you. If udp packets are blocked to any/all subnets this could be the cause as well. To enable Wol across different subnets you need to enable udp broadcast forwarding in your network. This is an individual switch option so you likely need to work your way from the fog server up to the central with/router.



  • Hi,

    I’m in 1.3 version. I haven’t any FOG_WOL Option in the Fog General setings and my wakeonlan doesn’t work.
    Is that normal?

    Thank



  • Sorry, what a mistake I am deeply ashamed :oops:

    some where I forgot the slash… :oops:

    SOLVED…


  • Senior Developer

    Put the slash in front of the fog part int the path so it reads as /fog/wol/wol.php



  • [URL=‘http://…fog’]http://192.168.48.80[/URL]/fog/wol/wol.php?wakeonlan=00:1c:25:d1:xx:xx this is working…

    FOG_WOL_HOST = 192.168.48.80
    FOG_WOL_PATH = fog/wol/wol.php
    FOG_WOL_INTERFACE -eth0

    wake-up task not working, deploy a image the system also not starting…


  • Senior Developer

    Do me a favor:

    Check the FOG Configuration->FOG Settings->General Settings

    FOG_WOL_HOST should be the IP of your FOG Server, or whichever FOG Server you’re attempting to do the WOL from: (E.G. 192.168.63.254)
    FOG_WOL_PATH should be the location of the wol.php script in whole: (E.G. /fog/wol/wol.php)
    FOG_WOL_INTERFACE should be the NIC of the interface you’re expecting Wake on Lan to come from: (E.G. eth0)


  • Senior Developer

    Let me ask:

    What tasking are you trying to perform that isn’t sending the WOL packet?



  • I have update fog to latest svn 2429 and installed WOLBroadcast plugin set the broadcast to 192.168.63.255
    but still no luck…
    the system isn’t turned on and i do not see the wol.php in the access.log
    if I do it manually in the browser then I will see the wol.php in the access.log and the system turns on…



  • I’ll chime in from a networking point of view… yes the broadcast needs to be 192.168.63.255 as that is the highest address in the subnet. With a subnet mask of 255.255.240.0, 192.168.48.255 falls within the valid IP range and will not work as a broadcast. By sending a WOL packet to 48.255, you are only targeting one IP.


  • Senior Developer

    You may think about updating to the lastest svn.

    Install the WOLBroadcast plugin

    Configure your broadcast address of 192.168.68.255

    Test and hopefully all will work for you!



  • my broadcast is 192.168.63.255
    and gateway 192.168.48.1

    FOG version 1.2.0
    Ubuntu 14.04 LTS


  • Senior Developer

    Or is your broadcast at:
    192.168.63.255?


  • Senior Developer

    So what’s the broadcast address of the main network?

    It would seem to me that this is where you need to specify the wake on lan.

    I’d imagine you’d need to send WOL on the 48.255 assuming this is where your gate way resides?



  • sorry we do not have separated subnet we use a B class network.
    with a subnetmask of 255.255.240.0 this will get a ip range from 192.168.48.0 to 192.168.63.255.


  • Senior Developer

    How can you have separated subnet’s but not separated vlans?



  • I did see this thread but we do not use vlan’s.
    and wol is working with other programs (like Italc and qdp deploy)
    [SIZE=2]will take a look again in this thread [/SIZE]maybe[SIZE=2] i missed something [/SIZE]


Log in to reply
 

463
Online

39183
Users

10832
Topics

103076
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.