Pending MAC addresses



  • Hi all,
    If I recall correctly in FOG 0.32 when you registered a laptop via wired ethernet, it would pick up the wireless MAC address - then you would just open that host and it would have that MAC address waiting. Then you would just click the + sign next to it and it would be associated with that host…

    In FOG 1.2 I see that you can still hit the + sign and manually add your wireless MAC, but why doesn’t it discover it automatically anymore?

    Opening each host and just clicking + on the pending MAC address wasn’t too bad, but manually typing in all of the wireless MAC addresses will take a long time…

    If anyone has any advice or information on this it would be greatly appreciated. Is there a way to restore this functionality? Or better yet, automatically associate the pending MAC addresses so you don’t even have to open each host?

    Thank you for and advice or help,
    D.L.



  • Great, thanks again. I saw an older thread about automatically associating the pending MACs with a host, so you don’t have to open each host and click + to add the wireless MAC.

    Is that actually possible and/or could you point me in the right direction? Because it seems like it would be a time-saver…

    Thanks,
    D.L.


  • Senior Developer

    From my experiences, what you’re asking seems to work best, though I’ve yet to test all possibilities.



  • Thanks for the information Tom, I appreciate it. So are you saying that the wireless MAC (pending MACs) are a function of the FOG service? For some reason I thought that these were picked up via PXE during the host registration … but it sounds like these are actually added once Windows boots, via the FOG service over wired ethernet … ?

    If it is happening at the FOG service level, then will it pick up the wireless MAC address if I just leave it plugged in to ethernet until it has joined the domain, etc.??

    Thank you,
    D.L.


  • Senior Developer

    The problem isn’t FOG or your client, technically. The problem is with Windows 7 and modern updates, it’s disabling devices that aren’t necessarily in use at the time.

    So I’ll place an example.

    Your Wired nic is 00:11:22:33:44:55

    Your Wireless nic is 11:22:33:44:55:66

    You register and image your machine, all fine under the wired NIC.

    When the image is done, you disconnect the nic from the system.

    Once your system is booted, it “tries” to register with the wireless NIC.

    However, because the wired nic is not connected.

    Windows 7 will “disable” the wired nic and when the current client tries to register, the FOG Server is only receiving the 11:22:33:44:55:66 nic. It has no idea what host that belongs to and simply get’s returned a message equivalent of “Invalid Host”. This is why you’re not seeing the NIC’s register with the system.

    It hasn’t a clue what the host is because not all the NICs are being passed.


Log in to reply
 

336
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.