Fresh 1.2 install with old 0.32 images not deploying correctly



  • Good morning, first to start off by looking through settings and forum browsing I’ve made many settings changes in the recommendations from the searches.
    Had an old 0.32 install, we just copied the /images folder, didn’t backup any databases or tables(woops). We’ve since transferred the images to the new /images directory.

    1. chmod -R 777 performed.
    2. [FONT=Ubuntu][COLOR=#555555]FOG_FORMAT_FLAG_IN_GUI is checked, and image has been set to partimage[/COLOR][/FONT]
      [FONT=Ubuntu][COLOR=#555555]3. Image management name matches image name in /images[/COLOR][/FONT]
      [FONT=Ubuntu][COLOR=#555555]4. Storage management user/pass matches TFTP in fog settings(FTP working correctly)[/COLOR][/FONT]

    EDIT: 5. also performed sudo touch on /images/.mntcheck and /images/dev/.mntcheck

    [FONT=Ubuntu][COLOR=#555555]I added the image in Image Management (name matches image name), storage group set, OS set,Image Path correctly named, image type (i’ve tried single disk, and mult part w/ single disk, couldn’t remember which option was set when I uploaded it on 0.32) and Image Manager set to partimage.[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Host is registered, assigned an image, group, Ad settings etc. When I deploy the image it boots, goes through the process, it’s pretty quick I’ve had to take videos to get what it’s been saying, Attached are stills from when the task goes through the “image” process and then doesn’t do anything and says task completed! and restarts. [/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Any help or suggestions? Still looking into other searches for similar issues. Thanks![/COLOR][/FONT]

    [url="/_imported_xf_attachments/1/1415_Multiple Partition Single Disk.png?:"]Multiple Partition Single Disk.png[/url][url="/_imported_xf_attachments/1/1416_Single Disk Resizeable.png?:"]Single Disk Resizeable.png[/url]



  • I got the same issue - but unfortunately, creating a new image and pulling it from the client does not work either. It is just going through the check stuff and reboots the client.

    System Ubuntu 12.04
    FOG 1.2.0



  • I can confirm this. I did the same (see my other posts, here is one: [url]http://fogproject.org/forum/threads/upgraded-from-32-too-1-1-2-but-cant-deploy-an-image.10962/#post-32956[/url])
    Had to re-image to my fog server, and then they worked. the OS number changes, and there is no earthly way to get into the backend of the code and change it (or something? nfi but thats my guess)



  • Hi,
    Although it is a hassle, one simple way around this is to re-build a 0.32 box on Ubuntu 10.04, deploy the old images to a host or VM, then re-capture with a new installation of FOG 1.2 with default settings. That will transfer the image to the new FOG server with partclone and that image will work from there on out…

    Best regards,
    D.L.


Log in to reply
 

480
Online

38968
Users

10709
Topics

101631
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.