Fog/sysprep stops at computer name screen



  • Using FOG 032 for windows 7 build. I am using an unattend.xml file. When I blow an image down to a box everything goes well. Fog renames computer and joins to the domain. During the first or second reboot however the computer stops at the computer name dialogue.

    It defaults to the name specified in FOG in this case PC-*. If i click next here the machine goes on its merry way fog does the rename and my sysprepped image works. The problem is I want this to be automated and the stop at the computer name is screen is an issue. Anyone seen this before? How can I get this to automatically blow by this screen rather than stopping?

    I see in the fog settings for quick registration seems to correlate to the computer name in the dialogue. I also noticed that the FOG_QUICKREG_AUTOPOP setting was set to 0. I changed this value to 1 thinking that perhaps this would make the process no longer stop and wait for me to click next. No dice.

    Kind of stumped with this one.



  • I may be wrong here, I haven’t worked with Fog in a while and may not be familiar with any new features, but here goes.

    If you don’t specify a computer name in your answer file windows will always stop and ask you for a name. If you put a * in for the name, one will automatically be generated by windows and you will not be asked for a name. When the computer reboots, the fog service will kick in and automatically rename the computer to whatever it is in your database.

    Your quick reg should be set to 0 unless you are actually using quick registration. Ex, you have 10 new computers but don’t want to give them all names manually. Quickreg will automatically do this for you, but as far as i know it has anything to do with sysprep.

    Is your computer name really set to PC-*. If it is that’s not right. The start should be replaced with a number if quick reg worked correctly.

    Early name changer - I have not worked with this yet. As far as I know it has to do only with registry and not sysprep. Maybe you have this setting on and the pc’s registry is updated to the name in your database, then sysprep is just getting the name from that.

    In summary, turn off quick reg, turn off name change early, and change your answer file computer name to a * You should be fine then.



  • [quote=“jdd49, post: 1788, member: 623”]What do you have the computer name in your answer file set as?[/quote]
    No computer name in answer file. I wanted fog to rename to computer name defined in fog for the particular MAC. Once i hit next manually it does work as advertised but as I said earlier any manually intervention here is not going to help. Thanks for the reply.



  • What do you have the computer name in your answer file set as?


Log in to reply
 

377
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.