FOG 1.2. doesn't work across MAC-secured VLANs... or does it?



  • Hello,
    I’m new to this forum. I searched for similar threads, but I couldn’t find any…

    To tell you all what my problem is, I think I have to give you a glimpse of what my network looks like.
    [ATTACH=full]1411[/ATTACH]
    Our whole network is divided into VLANs, nothing special so far… There is a Radius-Server which sorts all incoming MAC-addresses in one of the 3 VLANs. I can acces the web-frontend of the radius and assign a MAC to a certain VLAN. No MAC can be assigned to multiple VLANs.
    Furthermore, I have no control over our switches. I have to live with what I have. (no iphelper etc.)

    My plan is to create a FOG environement which is capable of serving all VLANs with up- and downloads. Like you see above, I have a physical server running win 2008 server containing 3 physical nics. One for each VLAN. I wanted to virtualize FOG, so that I’m not bound to the servers hardware. This works pretty well if I only want to serve one VLAN.
    My FOG Master server has got 3 virtual nics. Each bridged to one physical nic.

    I used FOG 0.32 with the old pxelinux.0. I just had to install FOG and set dnsmasq up. This worked pretty well except that I had the same problem with the VLANs.
    Now I want to use FOG 1.2. I also had to set up dnsmasq which works since I did as the wiki said. I had a big problem to get the ipxe to work… I filled the win 2008 options 66 & 67 with the correct IPs and the undionly.kpxe but it wouldn’t work. I tried the chainloading thing to the old pxelinux, which didn’t work with the virtualized FOG since I used vmware. Now I switched to virtual box and it works. Even though I couldn’t get it running without the chainloading to pxelinux.
    ([url]http://fogproject.org/wiki/index.php/Chainloading_PXE_to_iPXE_using_pxelinux.0[/url])

    Since I got the Fog 1.2. running in VLAN 3 I tried to set it up for the other VLANs. Best thing I got so far were the above mentioned 2 storage nodes. First I tried to configure them like the wiki said, but then I had to realize, that tftp-service doesn’t span accross the VLANs and I couldn’t get any PC to register at the FOG from VLAN 4 or 5.
    Thats why I tried multiple tftp and pxe servers like it is mentioned in the wiki.
    ([url]http://www.fogproject.org/wiki/index.php/Multiple_TFTP_servers[/url])
    Now I just had to configure the /tftpboot/pxelinux.cfg/default, mentioned in the chainload-link above, properly so that each storage node asks at 192.168 4.20 or 5.20 for the boot.php.
    Now I had the problem, that the boot menu wanted to load from each subnet but couldn’t because of a path for the background picture of the boot menu. This path was on 192.168.3.20 and my capabilities in php and kernel compiling are very limited… I had to out comment a line on the master server in
    /var/www/fog/lib/fog/BootMenu.class.php
    which started with something like console --picture. Now I dont’t have a background picture for the FOG boot menu, but I can boot from every VLAN into that boot menu.

    I’m not able to deploy an image to my machine in VLAN 5 because the machine couldn’t mount the nfs on 192.168.3.20. Which doesn’t really astonish me, because that would never work that way on my shitty network… radius server…
    I thought, that when I set up storage nodes, the whole imaging-nfs-process would take place on that storage node. But as far as my setup ist concerned it doesn’t work. Has someone had my problem? Or does someone have any other ideas how I could get FOG to work on my VLANs?

    Side info:
    Ubuntu 13.10 x64 server + FOG 1.2.0

    PS: If you need any other information to help me solve my problem, don’t hesitat to ask. I’m quite sure I didn’t provide everything that you could need. Thanky

    [url="/_imported_xf_attachments/1/1411_Network.JPG?:"]Network.JPG[/url]


Log in to reply
 

373
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.