FOG FTP Login Failed



  • [COLOR=#333333][SIZE=14px][FONT=Arial]Hey guys,[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]I’ve recently moved our FOG Server to a new virtualized server. I thought that it should be pretty easy and it was time to virtualize- it was on an old dell box. This is on ubuntu 12.04 LTS. I followed this guide:[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial][URL=‘http://community.spiceworks.com/how_to/show/2631-moving-a-fog-server-to-new-hardware’][COLOR=#2080ad]http://community.spiceworks.com/how_to/show/2631-moving-a-fog-server-to-new-hardware[/COLOR][/URL][/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]Everything worked great and I was up and running in a couple hours after the /images transferred over. I was able to quick image a machine to test. Everything seemed ok until i got time the other day to test the upload and try it on a new image. It worked fine and completed, saying upload successful, but then gives an error about the FTP login couldn’t connect and says its using the username fog and a password i’ve never seen before. Even though I made the new image on FOG gui it never showed up under images, or under /images on the ubuntu server, and the image I uploaded never transferred. [/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]When I go into the /images folder on the ubuntu box, every image listed has a lock icon on it.[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]There was a post here from someone with the exact problem that I have, and he fixed it by manually creating the folder in /images and giving it 777 rights, but this seems like a painful process having to do it every time I need to image something (assuming it works for me). That post is here…[URL=‘http://fogproject.org/forum/threads/fogftp-login-failed.11748/’][COLOR=#2080ad]http://fogproject.org/forum/threads/fogftp-login-failed.11748/[/COLOR][/URL][/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]Also if i go in to the image management section in the FOG gui, it doesn’t list image sizes and states the ftp error there as well.[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]I tried sudo chmod 777 /images and it did nothing, thinking it would give the root full access. I’m not that great with linux so any help is greatly appreciated.[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial]Please see attached photos.[/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial][ATTACH=full]1399[/ATTACH][ATTACH=full]1400[/ATTACH][ATTACH=full]1401[/ATTACH][ATTACH=full]1402[/ATTACH][ATTACH=full]1403[/ATTACH][/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial] [/FONT][/SIZE][/COLOR]
    [COLOR=#333333][SIZE=14px][FONT=Arial][ATTACH]1399[/ATTACH][ATTACH]1400[/ATTACH][ATTACH]1401[/ATTACH][ATTACH]1402[/ATTACH][ATTACH]1403[/ATTACH][/FONT][/SIZE][/COLOR]

    [url="/_imported_xf_attachments/1/1399_perm.JPG?:"]perm.JPG[/url][url="/_imported_xf_attachments/1/1400_image.JPG?:"]image.JPG[/url][url="/_imported_xf_attachments/1/1401_server.JPG?:"]server.JPG[/url][url="/_imported_xf_attachments/1/1402_server2.JPG?:"]server2.JPG[/url][url="/_imported_xf_attachments/1/1403_ftpfail.JPG?:"]ftpfail.JPG[/url]



  • I ran into this issues for a couple of hours. I actually found that SELinux turned back on since it wasn’t disabled in the start up config. For anyone that has more issues with the error above try the command sestatus if enforcing follow this page [url]http://www.crypt.gen.nz/selinux/disable_selinux.html[/url]



  • so I checked the IP storage node and this particular ip address is completely unblocked for everything. As for the version of VSFTPD it is 3.0.2-1ubunt/amd64



  • [quote=“Tom Elliott, post: 37394, member: 7271”]First, make your fog user password something simple for you to remember.

    [code]sudo passwd fog[/code]

    Go to FOG GUI->Storage Management->All nodes-><your relevant node>->Management username and password.

    Management password should be that of the password you set for the fog user.

    All Done!

    Ensure that rights are proper:
    [code]sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chown -R fog:root /images
    sudo chown -R 777 /images[/code]

    Enjoy the freedom.[/quote]

    Thank you Tom! This fixed it for me (I think). I’m not in my office today to check, but i remoted in and did all of the commands, rebooted, logged into FOG gui and listed image management. Before it would take about 2 minutes to list the images (im assuming because the passwords were wrong). But it loaded right up and now doesn’t list the ftp error! So I am assuming it will work now. I will confirm monday but thanks for the prompt response. The one thing I still notice is the images inside the images folder still have the lock symbol on them but i dont know if that is an issue or not. I just don’t know why i had the error in the first place because I set the virtual server up identically to the existing one. Must have missed something somewhere. Thanks again!


  • Senior Developer

    Is the IP of the related storage node correct, and is the firewall disabled?

    What version of vsftpd are you running?



  • It is not happening during an upload (That I know of yet) but it is occuring on the image management screen and yes it says that same thing on all of the images.


  • Senior Developer

    So is this occurring on all your images? Or only certain images?



  • Yes I did


  • Senior Developer

    Did you set the fog user password?



  • So I am also having this issue and I have checked my passwords everywhere as well as doing the sudo passwd fog and the touch commands as well. I have also changed it to what is under the [FONT=Ubuntu][COLOR=#555555]FOG_TFTP_FTP_PASSWORD. I have gone in and changed it in a couple of files and I still can’t get this to work under image management. [/COLOR][/FONT]



  • I knew someone over here would have the answer.


  • Senior Developer

    First, make your fog user password something simple for you to remember.

    [code]sudo passwd fog[/code]

    Go to FOG GUI->Storage Management->All nodes-><your relevant node>->Management username and password.

    Management password should be that of the password you set for the fog user.

    All Done!

    Ensure that rights are proper:
    [code]sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chown -R fog:root /images
    sudo chown -R 777 /images[/code]

    Enjoy the freedom.


Log in to reply
 

358
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.