Bad IP address somewhere in config?

  • Hey guys

    I’m trying to learn how to set up fog and get more familiar with linux at the same time so I’m trying to deploy a FOG server both at home and work. I’ve run into more issues than I care to list, but I finally have everything (almost working).

    My current build that I am playing with is on Ubuntu 13.10 and FOG 0.32 (I have another vm I am trying to get working with FOG 1.2.0, but that’s another story) and with the DHCP options set, I have no problems getting clients to pxe boot from the fog server and run inventories etc.

    The problem I seem to be running in to now is that when I am trying to upload an image, the client computer is trying to route to the host with an IP address of in an attempt to mount the file system - which is setting off an alarm bell for me, because the IP of the fog server is! So after working my way through various config files I’ve found numerous references to this IP address (still not sure where it’s picking it up from) but it still produces this error.

    So I am convinced at some point this IP address has worked it’s way into a config file which I have not been able to find and has been preventing image uploads from working, this would also presumably affect image downloads too, but I haven’t been able to try that yet.

    The files I have verified and corrected IP addresses in are: /tftpboot/pxelinux.cfg/default and /var/www/fog/commons/config.php - but it would appear that I am still missing one. I imagine it’s a rather simple one to fix and I just don’t know where to look.

    Can someone point me in the right direction please? Thanks!

  • Excellent! That is where the errant IP address was residing. I hadn’t thought to look there, thanks!

    After that, the job still failed even after rebooting the server. Deleting the image and then re-creating it and restarting the task allowed this to run as it was intended. Thanks!

    If only all the problems I encountered were so easily resolved. Thanks again.

  • This, sounds to me, like a problem with the storage node IP configuration in the GUI.

    Go to Storage Management Page, show all nodes and select the relevant one. I’ll guess your IP in there is still set to