"Scheduled Date is in the Past" When Scheduling Jobs



  • Okay, maybe this is just me being stupid, but it seems to keep happening with different machines, so here we go:

    I’ve been testing the functionality of the scheduled jobs with Fog. (Using build 2031 on Ubuntu 13.10)

    They aren’t working.

    Yesterday, I scheduled a job to run after hours. Just scheduling it was a pain. I set it to go at 18:00 hours. I received a “Upload task failed to create for <machine name> with image <image name>. Scheduled date is in the past. Date: 2014/23/09 18:00”

    So I scheduled it for 19:00 hours, and this time it worked. I noticed that there was an 18:00 hour one scheduled on “Not active, delayed”. I deleted that.
    Came in this morning, the job never ran. Now that one was set to “Not active, delayed.”

    Deleted that.

    Now I decide this morning I need to test this feature to see if it will work.

    So, I prepare to upload an image. The machine is all prepped.

    I go to schedule the job for 5 minutes from now.

    I get the message again:

    “Upload task failed to create for <machine name> with image <image name>.
    Scheduled date is in the past. Date: 2014/24/09 09:50”

    I scheduled the job at 09:45.

    I checked the linux box system time. It’s correct.
    The date is correct.
    It’s the correct time zone.

    If I look at the Fog homepage, the “bandwidth-Transmit” graph appears to be showing the correct time.

    Now, I tried to schedule this for different times.

    It’s currently 9:58 AM.

    I tried scheduling for 10:05 - I get the same error.
    10:10 – same error.
    10:30 – same error.
    11:01 – same error.

    Tomorrow: It works.
    Today at 18:01 – It works.
    Today at 13:02 – error
    Today at 14:03 – It works.

    I’m confused.



  • Yup. That worked. Thanks, Tom!



  • You’ve got to be kidding me.

    Two stupid mistakes.

    I edited the /etc/php5/apache2/php.ini file, never uncommented it.
    Didn’t do the /etc/php5/cli/php.ini file.

    Let’s see how this works…

    [quote=“Tom Elliott, post: 36977, member: 7271”]It’s likely your /etc/php5/apache2/php.ini AND/OR /etc/php5/cli/php.ini date.timezone settings.

    If they’re not set, it defaults the timezone to GMT/UTC which, sounds like you’re on EDT?[/quote]


  • Senior Developer

    It’s likely your /etc/php5/apache2/php.ini AND/OR /etc/php5/cli/php.ini date.timezone settings.

    If they’re not set, it defaults the timezone to GMT/UTC which, sounds like you’re on EDT?



  • Okay. Here’s some more information.

    I just uploaded the image in real time. The upload completed less than 5 minutes ago. It’s currently 11:06 AM.

    When I check the Image Management page, it states that the images was uploaded today at 3:04 PM.

    Something is screwy with the time somewhere.


Log in to reply
 

433
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.