Dell Latitude 10 Tablet is Not able to PXE Boot



  • Hi all,

    I have been having issues with trying to get some Dell Latitude 10 tablets to PXE boot from Fog. Currently I am working on getting our Fog ver 1.2.0 up and running with our current hardware. Unfortunately, I have been running into issue with these devices. What happens is that I get the devices to pxe boot through the dock, the device gets an IP, then proceeds to download the pxe file (undionly.kpxe, ipxe.pxe, snponly.efi, etc etc…) the last thing that is shown on the screen is “Succeeded to download the NBP file” it then just goes straight into loading Windows.

    So far the only thing I have tried is downloading all the files located here —>[CODE]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp[/CODE] I have tried getting the tablets to boot to all of these with no avail…

    To possible help you help me a little background info on these stinky tablets are, they are 32bit UEFI only device (no legacy boot), they have to be docked in order to pxe boot, so far the only thing that it would pxe boot to is WDS server 2012 or 2012 R2.

    Any help would be much appreciated, thanks

    Screenshot below

    [ATTACH=full]1371[/ATTACH]

    [url="/_imported_xf_attachments/1/1371_PXE Screenshot.png?:"]PXE Screenshot.png[/url]



  • Go here: [url]https://rom-o-matic.eu/[/url]

    Click Advanced, at the bottom choose “EFI PXE Bootstrap 32-bit (.efi)”

    These are the options I always check:

    [SIZE=12px][FONT=Arial][COLOR=#000000]CPUID_SETTINGS[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]DOWNLOAD_PROTO_NFS[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]IMAGE_PNG[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]PARAM_CMD[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]CONSOLE_CMD[/COLOR][/FONT][/SIZE]

    Finally, plop this script in the iPXE script box (remember to change the last line to match your FOG server’s IP or hostname:
    (the colour and cpair lines are optional, I use these for my menu colors. Simply remove them if desired.)

    #!ipxe

    colour --basic 2 7
    cpair --foreground 7 --background 9 1
    cpair --foreground 0 --background 9 2
    dhcp
    set arch i386 ||
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [url]http://x.x.x.x/fog/service/ipxe/boot.php##params[/url]

    Note: With the 32-bit tablets I UEFI PXE boot with, I have to manually set the arch to i386 in this script because they are technically 64-bit capable and FOG detects this and gives them bzImage/init.xz, but they only work with bzImage32/init_32.xz.


Log in to reply
 

461
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.