Problem booting to PXE



  • Hi all,

    I’ve just recently come across Fog and thought I’d play about as we need a decent imaging solution!

    I’ve got it setup on a virtual machine and for the most part it appears to be working okay.

    web interface is working fine.

    I’m able to run tftp get <ip> undionly.kpxe successfully.

    I’ve added the following entries on the DHCP server: 66: <ip> 67: undionly.kpxe

    Server is running on latest Ubuntu. Fog is latest installation.

    The problem I’m encountering is when I try booting from PXE on a client machine (Dell OptiPlex 7010 / several other models of Dell) it is getting as far as “tftp …” then times out eventually as if it isn’t seeing the TFTP server.

    Any assistance would be amazing.

    I’m not very familiar with Linux at all so beginner talk please!

    Thanks,

    Paul



  • If you haven’t already, run:

    [CODE]sudo service tftpd-hpa restart[/CODE]



  • Ah I see -

    It displays the local machines IP / MAC but not the IP of the TFTP server.


  • Senior Developer

    When I say getting and IP, I’m referring to the TFTP… screen, not in general. It seems, to me, that this is where your problem lies. I don’t know your network layout so I can’t be any more help than asking for vague questions every now and again.



  • Hi guys,

    Anyone able to help with this?

    Thanks,



  • Hi Tom,

    The server IP is static. (Obviously!)

    The client PC I’m using as a test for the PXE boot is receiving an IP via DHCP and yes it is within the scope and able to communicate with the FOG server.

    Paul


  • Senior Developer

    THe tftp… tells me it’s not even making it to request the files.

    Does the system receive an IP address?

    Does the system receive an IP Address within the range specified and accessible to your fog server?



  • [quote=“Tom Elliott, post: 36793, member: 7271”]Have you disabled firewall?

    [code]sudo ufw disable[/code][/quote]

    Hi Tom,

    Sorry - forgot to include that.

    Yes I have disabled the firewall.

    Thanks,

    Paul


  • Senior Developer

    Have you disabled firewall?

    [code]sudo ufw disable[/code]


Log in to reply
 

736
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.