Created by FOG Reg date is always wrong



  • I have an issue that I am having a hard time resolving. When registering a host, in the host description the server normally puts: Created by FOG Reg on September 4, 2014, 9:03 pm

    For me this date is always wrong, usually 12 to 24 hours in the future. Is there any way to correct this?

    The time on my fog server is correct (It is a zentyal PdC so incorrect time would prevent windows domain users from logging in)



  • That worked! the correct time is now being shown.



  • Thanks for the repsonse Tom!

    I am going to modify the PHP.ini files as suggested and restart apache2. I’ll deploy another image and see if the date is correct then post back here the results.

    Thanks again!


  • Senior Developer

    It either one or the other on the time difference. There should be no in-between. It’s also going to be a certain amount of time ahead or behind your “server” time by a specific amount. Where are you located?

    Based on what I can tell, php does not have a date.timezone set so it’s putting the time to that of GMT, or should be at least.

    If you’re really worried about the timing itself, set the /etc/php.ini date.timezone setting to that of your Local timezone. In ubuntu, you’ll likely need to change both files dealing with php in /etc/php5/apache2/php.ini and /etc/php5/cli/php.ini


Log in to reply
 

473
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.