DHCP: PXE - E53 No Bootfile found



  • I need some help with an issue I am having trying to PXE boot my clients PCs. I am running Ubuntu 12.04 LTS and Fog 1.2.0. I have fog running successfully on a different server I created with Ubuntu 14.04 LTS, but it is under deep instruction to not upgrade or wipe the server I am working on now. I am unsure why I am receiving this error because I have the settings exactly the same as the server I have working (but it is not powered on now). I am not able to touch the DHCP servers, but I know they work because I have fog successfully set up on the other server. Any guidance would be greatly appreciated because I really want to solve this problem. Thanks.


  • Developer

    I don’t think your NIC is the issue. I use the same model of NIC in my fogserver and I do not have issues.

    It is very odd the issue you are facing, please check on our discussion in your inbox.



  • My working fog server is using fog 1.2.0 on ubuntu 14.04 . The server I am not creating is an exact replica in the settings, so I am confused as to why I am running into this problem. It may be hardware because my nic is realtek and I heard a lot of issues with realtek nics and linux. Not really sure. Any guidance is appreciated. Thanks.


  • Senior Developer

    When you were able to create a “working fog server” what version of fog where you using?

    I ask this because if it was 0.32 that was working, your Scope Option 67 is probably looking to get pxelinux.0



  • [quote=“Jaymes Driver, post: 36692, member: 3582”]Personally, I would use the DNSMasq and stop messing with the scope and dns settings. DNSMasq works in such a way it only issues ips to machines looking to PXE boot so it won’t work like a DHCP server. And best of all, when you pull the fog server, nothing else in your network is affected.

    DNSMasq is made so that users that don’t have the ability or the know how to edit the scope and DNS settings can still use some of the services.

    I’m not saying your settings are wrong in any way. I had all my settings correct and STILL met proxy boot issues, particularly the Error you are experiencing.

    I work in a Novell environment, Novell Netware 6.5 to be exact, which has strict limitations on a boot file name. In order to use the undionly.kpxe in fog I had to set up and enable DNSMasq to get my network to resolve my boot file and server. I had to do this for a number of reasons other than just Novell’s limit too. I have other technicians in my network that use WDS to image. Except their settings override mine. I also have IP helpers in my network, that override my boot settings that are set up for the WDS. DNSMasq has proven to be a wonderful solution many times worth it’s weight in gold. I know you want to save it for the last ditch effort, personally, I would be using it FIRST before I tried anything else (after of course adding my boot file and server to the scope and dhcp settings.)

    Either way, Good luck and I hope you solve your issue.[/quote]
    Another thing that I wanted to add is that I do have the ability to tftp the undionly.kpxe file from the client pc and also on the server. I don’t know if that means anything, but just wanted to acknowledge that I can do that. Thanks



  • [quote=“Jaymes Driver, post: 36692, member: 3582”]Personally, I would use the DNSMasq and stop messing with the scope and dns settings. DNSMasq works in such a way it only issues ips to machines looking to PXE boot so it won’t work like a DHCP server. And best of all, when you pull the fog server, nothing else in your network is affected.

    DNSMasq is made so that users that don’t have the ability or the know how to edit the scope and DNS settings can still use some of the services.

    I’m not saying your settings are wrong in any way. I had all my settings correct and STILL met proxy boot issues, particularly the Error you are experiencing.

    I work in a Novell environment, Novell Netware 6.5 to be exact, which has strict limitations on a boot file name. In order to use the undionly.kpxe in fog I had to set up and enable DNSMasq to get my network to resolve my boot file and server. I had to do this for a number of reasons other than just Novell’s limit too. I have other technicians in my network that use WDS to image. Except their settings override mine. I also have IP helpers in my network, that override my boot settings that are set up for the WDS. DNSMasq has proven to be a wonderful solution many times worth it’s weight in gold. I know you want to save it for the last ditch effort, personally, I would be using it FIRST before I tried anything else (after of course adding my boot file and server to the scope and dhcp settings.)

    Either way, Good luck and I hope you solve your issue.[/quote]
    Hello Jaymes,

    All honesty, I do want to use the DNSMasq, but I am not a professional by any means with Linux so creating something to be used for Fog makes me nervous because it is just something else that can go wrong. In addition to the guide, could you give me extreme specifics for creating the DNSMasq and then I will create it and use it because I am extremely fed up with this at this point. Thanks.



  • [quote=“Junkhacker, post: 36687, member: 21583”]did you install a desktop or server version of Ubuntu?[/quote]
    So I tried something different and did a fresh install of Ubuntu 14.04 LTS desktop and then installed fog 1.2.0 and after I confirmed that all of my settings are the same as my previous server, I am still getting No Bootfile error. I know, use DNSMasq, and I am about to, but right now I want to figure out why one works perfectly, but the other does not. Any ideas, or show me how to proper link the tftpboot to that location as listed above would be greatly appreciated. Thanks everyone for your help with my issue. I really do appreciate everyone’s help.


  • Developer

    Personally, I would use the DNSMasq and stop messing with the scope and dns settings. DNSMasq works in such a way it only issues ips to machines looking to PXE boot so it won’t work like a DHCP server. And best of all, when you pull the fog server, nothing else in your network is affected.

    DNSMasq is made so that users that don’t have the ability or the know how to edit the scope and DNS settings can still use some of the services.

    I’m not saying your settings are wrong in any way. I had all my settings correct and STILL met proxy boot issues, particularly the Error you are experiencing.

    I work in a Novell environment, Novell Netware 6.5 to be exact, which has strict limitations on a boot file name. In order to use the undionly.kpxe in fog I had to set up and enable DNSMasq to get my network to resolve my boot file and server. I had to do this for a number of reasons other than just Novell’s limit too. I have other technicians in my network that use WDS to image. Except their settings override mine. I also have IP helpers in my network, that override my boot settings that are set up for the WDS. DNSMasq has proven to be a wonderful solution many times worth it’s weight in gold. I know you want to save it for the last ditch effort, personally, I would be using it FIRST before I tried anything else (after of course adding my boot file and server to the scope and dhcp settings.)

    Either way, Good luck and I hope you solve your issue.


  • Developer

    did you install a desktop or server version of Ubuntu?



  • I tried to link the /tftpboot folder to /var/lib/tftp using:
    ln -s /tftpboot /var/lib/tftp
    I still receive the same error message. Did I link the folder properly? Haven’t had to do that before so just researched it and that’s what it said to do to link.



  • [quote=“Tom Elliott, post: 36661, member: 7271”]Have you attempted to use tftp command line to see if you can even receive the file?

    Have you verified that firewall (ubuntu usually defaults to ufw, fedora 20+/centos 7 seem to use firewalld, iptables is flushed and disabled?) Have you ensured selinux (only relevant from what I can tell on RedHat based distros) is disabled and disabled properly? (Meaning verified with sestatus)

    Have you tried linking the tftpboot to /var/lib/tftp? (For some reason, some distro’s are really pushing to put the files here now.)[/quote]
    Hello Tom,

    Thank you for your help. I have disabled ufw, but I did notice an SELinux folder on the computer, which I did not have on my Ubuntu 14.04 LTS that I have set up for my other fog server. I did the steps to disable SELinux, but not sure how to check because when I type sestatus it says it is not installed. I will try linking the tftpboot to /var/lib/tftp and see if that works (crossing my fingers) and get back to let you know if it works. Thanks everyone for the help!



  • [quote=“Jaymes Driver, post: 36640, member: 3582”]LordRaptor333 I have been able to alleviate this issue in my environment by using DNSMasq to help to resolve to my boot file and server.

    My recommendation is in the link below:
    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]

    This helps to solve issues when you can get the boot files on the client but they fail to load the boot file during pxe booting. Hope this helps!

    however, there are some threads on this forum that are tailored towards the error you are experiencing and Ubuntu 14 because they decided to change where some core files are stored. You may want to search for those threads (sorry I don’t know what they are off the top of my head.)[/quote]
    I appreciate the helpful advise Jaymes. I had thought about using DNSMasq, but I feel that the network settings has to be right because I have one working server using Ubuntu 14.04 LTS working no problem (but there were some troubles getting it started). The server I am creating now is using Ubuntu 12.04 LTS and my boss does not want me changing anything on it, so I have to work with what I got. I will use the DNS Masq as a complete last resort, which is coming the more I work on this POS. Thanks.



  • [quote=“gwhitfield, post: 36639, member: 344”]I struggled with this for a few hours today only to find out that the bootfile options on my DHCP server (WIN2008) had been set in both the Server Options [U][I][B]AND[/B][/I][/U] in the Scope Options fields. I have never needed to specify Scope Options so I didn’t even look in there, but once I did I saw they were the old settings. Once I removed the Scope Options settings (simply to reduce the duplication), everything worked as expected.[/quote]
    Unfortunately, I am not able to touch the DHCP server, so I am unable to check any of the settings. All I know is that it must be set up correctly because I was able to create one working fog server. Thanks.



  • [quote=“Junkhacker, post: 36637, member: 21583”]is the client going through the same network equipment that was working with the old server? could there be any difference in the network configuration?[/quote]
    No. The new server has different hardware than the working server, but nothing extravagant that I know of that would disrupt the networking. I had no problem installing fog and as I stated, the network setup is completely the same. Is there something different with 12.04 LTS to 14.04 LTS that may be causing this problem? Just a thought.


  • Developer

    Thank you Tom this line was the one i was looking for
    [code]
    Have you tried linking the tftpboot to /var/lib/tftp? (For some reason, some distro’s are really pushing to put the files here now.)[/code]


  • Senior Developer

    Have you attempted to use tftp command line to see if you can even receive the file?

    Have you verified that firewall (ubuntu usually defaults to ufw, fedora 20+/centos 7 seem to use firewalld, iptables is flushed and disabled?) Have you ensured selinux (only relevant from what I can tell on RedHat based distros) is disabled and disabled properly? (Meaning verified with sestatus)

    Have you tried linking the tftpboot to /var/lib/tftp? (For some reason, some distro’s are really pushing to put the files here now.)


  • Developer

    LordRaptor333 I have been able to alleviate this issue in my environment by using DNSMasq to help to resolve to my boot file and server.

    My recommendation is in the link below:
    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]

    This helps to solve issues when you can get the boot files on the client but they fail to load the boot file during pxe booting. Hope this helps!

    however, there are some threads on this forum that are tailored towards the error you are experiencing and Ubuntu 14 because they decided to change where some core files are stored. You may want to search for those threads (sorry I don’t know what they are off the top of my head.)



  • I struggled with this for a few hours today only to find out that the bootfile options on my DHCP server (WIN2008) had been set in both the Server Options [U][I][B]AND[/B][/I][/U] in the Scope Options fields. I have never needed to specify Scope Options so I didn’t even look in there, but once I did I saw they were the old settings. Once I removed the Scope Options settings (simply to reduce the duplication), everything worked as expected.


  • Developer

    is the client going through the same network equipment that was working with the old server? could there be any difference in the network configuration?



  • I also wanted to add that I can tftp the undionly.kpxe file on the server and off the client. If that provides any help with my issue. Thanks.


Log in to reply
 

863
Online

38955
Users

10706
Topics

101578
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.