Clone upload fails with "Invalid Partition Data" error.

  • I ran into this problem on the very first laptop I tried to create an image from. The system stalled at “using hard drive /dev/sda” and using the debug upload option I got an interesting error that I could find no reference to in the forums.

    I don’t remember the exact error message but I do know that it referenced “invalid partition data” and not “invalid partition table”.

    It turns out this error is caused but installing an MBR on a GPT drive which left a damaged GPT table (partially overwritten), and while Windows 7 will happily ignore it, FOG will not. Since I needed to get an image from this machine I booted up into Clonezilla, who also balked at this error, but did give me the fix. Dropping down to the console I performed a sgdisk -z /dev/sda, which removes the GPT partition table without touching the MBR (YMMV). Now this does have a chance of resulting in some data loss, in my case it worked perfectly. After that it was smooth sailing with FOG.

    Just thought I would share my experience in case anyone else runs ito this issue.

  • Thanks for posting, saved me lots of time 🙂

  • Thanks Liam, actually helped us out a lot.