Gandalf's Win8.1u1 x86 PE



  • I can boot and run every .ISO I use under FOG 1.2.0 svn2250, except the x86 version of Gandalf’s PE. ( [url]http://windowsmatters.com/tag/winpe/[/url] ).

    After caching the .iso, the PE throws up an error ( status: 0xc0000017 ). Strangely the x64 version which is 50% larger, works without issue.

    It’s been a busy summer, but I’m fairly certain I successfully tested this version of the x86 .iso on Fog 0.32 … or I might just be loony.

    My 1.2.0 FOG PXE Boot Menu Configuration / Advanced Configuration Options entry:

    menu
    item --gap – ------------- iPXE Boot Menu -------------
    item PE31 Boot PE 3.1 x86 (Win7)
    item PE40 Boot PE 4.0 x86 (Win8.0)
    item PE50 Boot PE 5.0 x86 (Win8.1)
    item GANDALF32 Boot Gandalf’s PE 5.1 x86 (Win8.1u)
    item GANDALF64 Boot Gandalf’s PE 5.1 x64 (Win8.1u)
    item SHELL iPXE Shell
    item IPXEDEMO iPXE Online Boot Demo
    item RETURN Return to the Top Menu
    choose --default PE50 --timeout 300000 target && goto ${target}

    :PE31
    imgfetch [URL]http://${fog-ip}/iso/winpe31_x86.iso[/URL]
    boot memdisk iso raw ||
    goto MENU

    :PE40
    imgfetch [URL]http://${fog-ip}/iso/winpe40_x86.iso[/URL]
    boot memdisk iso raw ||
    goto MENU

    :PE50
    imgfetch [URL]http://${fog-ip}/iso/winpe50_x86.iso[/URL]
    boot memdisk iso raw ||
    goto MENU

    :GANDALF32
    imgfetch [URL]http://${fog-ip}/iso/Gandalf_Win8.1uPE_x86v3.iso[/URL]
    boot memdisk iso raw ||
    goto MENU

    :GANDALF64
    imgfetch [URL]http://${fog-ip}/iso/Gandalf_Win8.1uPE_x64.iso[/URL]
    boot memdisk iso raw ||
    goto MENU

    :SHELL
    shell ||
    goto MENU

    :IPXEDEMO
    boot [URL]http://boot.ipxe.org/demo/boot.php[/URL] ||
    goto MENU

    :RETURN
    boot [URL]http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac[/URL]} ||
    prompt
    goto MENU

    autoboot
    [/CODE]

    BTW, the .iso files are stored in /var/www/html/iso . I’ve reproduced this condition on multiple machines with up to 8GB memory.



  • NVM. It appears I’m not the only one with issues with the latest Gandalf. At least I got to share my iPXE Advanced Boot Menu configuration. :)


Log in to reply
 

438
Online

38940
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.