Fog 0.32 unable to start replicator service



  • Hello,

    I have attempted to install a second storage node on one of my FOG servers and the replicator, multicast manager, and scheduler services are not running on my main FOG server. I have change the interface from eth1 to eth2 which I believe has something to do with why those services are now running. I went through every config file I can think of to change the interface from eth1 to eth2 but I still cannot get those services to start so that the FOG server can replicate my images to the storage node.

    Version of FOG is 0.32 and no immediate plans to update

    Thanks in advance for any help you can provide .



  • Confirmed my main FOG server can replicate to my storage node now. Thanks again everyone for your help I’m glad the solution was simple.



  • I did what you suggested Mentaloid and I immediately got a permission denied error, I applied the permission octal code 0755 to directories and set the permissions recursively and restarted my FOG server and now those services are starting up. For some reason the octal code was set to 0644.

    I now have the TTY 2 ,3 and 4 screens. I will now retry to connect my second storage node



  • This sounds a lot like the services are crashing before any logs are output. When they crash or exit unexpectedly, the output is masked by start-stop-daemon, and goes into the “black hole”.

    What happens if you manually run the services like so… (these do not background when run like this… if successful, you will not see any output, they will appear to just sit there. Control+Z to suspend, then bg to send to background)
    [code]
    sudo /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    {Control+z}
    bg
    sudo /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    {Control+z}
    bg
    sudo /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    {Control+z}
    bg
    [/code]
    Any errors?



  • When I start the services I don’t notice any changes especially the log files or the other TTY screens appearing, it’s like they load into a black hole somewhere never to be seen again. I was hoping to find a log file somewhere that will note any information regarding the startup of the services so that I may track it down easier… like I said earlier, I had to change the NIC on the main server which may have caused this issue which so far is only a theory.

    I have attempted the re-install of FOG and it has not changed anything and I’m hesitant to do a SVN or regular upgrade to the 1.2 version. I experimented upgrading 0.32 to version 1.0.x versions and my results were OK, but I noted some challenges and will mean a few changes on our backend like DHCP options is required.

    I did meet with my supervisors yesterday afternoon and we are discussing some changes on how we are managing the FOG servers and we will look into the newer releases of FOG sometime in June 2015. Right now I’m observing other forums regarding the best combinations for new FOG releases and the OS distro/version to use.



  • I see that services were not running when you run the stop command.
    Does it change something after you started them manually ?

    When i have strange things, i run install.sh and fog takes it as an update (no db drop or image deleted).
    In fact, i do it for each new svn version.
    Maybe this could fix something ?



  • here’s the text output of that command

    root@cec-fog:~# php -v
    PHP 5.3.10-1ubuntu3.13 with Suhosin-Patch (cli) (built: Jul 7 2014 18:52:09)
    Copyright © 1997-2012 The PHP Group
    Zend Engine v2.3.0, Copyright © 1998-2012 Zend Technologies
    root@cec-fog:~#


  • Senior Developer

    What version of PHP are you running?

    Run from a terminal:
    [code]php -v[/code]



  • Hi Tom, Attached a zip file of the logs you requested including a screen shot (well a text output of my putty session) of the commands you suggested I run…

    I have look around the forums and even google searching the issue and so far nothing comes up why the services don’t start or stay running and usually the ones I do find already have the log files available for troubleshooting which of course is not true in my case. the TTY2, 3, and 4 screens aren’t available either and they show up fine on my other FOG servers I have setup with storage nodes. I typically use the Ubuntu 12.0.4 LTS server install 32bit or 64bit OS and the 0.32 FOG installer on my installations. The server I’m having trouble with is a 32bit version.

    I also have redone this particular server from scratch last week, and restored the images and database on it and still have the same issue… perhaps an issue with the MYSQL database?

    The server does fine with all other functions, downloading and uploading images and running snapins.

    [url="/_imported_xf_attachments/1/1333_zipfile of logs of 0.32 main FOG server.zip?:"]zipfile of logs of 0.32 main FOG server.zip[/url]


  • Senior Developer

    What happens if you run:
    [code]sudo service FOGMulticastManager stop
    sudo service FOGImageReplicator stop
    sudo service FOGScheduler stop
    sudo service FOGMulticastManager start
    sudo service FOGImageReplicator start
    sudo service FOGScheduler start
    updatedb
    locate fogreplicator.log[/code]



  • No results with that command.



  • I’m under 1.2 and log should be somewhere else.
    Try to find it with this command :

    [CODE]
    locate fogreplicator.log
    [/CODE]



  • There are no logs in that directory,



  • All logs should be in /opt/fog/log/



  • I managed to figure out how to set my network adapter to use eth1 instead of eth2, still no luck with starting the services. can anyone point me to a log file where linux will store events regarding the service startups for the services [FONT=arial][COLOR=#222222]FOGImageReplicator, FOGMulticastManager, and FOGScheduler[/COLOR][/FONT]



  • This issue is with my FOG server and storage node at one of my sites I support, I done this at other sites just fine but the difference is that I had to replace the network card in the FOG server so now the interface is eth2 and not eth1 and I think that is causing the services to fail on stop up and manual attempts to start any of the 3 services have been unsuccessful. I switched the network card before I added the storage node so I never suspected I might have a config problem. I can register and image computers just fine however.

    I have set the storage node under the same storage group.

    The TTY 2, 3, and 4 screens are not available on the master FOG server.



  • Hello,

    I’m not sure if you have 2 servers now or just a fog server with a node storage.

    Yesterday, I have added my fog 1.2 as new storage under my old fog 0.32 to do a replication and it worked fine.
    I learn from Tom that it’s the master that send image. I was thinking it was working also the other way (that the slave will retrieve the image) but it doesn’t.

    Are they in the same group and the server as master ?
    If you have two server like me, it must be configurated on the server that have the image.

    You can also check TTY 3 and look what is write about the replication or stop and restart the replicator service and see if this change anything :

    [FONT=arial][COLOR=#222222]Sudo service FOGImageReplicator stop[/COLOR][/FONT]
    [FONT=arial][COLOR=#222222]Sudo service FOGImageReplicator start[/COLOR][/FONT]



  • This post is deleted!

Log in to reply
 

366
Online

38982
Users

10712
Topics

101679
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.