Setting up fog on small network



  • Hello all, i am new to FOG. i was hopping i could get some help with this.

    i probably should have searched more for information about this before creating a new thread and i am sorry. but i am short on time and could really use the help.

    so i have installed FOG 1.1.2 on ubuntu 14.04

    i am looking to just set it up to image multiple PC’s over a switch. no DHCP or DNS server. i found the tutorial on how to install FOG on a small network. and i have done that. however when i am trying to PXE boot with the PC, it does not pull from the FOG server as it should.
    what am i doing wrong here? i want to be able to upload an image from a pc to the server, and then do multiple images down to PC’s.

    thank you all for any help that can be provided.



  • thank you. so it looks like there was a duplicate DHCP running. we found it and stopped it. now it works. thank you.

    also fixed the tftp ARP Time out that was occurring.

    so far this is fixed. I just need to get the image to upload correctly.



  • If this can help, here are my conf even if FOG should have doe it itself during install :

    /etc/dhcp/dhcpd.conf

    [CODE]
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.10.5;

    subnet 192.168.10.0 netmask 255.255.255.0 {
    interface eth1;
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 192.168.10.10 192.168.10.254;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 192.168.10.5;
    option routers 192.168.10.5;
    filename “undionly.kpxe”;
    }
    [/CODE]
    /etc/network/interfaces
    [CODE]
    auto eth1
    iface eth1 inet static
    address 192.168.10.5
    netmask 255.255.255.0
    network 192.168.10.0
    broadcast 192.168.10.255
    [/CODE]



  • As i did this only once and one month ago and all worked fine,
    maybe i’ll say ask or say things but i hope this would at least helpa bit to find what is not working.

    Are you sure that you don’t have an other DHCP on your network ?
    How your PC’s IP are configured then ? Are they all done manually ? Do you get IP from FOG DHCP under OS ?
    Is your FOG IP configuration is set as static ?



  • ok so looking more into this on the site, I am still not finding the answer I am looking for.

    I am trying to set up the fog server as the DHCP server. which throug the instructions I did. however the computer times out during PXE boot when looking for DHCP.

    what setting do I have incorrect? or am I missing?

    thank you for any help


Log in to reply
 

469
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.