Error While trying to Deploy Image - Partition outside of disk

  • Good Afternoon All,

    On our Fog Server (0.32) we have an image that was uploaded that we have used 6-7 times without issue. Now when I tried to deploy the image this morning, it is saying Hard Disk Error - Can’t have Partition Outside of Disk! I tried grabbing another pc (all of which are identical in hardware except HDD size, get to that in a minute) and it deployed perfectly fine, went back to the other pc and had same error again. The first pc with the error had a 160GB HDD in it, I switched it out with a brand new 250GB HDD still got the same error. The one I grabbed off the floor had a 320GB HDD in it and it is perfectly fine. Went back to the original pc and put a 500GB HDD in and now it is imaging fine? The entire FOG server is only 200GB so why does it require such a large disk? The Image settings are set on Multiple Partitions - Single Disk, is it trying to duplicate the partition sizes of the initial machine imaged? If so, is there a way I can change that so that a 160GB HDD will work instead of requiring at least a 320GB?

    Please let me know if you need more information.


  • Developer

    this is known and expected behavior. Multiple Partitions - Single Disk recreates the partition structure of the original image, and you can not create partitions on a drive that are larger then the drive can contain.
    the “way I can change that so that a 160GB HDD will work instead of requiring at least a 320GB” would be to use a Single Disk - Resizable image type, which shrinks the partitions to the smallest size possible for the data on the drive before pulling an image, then expands the drive to the full drive when downloading the image to a new computer.