Cant boot up after deploy linux ubuntu 12.04



  • hi all,
    first thanks to all of the hard working people to create this environment call FOG, its help so much to understand linux as well from being very good backup solution!! keep on !!!

    im not realy sure if its need to work!
    i deploy the image i just uploaded… so i make a test and it seems that all the data structure deployed OK - check with gparted live cd, and the system wont boot :(

    the upload process - want fine and my FOG version is 1.1.2 - on ubuntu server 12.04

    any help please
    thanks
    Nir



  • sorry for the late respond but i not trying to boot from PXE any more.
    i try to make it the first boot device and nothing change.

    only two things that work is to create an offline repository and then run the boot - repair process
    or
    [SIZE=14px][FONT=UbuntuRegular][COLOR=#333333]copy GRUB from [/COLOR][/FONT][/SIZE][COLOR=#222222][FONT=Ubuntu Mono][SIZE=14px]EFI/ubuntu/grubx64.efi[/SIZE][/FONT][/COLOR][SIZE=14px][FONT=UbuntuRegular][COLOR=#333333] to [/COLOR][/FONT][/SIZE][COLOR=#222222][FONT=Ubuntu Mono][SIZE=14px]EFI/BOOT/bootx64.efi [as published in [URL=‘http://askubuntu.com/questions/380447/uefi-boot-fails-when-cloning-image-to-new-machine]’]here[/URL]] [/SIZE][/FONT][/COLOR]
    but it will only boot from UEFI and not when i try to repair on legacy,

    what i need and want to try is to install fresh copy on legacy and then upload it with FOG, then i will try to deploy it on another computer and see…

    thanks Cadyfish and Tom

    hope that this post will help others

    Nir


  • Senior Developer

    What I’m telling you, is if you installed Ubuntu with UEFI enabled on the system, the problem is not grub, or boot-repair, or any of those things, it’s most likely, from what I can tell from the information you’re giving me, is PXE boot is currently booting through Legacy modes, when it tries to switch back to booting to the Hard disk, after PXE/iPXE has loaded, it’s causing your system to hang because there’s no MBR data on the disk to tell the system how and where to boot. If you make your Hard Disk the first boot device after imaging all should work.



  • Tom thanks for your post, i don’t think i explain myself good enough - i don’t have problem to boot from PXE from any computer and my FOG server works perfect !!

    my problem is that after backed up a computer with Ubuntu and i try to deploy it on another computer and it fail to boot to the operating system after the deploy task.

    i have search the net for best solution and i find that its a grub issue that fail because the image that i created is based on an installation of Ubuntu that installed on a computer with UEFI on the bios. [[url]http://askubuntu.com/questions/380447/uefi-boot-fails-when-cloning-image-to-new-machine][/url]
    and one of the solution is “boot-repair” that comes with live-cd, the problem is that the boot-repair task need access to the internet* to re-install the grub. [[url]https://help.ubuntu.com/community/Boot-Repair][/url]
    *i don’t have access to the internet in the clients

    so one thing lead to another and my wish is to fix or recreate the image in away that i can deploy it on any computer - and it will work without the need to repair anything

    thank again
    Nir


  • Senior Developer

    If you loaded the system in UEFI, you won’t be able to boot it if your first boot device is PXE. This is most likely because the NBP (Network Boot Protocol – aka PXE) is currently setup on your system to start up in legacy mode. You can’t boot UEFI systems from a starting point of Legacy booting.

    To test this, make your HDD the first thing to boot from in the BIOS, not the network. Your system should boot.



  • Hi, how can i explain more ??

    thanks in advanced
    Nir


  • Senior Developer

    What??



  • I try and it doesn’t change anything, the image that i build already build from Ubuntu that installed with UEFI and all of his configuration work with UEFI. so why changing the configuration in fog server change the image that i deployed ??



  • log into your fog web page and go to “Fog Configuration” (question mark) then click on “PXE Boot Menu” it is the last option change it and then click “Save PXE MENU”



  • OK
    Where I need to find exit to hard drive type ?



  • Disable UEFI by setting the computer to legacy mode in bios, and change the “exit to hard drive type” from I assuming “Sanboot style” to "Grub "



  • After deploying successful the machine restart and goes directly to black screen with the CLI curser blinking

    Host is Ubuntu 12.04.04 64bit desktop
    Hard drive structure is:
    sda1 - fat and boot flag
    sda2 - ext4
    sda3 - swap
    UEFI enabled on Bios
    The host can’t connect to the internet - its a close environment

    Thanks for your reply

    Nir



  • Could you give a more information on what it does when you try to boot? What OS are you deploying? Are you using legacy bios or UEFI?


Log in to reply
 

356
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.