IPXE help



  • [INDENT]Hello.
    I am working on using FOG to deploy images to a multi-building school campus. Our buildings are in different locations in the town and have different subnets ie; 10.50.14.x , 10.50.17.x, etc.
    I have run across a peculiar problem.
    I have the server installed in one building and can image to a different subnet that what it’s on (it’s 4 miles across town away, but it’s fiber so it works fast). I however cannot image computers in the same building as the server.
    The building it’s in has a subnet range of 10.50.8.x to 10.50.15.x, and I can image to another building that is 10.50.16.x to 10.50.24.x but not to the same subnet range that it resides on.

    I get an error message once iPXE starts going.

    "iPXE 1.0.0+ (8b294) etc etc
    configuring (net0 x:x:x:x:x:x)… ok
    could not start download: operation not supported ([url]http://ipxe.org/3c092003[/url])

    It makes no sense to me, but I am not a linux guy. I followed the instructions to chainload pxe to ipxe using pxelinux.0 and it made no impact. I formerly used clonezilla for imaging and never had any problems between subnets but it used pxelinux.0.[/INDENT]
    [INDENT]I am running FOG 2203, just installed it from the SVN[/INDENT]
    [INDENT]These machines are all the same model / bios revision, and I have tried reinstalling fog on various flavors of linux (ubuntu 10.x, 12.x, 14.x, and debian 7.6) and they all behave the same, except that ubuntu has issues with mysql not starting and the settings page link not working.[/INDENT]



  • Building A successfully gets DHCP addresses etc as well ?



  • Here is my log file of the current install if it helps.

    [url="/_imported_xf_attachments/1/1305_foginstall.txt?:"]foginstall.txt[/url]



  • option 66/67 are configured correctly (pointing at 10.50.10.98 (the FOG server)) and they are the same on both of my DHCP servers (one is a failover if the other goes offline, and on a different subnet). Is there anything more I should be putting in besides the IP address?


  • Senior Developer

    It could be something simpler maybe, but ip-helpers depend on the switching equipment you have.

    For your DHCP server, it’s handing out the undionly.kpxe telling the dhcp scope where to look at if it is pxe booted. Maybe the “Option 66/67” for your localized ip range does not point back to the fog server?



  • [quote=“Tom Elliott, post: 35584, member: 7271”]Sounds like your internal subnet needs to have the ip-helper’s setup to point back to that ranges DHCP scope as well.[/quote]

    How do I go about doing that?


  • Senior Developer

    Sounds like your internal subnet needs to have the ip-helper’s setup to point back to that ranges DHCP scope as well.



  • This is what a successful boot looks like before the FOG menu
    [ATTACH]1301[/ATTACH]

    [url="/_imported_xf_attachments/1/1301_IMAG0063.jpg?:"]IMAG0063.jpg[/url]



  • [quote=“madskillz23, post: 35558, member: 8206”]Are you sure its not a firewall issue between subnets?[/quote]
    It shouldn’t be. Our isp controls our firewall, but they allow this sort of traffic. That doesn’t explain whty it would work on external to it subnets and not it’s own.



  • Are you sure its not a firewall issue between subnets?



  • [quote=“cadyfish, post: 35555, member: 24458”]So I take it if “it was working before” you could image but you were having issues after deployment with the machine just boot looping through fog?

    Maybe try this post [url]http://fogproject.org/forum/threads/chainloading-ipxe.10915/[/url][/quote]

    No.
    I successfully imaged 30 machines in location B. They did exactly what they were supposed to and are currently running.
    I cannot get FOG to even start on the machines in location A (where the server is located). When the bios loads and starts getting the info from the server it fails to load something from iPXE. Here is a screen shot.
    [ATTACH]1300[/ATTACH]
    It never brings up the FOG menu

    [url="/_imported_xf_attachments/1/1300_image.jpg?:"]image.jpg[/url]



  • So I take it if “it was working before” you could image but you were having issues after deployment with the machine just boot looping through fog?

    Maybe try this post [url]http://fogproject.org/forum/threads/chainloading-ipxe.10915/[/url]



  • Yes working normally means every building but the one it is located in.
    Yes, I can ping the FOG server from the computers it’s failing on, and they have full connectivity. As does FOG .



  • [quote=“otomoton, post: 35545, member: 25704”] I had it working normally before I tried the chainloading work around. My DHCP server was already pointing to it and working great.[/quote]

    Just to clarify, when you say “working normally”, do you still mean every building EXCEPT the one its located in?

    I’m guessing computers in building A. can ping the FOG server, and have connectivity as well ?



  • Oh, I guess I wasn’t clear everything I did. I had it working normally before I tried the chainloading work around. My DHCP server was already pointing to it and working great. It works great in every building except the one it is located in. That is where I get the operation not supported error instead of the fog screen.

    I have buildings A, B, C, D, and E. Fog is in A. I can image computer successfully in B, C, D, E, but not in A.



  • otomoton,

    To test if dhcp is what is causing the issue run the following commands
    [CODE]sudo cp /tftpboot/undionly.kpxe /tftpboot/pxelinux.0
    sudo restart tftpd-hpa[/CODE]

    Then retry to connect your host if this resolves your issue it is due to a dhcp setting looking for pxelinux.0 and it cant find it. To resolve for future upgrades use this page to assist you to make the changes to point towards undionly.kpxe: [url]http://www.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG[/url]


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.