Ubuntu 14.04 Fog Server 1.20 - Download (Deploy) image issue



  • Thanks :)



  • Or you could install the fog latest version from code according to Tom this has been resolved:

    sudo apt-get install subversion
    svn checkout [url]http://svn.code.sf.net/p/freeghost/code/trunk[/url] freeghost-code
    cd freeghost-code/bin
    sudo ./installfog.sh

    I have been using one with version 2196 and a couple of others with 1.2



  • I set it to “Windows Vista” it still uploaded the same way. If it is just something with vista then I will go a head and try windows 7 at work. I am testing it for a windows 7 environment anyway. Hope that works better! :)



  • I know it was set to vista when I uploaded it. I will try changing the settings to see if it will change how it uploads. thanks


  • Senior Developer

    1.2.0 had a known issue with Vista images in specifics. The extra files are to be expected but I forgot about vista when recoding all of the things. I’m sorry. I believe it was fixed in 2096 or 2097 of the svn trunk though.



  • [quote=“Keifer, post: 35350, member: 25622”]Here is the results.

    foguser@fogserver:/$ ls -la /images/
    total 20
    drwxrwxrwx 5 root root 4096 Aug 13 20:50 .
    drwxr-xr-x 26 root root 4096 Aug 9 16:37 …
    drwxrwxrwx 2 root root 4096 Aug 13 20:50 dev
    -rwxrwxrwx 1 root root 0 Aug 9 16:18 .mntcheck
    drwxrwxrwx 2 root root 4096 Aug 9 16:18 postdownloadscripts
    drwxrwxrwx 2 root root 4096 Aug 13 20:28 vistatest2

    foguser@fogserver:/images$ ls -la vistatest2
    total 2718156
    drwxrwxrwx 2 root root 4096 Aug 13 20:28 .
    drwxrwxrwx 5 root root 4096 Aug 13 20:50 …
    -rwxrwxrwx 1 root root 2783365986 Aug 13 20:43 0800276c12c4.000
    -rwxrwxrwx 1 root root 1 Aug 13 20:28 d1.fixed_size_partitions
    -rwxrwxrwx 1 root root 15 Aug 13 20:28 d1.original.fstypes
    -rwxrwxrwx 1 root root 259 Aug 13 20:28 d1.original.partitions
    -rwxrwxrwx 1 root root 0 Aug 13 20:28 d1.original.swapuuids
    [EMAIL]foguser@fogserver:/images$[/EMAIL][/quote]

    Based on the .swapuuids it looks like your vistatest2 image operating system is set to linux instead of Windows Vista. Go into image management and change this and then re-upload. For a windows image you should see a d1.mbr file



  • [ATTACH=full]1295[/ATTACH] [ATTACH]1295[/ATTACH]

    [url="/_imported_xf_attachments/1/1295_FOG Server.png?:"]FOG Server.png[/url]



  • Here is the results.

    foguser@fogserver:/$ ls -la /images/
    total 20
    drwxrwxrwx 5 root root 4096 Aug 13 20:50 .
    drwxr-xr-x 26 root root 4096 Aug 9 16:37 …
    drwxrwxrwx 2 root root 4096 Aug 13 20:50 dev
    -rwxrwxrwx 1 root root 0 Aug 9 16:18 .mntcheck
    drwxrwxrwx 2 root root 4096 Aug 9 16:18 postdownloadscripts
    drwxrwxrwx 2 root root 4096 Aug 13 20:28 vistatest2

    foguser@fogserver:/images$ ls -la vistatest2
    total 2718156
    drwxrwxrwx 2 root root 4096 Aug 13 20:28 .
    drwxrwxrwx 5 root root 4096 Aug 13 20:50 …
    -rwxrwxrwx 1 root root 2783365986 Aug 13 20:43 0800276c12c4.000
    -rwxrwxrwx 1 root root 1 Aug 13 20:28 d1.fixed_size_partitions
    -rwxrwxrwx 1 root root 15 Aug 13 20:28 d1.original.fstypes
    -rwxrwxrwx 1 root root 259 Aug 13 20:28 d1.original.partitions
    -rwxrwxrwx 1 root root 0 Aug 13 20:28 d1.original.swapuuids
    foguser@fogserver:/images$



  • [quote=“Junkhacker, post: 35308, member: 21583”]the settings in [SIZE=2]/lib/fog/Config.class.php are not [/SIZE]relevant[SIZE=2] here, as the storage management section of that data has been moved to the database. the relevant settings to this are now found on the storage management page[/SIZE]

    [SIZE=2]there should be no need to re-register the host either[/SIZE]

    [SIZE=2]but i too would like to see the output of [/SIZE]ls -la /images/{image your trying to deploy}/
    [SIZE=2]and[/SIZE]
    ls -la /images/[/quote]

    Sorry for the miss information… Thank you for correcting me


  • Developer

    the settings in [SIZE=2]/lib/fog/Config.class.php are not [/SIZE]relevant[SIZE=2] here, as the storage management section of that data has been moved to the database. the relevant settings to this are now found on the storage management page[/SIZE]

    [SIZE=2]there should be no need to re-register the host either[/SIZE]

    [SIZE=2]but i too would like to see the output of [/SIZE]ls -la /images/{image your trying to deploy}/[SIZE=2] [/SIZE]
    [SIZE=2]and[/SIZE]
    ls -la /images/



  • Could you open up terminal and reply back with what shows up after the following to commands:
    ls -la /images/{image your trying to deploy/

    Also verify that the storage management page has the same settings for image location as in LN87 in /lib/fog/Config.class.php.

    If you changed these settings after a host was already registered I would also remove it and re-add



  • I have the images stored in the default directory “images” on the / of the drive. I have verified the path is the exact same. It actual list the image folder correctly on start of the pxe download. I have verified the is full rights to the image directory. This is a brand new install, all images were uploaded under 1.20.



  • Here are a couple things to check:

    -Are the images stored or mounted under /images?
    -Verify on the website Image Management tab the image location is exactly the same as the image path on the server
    -Run the following commands if not done so already:
    sudo chown -R fog /images
    sudo chmod -R 755 /images
    sudo chmod -R 777 /images/dev

    How were the images uploaded via 1.20 or .32 or earlier?


Log in to reply
 

496
Online

5.8k
Users

13.0k
Topics

123.1k
Posts