Ubuntu 14.04 Fog Server 1.20 - Download (Deploy) image issue



  • Hello,

    I have a Ubuntu 14.04 Fog 1.20 server and I have work through the directory rights issue and corrected my FTP login to download a image. Now I am getting a error soon as the image tries to download. It tells me “Image is a directory”. I tried to change the image type and it doesn’t help. I am working with this server in a virtualbox environment and vista virtualbox on a inside network.

    Any help you guys can give me would be great!



  • Update for everyone. I can Image Windows 7 just fine. Looks like it’s just Vista.



  • This post is deleted!


  • OK, I reuploaded the image from the client. The files are still showing in /images/dev/mac-address and nothing new has been added to /images. In other words, no LatitudeE5510 folder has been created. Any ideas?


  • Senior Developer

    That is correct.



  • Web UI says I am running version 2203. Is this correct?



  • OK, the script is done and I am logged back in now. Should I test an upload?

    What should I see in the file system as concerning the /images and /images/dev folders?

    Thank you!


  • Senior Developer

    Edit the file /opt/fog/.fogsettings

    Find the line that’s dealing with the IP and edit it. Save, rerun the installer.



  • When I try to run this script, it says that it will use my old IP address, not the current and correct one. How do I modify the script to put in the right IP? When I hit N for no, it exits.


  • Senior Developer

    Try:
    [code]svn co https://svn.code.sf.net/p/freeghost/code/trunk fog_svn
    cd fog_svn/bin
    ./installfog.sh[/code]



  • Sure. At this point, I will try anything.


  • Senior Developer

    Would you be willing to update to a later svn revisions to see if things start working for you?



  • No sir, it is Windows 7. Sorry for not putting that in.


  • Senior Developer

    Is this a Vista image?



  • I am having a similar issue here in that I upload an image, but I can’t download/deploy it. Last Friday when I tried, I attempted download, but teh old image deployed, even after deleting the files (I thought_ in the web portal. Today, I deleted the image and checked the box to delete files, so I could reupload. When I console into the server, I still see the files in /images/LatitudeE5510 which is where it says the image should be. This time I deleted through the web portal, then went in via SSH and removed the files and the directory inside /images. I double checked using ls command and the directory was gone. So I reuploaded my syspreped image after creating it again. Now when I go to deploy the image, it says it can’t find the image store. The LatitudeE5510 directory has not been created inside /images.

    I did not previously know about the /images/dev directory and when I look inside there, I see several MAC addresses, one being my upload machine.

    Is something not moving these files where they should be or something? I had previously looked at the permissions and /images had group and owner and everyone having read/write acccess.

    Just wondering where my images are and why I can’t deploy? I am running version 1.2 on Ubuntu server.


  • Senior Developer

    Can you try running the upload task in “Download - Debug” mode? To create the “debug” task, cancel the current download task if it’s not already been done. Go to host, list or search for the host you want to upload the task from. Click on the host and go to Basic tasks, choose Advanced, then click and schedule the Download - Debug task. Then boot the host.

    When you start the host, the task will not automatically start. At the “command” prompt type fog and hit enter. Then the task will start as normal. There will likely be pauses to help in the debugging process and where things are failing. Can you provide more information using this method?



  • What is the output of
    [CODE]ls -la /images/vistatest4[/CODE]

    Have you tried a different OS yet? Maybe vista issue was not resolved I am not sure I have not used it with fog.



  • I updated to the latest release of the server. (Version 2201) It created the image into one file. When I try to do a download. It comes up with a deployment screen, then says “error” at the bottom then reboots.

    foguser@fogserver:/images$ ls -la
    total 2718152
    drwxrwxrwx 4 root root 4096 Aug 16 20:36 .
    drwxr-xr-x 26 root root 4096 Aug 16 19:21 …
    drwxrwxrwx 2 root root 4096 Aug 16 20:36 dev
    -rwxrwxrwx 1 root root 0 Aug 9 16:18 .mntcheck
    drwxrwxrwx 2 root root 4096 Aug 9 16:18 postdownloadscripts
    -rwxrwxrwx 1 root root 2783365995 Aug 16 20:36 vistatest4
    foguser@fogserver:/images$



  • Each line needs to be entered together
    [QUOTE]
    [CODE]sudo apt-get install subversion
    svn checkout http://svn.code.sf.net/p/freeghost/code/trunk freeghost-code
    cd freeghost-code/bin
    sudo ./installfog.sh[/CODE]
    [/QUOTE]

    Otherwise go to [url]http://sourceforge.net/p/freeghost/code/HEAD/tree/[/url] and click on Download Snapshot and navigate to the bin folder and run the last command



  • I tried the commands.

    apt-get install subversion
    svn checkout

    Do I need to link up a different source or repository?


Log in to reply
 

428
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.