Moved Images folder now - Fatal Error: Failed to mount NFS Volume



  • Built a new Fedora 20 box and installed Fog 1.2.0 - Everything was working perfect then I needed to move my /images folder to /home/images/ due to space. (Used mv /images /home/images)

    1. Went into the storage management and made the change on “DefaultMember” - Image path /home/images

    2)Ran:
    [SIZE=12px][FONT=Arial][COLOR=#000000]sudo chown -R fog /home/images[/COLOR][/FONT][/SIZE][SIZE=12px][FONT=Arial][COLOR=#000000] [/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]sudo chmod -R 755 /home/images [/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]sudo chmod -R 777 /home/images/dev[/COLOR][/FONT][/SIZE]
    and
    [SIZE=12px][FONT=Arial][COLOR=#000000]touch /home/images/dev/.mntcheck [/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=Arial][COLOR=#000000]touch /home/images/.mntcheck[/COLOR][/FONT][/SIZE]

    [B]Two things are going on and I don’t know why:[/B]

    1. Under the log viewer I am getting a multicast over and over “[COLOR=#555555] StorageNode Not found on this system” but on the dashboard I am seeing the correct amount of storage space.[/COLOR]

    [COLOR=#555555]2) When I go to upload an image I am getting:[/COLOR]
    [COLOR=#555555] Mounting file system: Mount: Fog IP Address:/home/images/dev on /images failed: Permission denied[/COLOR]

    [COLOR=#555555]Fatal Error: Failed to mount NFS Volume[/COLOR]

    [B][COLOR=#555555]Here is images:[/COLOR][/B]

    [COLOR=#555555][root@pc images]# ls -la total 20 drwxrwxrwx 5 fog root 4096 Aug 12 10:30 . drwxrwxrwx. 6 fog root 4096 Aug 12 11:15 … drwxrwxrwx 2 fog root 4096 Aug 12 10:30 dev drwxrwxrwx 2 fog root 4096 Aug 12 10:24 Lenovo -rwxrwxrwx 1 fog root 0 Aug 12 15:21 .mntcheck drwxrwxrwx 2 fog root 4096 Aug 11 15:32 postdownloadscripts[/COLOR]

    [B]Here is dev:[/B]
    [B][/B]
    [COLOR=#555555][root@pc dev]# ls -la total 8 drwxrwxrwx 2 fog root 4096 Aug 12 10:30 . drwxrwxrwx 5 fog root 4096 Aug 12 10:30 … -rwxrwxrwx 1 fog root 0 Aug 12 15:22 .mntcheck [/COLOR]
    [COLOR=#555555][/COLOR]
    [COLOR=#555555][/COLOR]
    [SIZE=12px][FONT=Arial][COLOR=#000000][/COLOR][/FONT][/SIZE]

    [SIZE=12px][FONT=Arial][COLOR=#000000][/COLOR][/FONT][/SIZE]

    [SIZE=12px][FONT=Arial][COLOR=#000000][/COLOR][/FONT][/SIZE]





  • exports for NFS pointing to the new location??? I just fixed that on a FOG 1.2.0 on CentOS 7… same error… I had already chowned and chmodded the permissions for the new folder along with copying the .mntcheck files… all that was missing were the exports for nfs that were still pointing to the default /images folder



  • [B][FONT=Ubuntu][COLOR=#555555]Storage Node: DefaultMember[/COLOR][/FONT][/B]

    Storage Group: Default

    Enabled: Yes

    Graph Enabled: Yes

    Master Node: Yes

    [FONT=Ubuntu][COLOR=#555555][/COLOR][/FONT]



  • This post is deleted!


  • This post is deleted!

  • Senior Developer

    Still not fully understanding what’s wrong. It’s not the permissions or the folders themselves, so if it was reporting “StorageNode not found on this system” my guess is your FOG Server’s personal StorageNode is not the master/enabled storage node?



  • ???


Log in to reply
 

423
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.