Images in Database



  • Hey guys,

    I am having trouble figuring this one out, and I’ve seen other posts close to this but not the issue that I am having, hopefully someone here can help. I’m creating and uploading images off of some brand mew Lenovo T410 Laptops as well as a Dell Inspiron 620 Desktop, the images seem to go through the whole process where they upload to the server, and go in to the /dev folder. They then get transferred to the /images folder, but are still not registering as being on the Server in the Webgui. I’ve done the {chmod -R 777 /images } command and it went through no problem, but still no go. This is a brand new build using an HP DL380 Gen4 Server chassis, Ubuntu 12.04 LTS, and running the latest version of FOG.

    [url="/_imported_xf_attachments/1/1258_fog.PNG?:"]fog.PNG[/url][url="/_imported_xf_attachments/1/1259_Winscp.PNG?:"]Winscp.PNG[/url]



  • I’m able to get a couple of the computers Imaged, but now I am having trouble with another. It uploads and downloads just fine, but when it boots windows it freezes.



  • Well, I tried yet another computer and have still not gotten it to Image. I’m not really sure what my next step should be. Any other ideas?



  • Well, I ran that and did an upload, and it seems that the same thing has happened. The images moves from /images/dev to /images under the folder name, but it seems to be a much smaller amount of data than I would imagine, about 8GB. I attempted to deploy the image, but all it did was erase the MBR/GPT and then say task was finished. If I look on the Image Size on server it only shows 70MB. :/

    [url="/_imported_xf_attachments/1/1280_fog_images2.PNG?:"]fog_images2.PNG[/url]



  • Thank you sorry for asking os many questions, didn’t want to mess up and have to rebuild as it took several hours to rebuild.


  • Developer

    yes, w



  • I typed the fixparts /dev/sda, and now it is asking for MBR Command, do you know which option I need here, I assume w as it is write the MBR partition table to disk and exit. Does that sound right?


  • Senior Developer

    [quote=“Kyle Johnson, post: 35042, member: 25485”]Alright, so I thought that it might be the partitions or something because it was prebuilt, but I went ahead and wiped it and started fresh with a new copy of windows 7 and something shows up on the server now on the web gui as image size on server, but it just seems to the be 100MB System partition. In fact, it doesn’t look like much uploaded to the server as shown in that picture.[/quote]

    Based on the screen shot I’m seeing,

    You have only two partitions on this disk?

    d1p1.img actually appears to be a GPT table.

    What I’d recommend is recreate an upload task, but create it with upload - debug.

    From the GUI.

    Go to Host Management.

    Search or list Hosts.

    Search and click, or list and find and click, on the host you want to Upload the image from.

    Choose basic tasks.

    Click on Advanced.

    Click on Upload - Debug.

    Start the task.

    Boot the host you’re trying to upload the image from.

    When it gets to the terminal prompt, type:
    [code]fixparts /dev/sda[/code]

    Confirm and accept the changes it’s recommending.

    Once all is done, run the command
    [code]fog[/code]

    Hopefully all will work.



  • Alright, so I thought that it might be the partitions or something because it was prebuilt, but I went ahead and wiped it and started fresh with a new copy of windows 7 and something shows up on the server now on the web gui as image size on server, but it just seems to the be 100MB System partition. In fact, it doesn’t look like much uploaded to the server as shown in that picture.

    [url="/_imported_xf_attachments/1/1279_fog_images.PNG?:"]fog_images.PNG[/url]



  • Tom What do you mean?

    Also if this helps anyone a couple pictures of what happens.

    [url="/_imported_xf_attachments/1/1262_image.png?:"]image.png[/url][url="/_imported_xf_attachments/1/1263_image2.png?:"]image2.png[/url]


  • Senior Developer

    It’s because the system isn’t actually downloading my infloation. There is no data to see in the bandwidth graph.



  • It starts up like it is going to do the download, and just downloads what looks to be the MBR, and it only take maybe a minute then says imaged successfully. When it reboots it comes up and says missing operating system. But, the ‘Lenovo’ folder is there under /images. The images I tried to capture was a Windows 7 x64, Multiple Partition Single Disk upload. I wish it was just not being displayed correctly.

    Edit: I’m also noticing that the bandwidth receive graph isn’t working. hmmm


  • Developer

    if the only problem is that the image size on server isn’t being displayed, or is being displayed improperly, then you don’t really have a problem. this is a known issue that has been fixed in the code for the next release. if you’d like to have this working, you can update to the latest trunk version, and do some beta testing for us ;)



  • Junkhacker, which password are you referring to that it needs to match in the gui, the one that is set for storage management and TFTP_FTP pass by default?

    Also, would that be done by sudo passwd fog?

    Thank you

    Edit: After I sent that I went and logged in to the server using the user fog, and the password that is set for storage and TFTP_FTP and it logged me in just fine. Just to make note of it, the images are transferring to the /images folder just not registering in the webgui as there being any data there.


  • Developer

    the fog user is a linux user, you need to change the password for the user fog in linux, and it needs to match the password in the gui



  • I tried the following: Chown [COLOR=black][FONT=Consolas]-R fog:root /images (left the passwords in Storage and TFTP_FTP settings the same)[/FONT][/COLOR]
    [FONT=Tahoma]
    Now it seems to be working. [/FONT]



  • I am having the same problem with images not being moved ( Ubuntu 12.04 Fog 1.2.0). I have checked the passwords and they are the same in both places. It is clearly an authentication problem, but can anyone give us an idea of where and what to change.
    (very frustrated. been using FOG since 2009 with very few problems until the upgrade, which only happened because the old server died and we thought what the hell, lets catch up!)



  • Yeah, I tried to modify it there too, and same thing happened. I opened up a WinSCP session to 10.10.10.244 using ‘fog’ as the user name and ‘new password’ and it still says access denied. But as soon as I type in the default password, it logged me in immediately.



  • There is a tftp password setting under other settings>>fog settings as well, toward the bottom of the list.



  • [quote=“mbeeler, post: 34877, member: 25484”]Within the webgui is where I changed mine. I do not recall changing it anywhere else.[/quote]

    Well I just tried to initiate an FTP session, that when I use the new password, it doesn’t work, but if I try and use the old password it connects just fine. Not there has to be somewhere else to change it then I would imagine?


Log in to reply
 

363
Online

38988
Users

10712
Topics

101691
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.