Hdparm issue: Inappropriate ioctl for device



  • I know there are a couple of other threads related to this but sorting through all of it seems to lead me nowhere.

    I ma running FOG .31 We got in a bunch of HP z230 workstations. They have a single 500GB Toshiba SATA3 drive. When trying to register the host with the BIOS drive setting to RAID or AHCI we get the hdparm error. If I set it to IDE, Fog reports it cannot find the drive. So…I manually registered the host and I set it to deploy an image and it tells me my kernel is corrupt or damaged.

    I have tried the latest Tom Elliot kernel, the most recent KS kernel (which is ~4 years old) and tried the kernel I use successfully on my z220’s to no avail. Was there ever a definitive resolution to this problem?



  • This worked! Thanks Tom. From what I can tell the first time I downloaded this kernel something went awry although I got no error messages and the file was possibly corrupted, only 4655 bytes?. (I used a -no-certificate-check with wget, if i dont use the no cert, i get an SSL error) I noticed this a.m. it was much smaller than a kernel file should be. So this time I downloaded it in my Windows browser and pushed it up to my Fog box via FTP. Success. Thanks a gain Tom!



  • I think I did, but got it from a different link. I will try again using the address you just provided and report back.


  • Senior Developer

    Try my 32bit kernel with 0.31?

    wget -O /tftpboot/fog/kernel/bzImage https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/bzImage32
    

Log in to reply
 

446
Online

38716
Users

10544
Topics

99831
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.