FOG Main Server cannot determine free storage from a fog storage node



  • Hi,

    i have installed an additional fog storage node (S) imaging and the rest is working but the main fog cannot determine the freespace on the storage node.

    I excepted this will work when using fog as storage node.
    I made some experiments with nfs and ftp without installing fog there i had the same problems but i thougth this will now work out of the box.

    Regards X23


  • Senior Developer

    The only change I did for this issue:

    Edit the /etc/mysql/my.cnf file (ubuntu)
    Look for the line that has something along the lines of:
    [code]bind-address=127.0.0.1[/code]
    Make it look like:
    [code]#bind-address=127.0.0.1[/code]

    Restart mysql:
    [code]sudo service mysql restart[/code]



  • Hi,

    this one is also fixed, my fog db was only accessible from 127.0.0.1 like that no additional storage node can connect fogs db, we changed mysql settings to make it accessible from anyone or in special only the storage node.

    @Tom you did the changes maybe you can go deeper with details?

    Regards X23



  • Hi,

    it seems you found it:

    [IMG]http://i.imgur.com/f74irMV.png[/IMG]

    Hmm but why are the credentials wrong? I used what is display here:

    [IMG]http://i.imgur.com/X1AIqH5.png[/IMG]
    Howto find out correct credentials?

    Edit:

    Hmm it says cannot connect not wrong credentials… hmm db ip is pingable…

    Regards X23


  • Senior Developer

    From that storage node:

    If you run:
    [code]mysql -u fogstorage -p’fs1139809790’ -h172.19.102.17 fog[/code]

    Does it connect?



  • Hi,

    the Config.class.php is fine:

    [IMG]http://i.imgur.com/9ZeDgXC.png[/IMG]

    fog main (db): 172.19.102.17
    additional storage node (s): 172.19.102.18

    The picture above is taken from 172.19.102.18
    It must be another problem.

    Also: Using the additional storage node is working fine, what is not working is the correct image size on server but that was also wrong with main node, it always shows around 2gb for image on server:

    [IMG]http://i.imgur.com/IAGiC4z.png[/IMG]

    And fog main does not show free space for additional storage node:

    [IMG]http://i.imgur.com/Ex2xWGs.png[/IMG][IMG]http://i.imgur.com/S6J6d3x.png[/IMG]

    I used the following informations from main fog (db) to configure the additional storage node:

    [IMG]http://i.imgur.com/mWpeA4v.png[/IMG]

    Regards X23


  • Senior Developer

    This sounds, to me, like the Storage Nodes /var/www/fog/lib/fog/Config.class.php isn’t looking at the Main FOG Server’s database, as is intended. The way a node works, is it simply links to the main FOG Server and uses the main database.

    If the main FOG Server’s IP is 10.10.10.25, then the Config.class.php should look something like:
    [php] /**
    * db_settings();
    * Defines the database settings for FOG
    * @return void
    */
    private static function db_settings()
    {
    define(‘DATABASE_TYPE’, ‘mysql’); // mysql or oracle
    define(‘DATABASE_HOST’, ‘10.10.10.25’);
    define(‘DATABASE_NAME’, ‘fog’);
    define(‘DATABASE_USERNAME’, ‘fogstorage’);
    define(‘DATABASE_PASSWORD’, ‘fs8816181243’);
    }[/php]



  • Hi,

    i’ve installed same latest svn on both now, and i still get no free disk space:
    If i open freespace.php on new storage node (S) it still want to update a db that isnt existing on a storage node (S).

    Regards



  • Hi,

    if i try to connect to the new storage nodes freespace.php i see that:

    [IMG]http://i.imgur.com/9IW6WgF.png[/IMG]
    Why the hell will this displayed? There is no sql database on the storage node (S)…!

    FOG Main is SVN (1.2.0)
    Storage Node is SVN (Today)

    Is that a problem?

    Regards


Log in to reply
 

360
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.