PXE issues?



  • Hi All,

    Total noob here trying to install and run Fog. I have ran into some issues though. We have fog installed and running underneath a user account. The server is up and running with no issue, but we cannot get any of our computers on campus to load undionly.kpxe or any other boot file.

    I am running Ubuntu 13.10 on vmware with fog 1.2.0. I have tried fog 1.1.1 and fog 1.1.2, but had the same issue.The test vm from 2009 does work though, but we don’t want to be running on old outdated test server.

    On DHCP, we have port 66 with the correct IP address and port 67 with undionly.kpxe.

    I have tried ipxe.kkpxe, ipxe.kpxe, ipxe.pxe, pxelinux.0.old (won’t work because of no configuration file), undionly.kkpxe, undionly.kpxe, unionly.kpxe.INTEL, undionly.pxe. The pxe and ipxe and Undionly.kpxe starts configuring to eth0 but goes to “press a key to reboot.” Undionly.kkpxe comes up with error 3c092003.

    I have tried most of the suggestions at http://fogproject.org/forum/threads/ipxe-issue.10528/ with no avail. I was able to get the fog menu once with [I]. [/I]And that was after like 10 retries. And I haven’t seen it since.

    The test client is an old HP Pavilion a1610n with Nvidia nforce 10/100/1000 Mbps Ethernet. We have other clients, Lenovo and HP, but none of them will boot either.

    Like I said earlier, I am a noob and I have no idea what could be wrong here. Any help would be appreciative. Maybe I am missing something that is apparent to everyone else, but I have tried for over a week to try to get this fog server up and running correctly. I would love to get Fog up and running.



  • @John VanHoose, post: 39534, member: 4156 said:

    I just went back to .32 it works with no extra troubleshooting.

    It’s tempting, John, but I’m not giving up just yet.



  • I just went back to .32 it works with no extra troubleshooting.



  • http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/quote]

    I was having the same error and I tried the above link now I get the new menu screen but it just constatly flashes that screen and noting else.



  • It still surprises me that my user account is an Administrator, but I’m still not Queen of the Ubuntu castle. Mercy, I’ve made no progress today … my new boss must be totally impressed with the new Tech Lady.


  • Developer

    try ```

    sudo chmod -R 0777 /tftpboot

     
    Your user may not have the required privileges to chmod that folder without sudo.
     
    I only ask so I can download a version and try to replicate your issues.


  • It just says 12.04 LTS. I have not done the 81 updates that are available. I did try to do this: chmod -R 777 /tftpboot and got ‘operation not permitted’. This folder is owned by mystery user #1002 which does not show up in my user list. I have not been able to get dnsmasq set up because each roadblock requires study on my part.


  • Developer

    which version of 12.04 did you install, 12.04.1LTS? 12.04.4 LTS? 12.04.5LTS?



  • Tried to install dnsmasq and it threw an error about dnsmasq-base being an unmet dependency. This sure is making me nervous though I do appreciate the advice.


  • Developer

    @Barbara Howard, post: 39252, member: 27181 said:

    [INDENT=1]The firewall is disabled and I can successfully transfer the file via TFTP on my windows machine. Rights to tftpboot folder show: Owner=1002 (a user created as part of the installation?), Group=root and Others=Access Files. Not sure how to adjust that, but I made sure the rights to the images folder look OK (owner is root). Even tried a subfolder in images with ‘create and delete’ rights for all users even though I’m not getting that far in the process. Thank you for the help, Tom![/INDENT]

    Did you set up DNSMasq again?


  • Developer

    This post is deleted!


  • [INDENT]The firewall is disabled and I can successfully transfer the file via TFTP on my windows machine. Rights to tftpboot folder show: Owner=1002 (a user created as part of the installation?), Group=root and Others=Access Files. Not sure how to adjust that, but I made sure the rights to the images folder look OK (owner is root). Even tried a subfolder in images with ‘create and delete’ rights for all users even though I’m not getting that far in the process. Thank you for the help, Tom![/INDENT]


  • Senior Developer

    http://192.168.1.8/fog/service/ipxe/bg.png --left 100 --right 80http://192.168.1.8/fog/service/ipxe/boot.php##params ||http://fogproject.org/wiki/index.php/Tftp_timeout

    From what I can tell, your particular issue is that it’s not even getting to the undionly.kpxe file. NO amount of work or changes or additions to the advanced menu, or any menu for that matter, will help you see a menu if you’re not getting the file that’s needed.



  • Hello, I’m the rookie that struggled with TFTP login issues all day yesterday. I reinstalled FOG 1.2.0 today and it seems to have fixed that problem. Today I’ve struggled with the PXE boot. I can turn on a Dell D620, but get the T01, E3B file not found on my three victims (old Dell D620 (32bit), Thinkpad E440 (64) and a 64-bit VM). I tried adding an advanced menu option, but haven’t seen it come up. I’m not using FOG for DHCP and do get an IP address. DHCP entries for 66 and 67 have been made. The undionly.kpxe file does exist in the TFTPBOOT folder. I went with 12.04 LTS desktop version after getting befuddled with the server version which I tried after getting befuddled with the desktop version. I’ve tried using the undionly.kpxe.INTEL file as well, but went back to undionly.kpxe. FOG does turn on the D620 (the bright spot in the day), misses the PXE boot with the file not found errors, gets to the Windows login screen and then shuts down to try it all over again. This is what I get from the boot.php file. Any advice you can give me would be most appreciated.
    http://192.168.1.8/fog/service/ipxe/bg.png --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    item fog.advanced Advanced Menu
    choose --default fog.local --timeout 9000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.1.1 keymap= web=192.168.1.8/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.1.1 keymap= web=192.168.1.8/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.1.1 keymap= web=192.168.1.8/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :fog.advanced
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param advLog 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://192.168.1.8/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot



  • I’m not sure why this fixed my problem, but it did. We were getting timeouts/hanging at kernel download…

    I’d love to hear an explanation of what is looking for undionly.0…



  • finded the solution :
    ln -s undionly.kpxe undionly.0



  • Hi there,

    I updated yesterday from 1.1.2 to 1.2.0, then i get the same error,
    after reading the post, i installed & configure dnsmasq.

    then now i got this error :

    PXE-T01: File not found
    DASH-E3B: TFTP Error - File not found
    DASH-M0F: Exiting Option ROM

    The DHCP score options 66 & 67 are good (like for the 1.1.2)
    i tried to restore old tftpboot directory, same error.
    i check the dnsmasq, don’t see any errors.

    Fog is installed on a Ubuntu 14.04

    ps sorry for my bad english



  • EDIT/UPDATE: This article: http://fogproject.org/wiki/index.php/Chainloading_PXE_to_iPXE_using_pxelinux.0
    got things working at long last, at least as far as booting into the FOG Environment, and running the diagnostics mode. I haven’t tried actually imaging or uploading from any of our PC’s yet.

    I WILL note that FOG now seems touchier than ever about switch equipment; on the other hand, I keep telling the PTB our switches are desperately in need of replacement, so maybe this will give them an extra kick in the butt :-D

    ORIGINAL POST:

    Hi there,

    I have been banging my head against this same problem. I just upgraded today from FOG 0.32 to 1.2.0 in Ubuntu 12.04

    The DNSMasq trick worked like a charm…but now whenever we try to PXE boot, it craps out at this error:

    /default.ipxe…Connection timed out (http://ipxe.org/4c126035)

    We boot mostly Panasonic Toughbooks and HP Compaq Pro Elite workstations. We had NO problem in the past with PXE booting, not until this upgrade.

    The chain http statement in that file is pointing to the correct IP address of the FOG server, and when we run the URL through, we get an output that appears as expected.

    Any ideas?


  • Developer

    @Phantox Jada, post: 34379, member: 25158 said:

    I didn’t put in my DHCP server IP. I put in the actual fog server IP. I do not know if that was the correct thing to do, but everything is running now.

    That is the correct thing to do, that is what the documentation tells you to do!



  • I didn’t put in my DHCP server IP. I put in the actual fog server IP. I do not know if that was the correct thing to do, but everything is running now.


Log in to reply
 

369
Online

38721
Users

10548
Topics

99849
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.