Fails to pxe boot after first image.



  • I can always get the first image to storage, then after that, I can’t get any computer to pxe boot. It will get DHCP address then it times out on TFTP. I am running Ubuntu 12.04 with fog1.1.2.



  • I ran sudo service tftpd-hpa restart. Worked like a charm. Thanks a bunch everyone. That one sure had me going.


  • Senior Developer

    This has been written and coded many times throughout the forums. I think Jaymes’ fix is much better for this issue here is some steps you can do:

    sudo update-rc.d tftpd-hpa disable
    sudo sysv-rc-conf tftpd-hpa off
    

    This should disable tftpd-hpa from booting at system boot up.

    Then put the following line above the exit 0; line in /etc/rc.local:
    sleep 30 && /etc/init.d/tftpd-hpa start

    Save and close the file and you’re done. The rc.local script is run after bootup, so within 30 seconds of getting the login prompt tftpd-hpa will start up and you should have success.



  • @Tom Elliott, post: 33481, member: 7271 said:

    what happens if you run:

    >sudo service tftpd-hpa restart
    >```
     
    and try booting a host again?
    I was having the same problem and this worked for me. I then tried rebooting my server and had to run the command again. Is there a fix to not have to do this every time I need to reboot my server?

  • Senior Developer

    what happens if you run:

    sudo service tftpd-hpa restart
    

    and try booting a host again?


Log in to reply
 

411
Online

38746
Users

10569
Topics

100055
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.