FogScheduler seems to have Startup Problems



  • Hi,

    another issue i address with 1.1.2 is that i have the feeling that the FogScheduler isn’t running well after a system Startup, i created some Scheduled test uploads and the Computers doesnt wakeup until i restarted the FOGScheduler Service after every reboot of the Fog machine.

    The Strange thing is i can see that the FOGScheduler is starting while ubuntu boots, but for some kind of reason something went wrong or it crashes after a short time.

    Every time i restart the Scheduler Service Planned Tasks will run immediatelly.
    Any Idea?

    Regards X23



  • Hi,

    why isn’t the project driving your recommendations? grrr ;)
    i really want to have fog this time running well i tried a first run with 0.32 and was working hard on it but in the end it was useless for our business. This will be the second run i want fog so hardly for a nice automated backup of workstations.

    Regards X23


  • Senior Developer

    I’d give it a show.

    Basically I’m only allowing the rc.local to startup the mysql service, which is likely failing due to the similar tftpd-hpa where it’s booting before a network device is available.

    I’d also recommend disabling bootup start of FOGMulticastManager FOGScheduler FOGImageReplicator as well, and have the start after the mysql is started



  • Hi Tom,

    should i do both changes you address on your github account?

    [CODE]sudo su -
    cd /var/lib/mysql

    mv ibdata1 ibdata1.bak
    mv ib_logfile0 ib_logfile0.bak
    mv ib_logfile1 ib_logfile1.bak

    cp -a ibdata1.bak ibdata1
    cp -a ib_logfile0.bak ib_logfile0
    cp -a ib_logfile1.bak ib_logfile1

    service mysql restart

    sudo update-rc.d mysql disable[/CODE]

    Edit the /etc/rc.local file before the exit 0; line add:
    [CODE]sleep 30 && start mysql[/CODE]

    Regards X23



  • Hi,

    too bad i allready found that link to your github issues ;) i didn’t realized that this i my problem, i also have allready a link in my link list to this url :D

    Thanks

    Regards X23


  • Senior Developer

    There is a work around and a “kind of” solution for the problem.

    I have a write up on my github clone on it.

    I was just driving in, hence the “bad” translation.

    [url]https://github.com/mastacontrola/fogproject/issues/1[/url]



  • Hi Tom,

    isn’t there any workaround to it? That problem sounds like a timing problem.

    Regards X23


  • Senior Developer

    There is a known issue where my sequel has a similar start a problem to T FTP issues even in Ubuntu 13.10


 

518
Online

5.3k
Users

12.5k
Topics

117.8k
Posts