Install and operation was fine, until mysql_secure_installation afterward.



  • So, [U]fog[/U] uses the [U]root[/U] password for mysql. Why is that? Out of all the applications which are perfectly satisfied to run as their own user in the confines of their own database. And with no password by default. I understand that it is essential that the user be able to install the application and that taking shortcuts like this simplifies user installation but it already doesn’t allow for SSL (Solution: block port80 external and manage with GUI web browser [U]on[/U] server [unpreferable])

    Fog 1.1.2 installed on CentOS release 6.5.

    It was working great (thanks, by the way) and then I started thinking about security.
    Only configuration changes I have made so far after install:
    [LIST=1]
    []mysql_secure_installation (set a password)
    [
    ]updated the values accordingly in the file (/opt/fog/.fogsettings)
    [/LIST]
    I am receiving the infinity errors page. Unable to proceed.

    [CODE]
    Update/Install Failed!
    The following errors occured (SP)

    Update ID: 1 - 0

    Database Error: (???)
    Database SQL:
    CREATE DATABASE fog

    Update ID: 1 - 1

    Database Error:
    Database SQL: […continues over9000][/CODE]

    There is a password string below which I am unfamiliar with. Please explain the 68d2b7. Not my string.
    [CODE]# Created by the FOG Installer

    Version: 1.1.1

    Install time: Thu 26 Jun 2014 08:08:13 AM CDT

    ipaddress=“10.0.0.7”;
    interface=“eth0”;
    routeraddress=" option routers 10.0.0.5;";
    plainrouter=“10.0.0.5”;
    dnsaddress=" option domain-name-servers 10.0.0.5; ";
    dnsbootimage=“10.0.0.5”;
    password=“68d2b7”;
    osid=“1”;
    osname=“Redhat”;
    dodhcp=“n”;
    bldhcp=“0”;
    installtype=“N”;
    snmysqluser="root"
    snmysqlpass=“passwd”;
    snmysqlhost=“localhost”;
    installlang=“0”;
    donate=“0”;
    fogupdateloaded=“1”[/CODE]

    /var/log/httpd/error.log
    [Thu Jul 10 12:03:44 2014] [error] [client 10.0.0.151] PHP Warning: mysqli::mysqli(): (28000/1045): Access denied for user ‘root’@‘localhost’ (using password: NO) in /var/www/html/fog/lib/db/MySQL.class.php on line 64, referer: [url]http://10.0.0.7/fog/commons/schemaupdater/index.php[/url]

    Have I set the password in the wrong location?
    Please help! Thanks.


  • Senior Developer

    You can grant and rerun with the new settings, just place them in the .fogsettings.



  • Awesome. You rock so much. Ran installer. Installer says go to webpage and click button. Clicked button…
    [CODE]Update not required, your database schema is up to date![/CODE]

    However, are there plans to separate fog permissions from the root mysql user or can I grant/create/specify another user (fog) and rerun the installer with those settings? I have a ton of other questions. Need to read the forums I guess. Thanks again.

    [edit]
    Changed username value in /opt/fog/.fogsettings and reran installer. Seems to be working great.


  • Senior Developer

    Have you tried re-running the installer. The .fogsettings file is only used for updates/upgrades so while you set the password there, the config.class.php file has not had it running yet.

    Re-running the bin/installfog.sh file will not cause you to lose any data either.

    The password="[FONT=Consolas]68d2b7" is the linux fog user’s password as set at install time.[/FONT]

    [FONT=Consolas]Hopefully this helps.[/FONT]


Log in to reply
 

365
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.