Just Trying To Get Started



  • Hello,

    I am totally new to FOG, and only slightly more familiar with Ubuntu. I am a network admin in a public school district trying to establish a FOG server (unhappy with Windows-based options). I have installed Ubuntu 13.10 and FOG 1.0.1. on a desktop machine.

    I have been following the directions at:

    [url]http://www.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]
    I have a DHCP server that I can modify, but I didn’t want to go that route.
    I have attached to this post an output file from terminal in Ubuntu of the FOG installation and my steps thereafter.
    When I attempted to establish a connection to FOG by rebooting a computer in my network, the ProxyDHCP works because it prompts me to press F8 and gives me options for Boot from network or Boot from local hard disk. When I choose the network boot, I get a PXE-M0F error.
    I have disabled the firewall on my FOG machine with: sudo ufw disable, because it was suggested somewhere in the forum.
    I am so lost that I don’t even know where to begin.
    Thanks in advance for help.

    [url="/_imported_xf_attachments/1/1107_Untitled Document.txt?:"]Untitled Document.txt[/url]



  • YYYYYYAAAAAAAAAAAAAYYYYYYYYYY!!!

    IT WORKED! IT WORKED!

    :D:D:D

    I chainloaded PXE to iPXE using pxelinux.0, and now a client machine that is PXE booted resolves to the FOG menu!!

    I am very happy!!

    Now, what next???

    Back to the WIKI/User Guide!





  • Well, still no joy:(

    I get to a screen during the process that says:

    iPXE 1.0.0+ (1639) – Open Source Network Boot Firmware – [url]http://ipxe.org[/url]
    Features: NFS FTP HTTP HTTPS iSCSI DNS TFTP VLAN AoE bzImage ELF MBOOT PXE PXEXT
    Menu
    Configuring (net0 a0:1d:48:a9:e6:62)… ok
    Could not start download: Operation not supported ([url]http://ipxe.org/3c092003[/url])

    The reference page at ipxe.org doesn’t make much sense to me, except that it suggests I am trying to use a protocol that is not supported by the ipxe build.

    What have I done wrong?!



  • This post is deleted!


  • Thanks, X23.

    Your post must have been formulated as I was looking for the very answers you provided.



  • Scratch that.

    I found these:

    [url]http://www.fogproject.org/wiki/index.php/Integrating_FOG_into_an_Existing_Network[/url]

    [url]http://www.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG#Windows[/url]

    I have changed the DHCP settings (066 & 067) for a couple of scopes in my network (just to test), according to the above directions.

    Now, to test!



  • Hi,

    i think you are good with:
    [LIST=1]
    [][LIST]
    [
    ]Type 2 and press Enter for Ubuntu installation.
    []Type N and press Enter for Normal installation
    [
    ]Supply IP Address, it SHOULD be the static IP address you set up earlier, if it is not please revert to step 5 and try again.
    []Type Y and press Enter setup DHCP Server.
    [
    ]Enter the IP Address associated with your DHCP Server
    []Type Y and press Enter to set up DNS.
    [
    ]Enter the DNS Server address and press Enter.
    []Type N and press Enter to leave the default Network Card the same.
    [
    ]Type N to disable DHCP Service.
    [][B]NOTE: It tells you that in order to use your PXE server you have to run a few commands on your DHCP server, this is not entirely true, but it definitely helps, this will point your clients to your server, or you can disconnect your server from the outside world while you image.[/B]
    [
    ]Type N to not install Additional Languages.
    []Type Y and press Enter.
    [/LIST]
    [
    ]Next it will verify the settings, make sure everything has been entered correctly.
    [LIST]
    [][B]NOTE: I set up Fog with default passwords for MYSQL and users, you can supply information if you like, just make notes.[/B]
    [
    ]Type a password for the “root” user in MySQL and press enter.
    []Type the Password again and press enter.
    [
    ]Type the Password again and press enter.
    []Type Y to send your install information to the Project, and it will take some time to complete.
    [/LIST]
    [
    ]Now we need to set up the web GUI for FOG. Open your browser and navigate to [URL=‘http://%28serveripaddress%29/fog/management’]http://(serveripaddress)/fog/management[/URL]. Or click the link in the Terminal window.
    []The web GUI will alert you to back up your database for MYSQL Server and install the upgrades, do so and follow the upgrade instructions.
    [
    ]Next log in, default user name is FOG and the password is password.
    [/LIST]
    [url]http://fogproject.org/wiki/index.php/Ubuntu_12.04[/url]

    [SIZE=5][B]Modifying existing DHCP server to work with FOG[/B][/SIZE]

    If you already have a DHCP server setup on your network you don’t want two. So if you chose to not install DHCP during FOG installation you will need to set some options in your current DHCP server to point PXE services to the FOG server.
    [SIZE=5][B]Windows[/B][/SIZE]

    [SIZE=4][B]0.33 and up[/B][/SIZE]

    To set options 066 and 067 on Windows Server:
    [LIST=1]
    []Open DHCP configuration [B]Start[/B] > [B]Administrative Tools[/B] > [B]DHCP[/B].
    [
    ]Then expand your server, expand the applicable scope (often only one is there)
    []right click on [B]Scope Options[/B]
    [
    ]click [B]Configure Options[/B]
    []tick [B]066[/B] and enter the IP Address of the FOG server
    [
    ]tick [B]067[/B] and enter [B]undionly.kpxe[/B].
    [*]Make sure that 060 is unticked.
    [/LIST]
    For a video walk through jump to 6:44, on:

    [media=youtube]Ak6kfvGM0Dk[/media]
    [SIZE=5][B]Linux[/B][/SIZE]

    [SIZE=4][B]0.33 and up[/B][/SIZE]

    If you would like to use an existing Linux based DHCPD server you will need to perform the following steps:
    [LIST=1]
    []Edit your dhcpd.conf file (ie: vim /etc/dhcpd.conf)
    [
    ]In the global section or in a subnet declaration add [B]next-server X.X.X.X;[/B] and [B]filename “undionly.kpxe”[/B]; where X.X.X.X is the IP of your FOG server.
    []Restart your dhcpd server (ie: service dhcpd restart)
    [/LIST]
    [LIST]
    [
    ]For more, see: [URL=‘http://fogproject.org/wiki/index.php/Linux_DHCP_Server’]Can I use my existing linux DHCP Server?[/URL]
    [/LIST]

    [URL=‘http://fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG’]for more see: http://fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG[/URL]

    The WIKI is your friend! ;)

    Regards X23



  • Well, since no one has had anything to say on this thread for many days, let me see if I can revive the discussion…

    I have decided to scrap my current install and reinstall 13.10 and 1.1.2, with the intention of modifying my DHCP server settings to point PXE booting devices to the FOG server. The ProxyDHCP approach was my first choice because it wasn’t going to involve screwing with my DHCP server settings, thereby maintaining the integrity of my old system (Windows Deployment Services).

    But, at this point, I am willing to “jump all in” to get a FOG server that works.

    So, as I am getting ready to install FOG, what choices should I make during the install process, considering what I intend to do? Should I just choose the defaults, or does some special configuration need to happen?



  • Okay, here’s where I am:

    Both the client and the server are connected to a small 8 port hub (which is also connected to the network, so my server could have its IP address, 10.10.0.178).

    I edited the ltsp.conf file from here [URL=‘http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE’]http://fogproject.org/wiki/index.ph…with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/URL]

    the only active lines in the ltsp.conf are

    [CODE]port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,10.10.0.178
    dhcp-no-override
    pxe-prompt=“Press F8 for boot menu”, 5
    pxe-service=X86PC, “Boot from network”, undionly
    dhcp-range=10.10.0.178,proxy[/CODE]

    When I PXE boot the client, TFTP picks up so fast that I can’t see without slow-mo what it’s saying. Then the screen reads “iPXE initializing devices…”

    Then (thanks to slow-mo) it errors out with “/default.ipxe… Error 0x3d126001 ([url]http://ipxe.org/3d126001[/url])”


  • Developer

    [quote=“Phil Brackett, post: 32434, member: 24966”]Since the FOG machine is not hooked up to my network anymore (because you had me move it to an isolated switch) I don’t know its IP address so I couldn’t modify to ltsp.conf to be any more specific.[/quote]

    You should set a static ip address for the machine. It shouldn’t matter what switch you move it to, you should always have the same ip address.


  • Senior Developer

    I’m going to step in a little bit. You’re over thinking I think a little bit.

    If you take the client system and place the network on the same switch as your FOG server does all work?
    If it doesn’t work, then the problem is either DHCP isn’t handing out the right pointers to your FOG Server (Option 66/Option 67) or your switch is blocking the passing of this data to the FOG Server, or the service isn’t running on the FOG Server.

    If the first switch works, then step to the next switch and try again, if that doesn’t work then something in that second switch is blocking access out. If all works fine, step back to the next switch in the chain. And so forth.



  • Since the FOG machine is not hooked up to my network anymore (because you had me move it to an isolated switch) I don’t know its IP address so I couldn’t modify to ltsp.conf to be any more specific.



  • On HP Elitebook (client):

    no DHCP or ProxyDHCP offers were received.

    I am using the exact ltsp.conf that you showed me (no changes).

    FOG machine and Elitebook both plugged into Cisco 2960 ports 1 & 2


  • Developer

    [quote=“Phil Brackett, post: 32431, member: 24966”]Jaymes, I have installed the FOG machine and a client machine (the HP Elitebook) on a spare Cisco 2960. I have also edited my ltsp.conf to match the one you showed me at [URL=‘http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE’]http://fogproject.org/wiki/index.ph…with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/URL]

    I have also restarted the dnsmasq service.

    Where is the tftpboot folder, so I can symlink according to your directions?[/quote]

    It is on the root of the drive.
    [code]
    cd /tftpboot [/code]



  • Jaymes, I have installed the FOG machine and a client machine (the HP Elitebook) on a spare Cisco 2960. I have also edited my ltsp.conf to match the one you showed me at [URL=‘http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE’]http://fogproject.org/wiki/index.ph…with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/URL]

    I have also restarted the dnsmasq service.

    Where is the tftpboot folder, so I can symlink according to your directions?


  • Testers

    To check if you have portfast enabled on your 2960 series
    telnet to your switch and issue these commands:
    show running-config
    scroll down to your interfaces.
    [CODE]interface GigabitEthernet1/0/1
    switchport access vlan 130
    switchport mode access
    switchport voice vlan 120
    switchport port-security maximum 2
    switchport port-security
    switchport port-security aging time 2
    switchport port-security violation restrict
    switchport port-security aging type inactivity
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    macro description cisco-phone
    spanning-tree portfast
    spanning-tree bpduguard enable
    service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
    !
    interface GigabitEthernet1/0/2
    switchport access vlan 130
    switchport mode access
    switchport voice vlan 120
    switchport port-security maximum 2
    switchport port-security
    switchport port-security aging time 2
    switchport port-security violation restrict
    switchport port-security aging type inactivity
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    macro description cisco-phone
    spanning-tree portfast
    spanning-tree bpduguard enable
    service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
    [/CODE]

    look for [COLOR=#ff0000]spanning-tree portfast[/COLOR]

    if you see it, its enabled, unless its expressly disabled then you will see
    spanning-tree portfast disabled

    to enable port-fast: --change 1/0/1 to the interface you need
    [CODE]
    GR-NB-2960S-01#enable
    GR-NB-2960S-01#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    GR-NB-2960S-01(config)#
    GR-NB-2960S-01(config)#interface gigabitEthernet 1/0/1
    GR-NB-2960S-01(config-if)#
    GR-NB-2960S-01(config-if)#spanning-tree portfast
    GR-NB-2960S-01(config-if)#exit
    GR-NB-2960S-01(config)#exit
    GR-NB-2960S-01#
    [/CODE]

    [COLOR=#000000]If you wish to save your settings. [/COLOR]

    [CODE]GR-NB-2960S-01#write memory
    Building configuration…
    [OK]
    GR-NB-2960S-01#
    [/CODE]



  • I will get started right away. More to come in a few.


  • Developer

    [quote=“Phil Brackett, post: 32422, member: 24966”]We are a Windows network with a Lightspeed filter, and my FOG machine is already a part of a filter bypass group, so its inability to access the internet is a little dumbfounding. In fact, when I check my web filter logs to see where the FOG machine has tried to go, it shows no attempts to access the internet at all (since yesterday). Weird?!?!

    Anyway, thanks for the CNA information, I have it right now discovering my switches on the IP subnet where I have them all assigned!!

    When you suggest moving the FOG server and a host machine to an isolated switch, do you mean just connecting the two machines to a single switch that is not connected to anything else?[/quote]

    That is very odd, however, I don’t have any experience with lightspeed.

    In theory, yes, just connecting the two machines on the same switch without any other network access should work, as long as you can supply some kind of DHCP information.

    If you would like we can set up the DNSMASQ service, I use this in my environment and it is actually the only way to resolve to my FOG server. It’s a quick easy set up, and it’s just as easy to remove. The DNSMASQ will act as a proxy dhcp server for machines looking to boot via TFTP, it will also help to point those machines to the correct boot file.

    If you are interested the link is here [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]



  • We are a Windows network with a Lightspeed filter, and my FOG machine is already a part of a filter bypass group, so its inability to access the internet is a little dumbfounding. In fact, when I check my web filter logs to see where the FOG machine has tried to go, it shows no attempts to access the internet at all (since yesterday). Weird?!?!

    Anyway, thanks for the CNA information, I have it right now discovering my switches on the IP subnet where I have them all assigned!!

    When you suggest moving the FOG server and a host machine to an isolated switch, do you mean just connecting the two machines to a single switch that is not connected to anything else?


Log in to reply
 

348
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.