Scheduled task via cronjob



  • We use Fog 1.1.2 on a server running Ubuntu 14.4 x64 server version. Unfortunately, the time-triggered task from the cron jobs do not work. Under scheduled task the task remains active and is not included in the active task.

    In the GUI, the following was defined 10 13 ***

    What are we doing wrong?



  • If scheduling a shutdown after completion of a donate task, the client reboots rather than shuts down. (fog 1.1.2 on ubuntu server 14.04)

    Can anyone help me.



  • ok, the spaces were created when entering the forum. Of course, I have entered the time zone without spaces in php.ini.

    As I said:

    So does the “Schedule Delayed Deployment” correctly.

    The time in the log view has a difference of 2 hours. The “Schedule Cron-style deployment” only works if you by 2 hours is the time in cron job in the past. WOL works with both versions.

    This is also ok if you consider that.

    One problem is but still. When completed the task is done on client no shutdown but a reboot …!

    When creating the task a shutdown is selected. Why might that be?

    Max


  • Senior Developer

    I believe you can’t have spaces.

    Your “date.timezone” should be set to:
    [code]date.timezone = Europe/Berlin[/code]

    This is because it parses it as filesystem parameters. Europe / Berlin is not valid because the path doesn’t exist.



  • hi there,

    our today’s test we have found a small bug. The parameter date.timezone in php.ini is set to:

    [PHP]date.timezone = “Europe / Berlin” [/PHP]

    This is also the local time zone of the FOG server.

    So does the “Schedule Delayed Deployment” correctly.

    The time in the log view has a difference of 2 hours. The “Schedule Cron-style deployment” only works if you by 2 hours is the time in cron job in the past. WOL works with both versions.

    many greetings


  • Senior Developer

    What time are you expecting the task to run. I asked list because the Cron tells it to run at 1:10 every day



  • Maybe that helps. An active cron scheduled task is not included in the active tasks.

    The Log View shows the following entries

    [CODE][07-09-14 10:03:37 am] * 0 active task(s) awaiting check-in.
    [07-09-14 10:03:37 am] * 1 task(s) found.
    [07-09-14 10:03:37 am] * Task run time: Crontab: 10 9 * * *
    [07-09-14 10:03:37 am] * Task doesn’t run now.
    [07-09-14 10:04:37 am] * 0 active task(s) awaiting check-in.
    [07-09-14 10:04:37 am] * 1 task(s) found.
    [07-09-14 10:04:37 am] * Task run time: Crontab: 10 9 * * *
    [07-09-14 10:04:37 am] * Task doesn’t run now.[/CODE]



  • The time zone in the file under / etc/php5/apache2/php.ini was from documented and the parameter to “date.timezone = Europe / Berlin” is set.

    I have read up on the subject in the forum :)

    Only after setting the time zone in php.ini worked the timed task on the calendar.

    The scheduled task from the cronjob works still not even.

    frank


  • Senior Developer

    My only thought as to the issue is the date.timezone setting. FOG defaults the time in use to UTC if the /etc/{php5/apache2/,php}/php.ini file is not set or commented.

    A commented date.timezone looks like:
    [code];date.timezone = [/code]

    Set it to your appropriate timezone and I believe you’ll have much better success:

    Example:
    [code]date.timezone = America/New_York[/code]



  • Yes, the FOG scheduler service is running on the FOG server. The other timed task that is set on the calendar works. Only the cron job scheduler does not work.

    Thanks for the help - yours sincerely.


  • Senior Developer

    Is the FOGScheduler service running on the FOG Server?


Log in to reply
 

364
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.