Multicast does not work when using SQL database password



  • Hi all,
    I’m not sure if this warrants a new thread but in FOG 1.1.2 on Ubuntu 14.04 multicast works perfectly with a blank SQL database password, but the task won’t start when there IS a SQL database password. I have entered the password upon installation, verified it, etc…

    It is just strange the number of issues that having a SQL database password creates, you would think that it would be possible to actually have one…

    Thanks for any input, and thanks to the developers,
    D.L.



  • I probably should have described it better, but it sits at the “Starting to restore image screen” and the multicast task never actually begins, as described in this thread :
    http://fogproject.org/forum/threads/fog-1-1-0-multicast-sits-at-starting-to-restore-image-to-device-dev-sda1.10782/page-2#post-31993

    Also (or as a result of this) in /opt/fog/log FOG version 1.1.2 does not create the multicast.udpcast.1.log (approximate file name) file, nor does it create any entries in the multicast.log file. Since I was confused by this I pulled up an old .32 installation - in .32 it has the same behavior, however it does make entries in the multicast.log to at least let you know what is going on:

    [07-01-14 9:54:10 am] * Starting FOG Multicast Manager Service
    [07-01-14 9:54:15 am] * [07-01-14 9:54:15 am] Checking for new tasks every 10 seconds.
    [07-01-14 9:54:15 am] * [07-01-14 9:54:15 am] Starting service loop.
    [07-01-14 9:54:15 am] | [07-01-14 9:54:15 am] Failed to connect to database server, will try again in next iteration.
    [07-01-14 9:54:25 am] | [07-01-14 9:54:25 am] Failed to connect to database server, will try again in next iteration.
    [07-01-14 9:54:35 am] | [07-01-14 9:54:35 am] Failed to connect to database server, will try again in next iteration.

    And yeah, on one test installation I did create a password for the root user. I’ve checked in Config.class.php in /var/www/html/fog/lib/fog and it is correct and I’ve also verified it by running mysql -u root -p and entering the correct password. This test installation will not multicast, and gets stuck as described above. On another test installation I used all of the same settings, and I did not enter a SQL password on installation - this box will start multicast tasks…

    Thanks Tom, you’re the man,
    D.L.


  • Senior Developer

    How do you mean it works without, but not with?

    Did you actually create a password for the root user in mysql?


Log in to reply
 

484
Online

38926
Users

10692
Topics

101460
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.