Fog registration with NUC



  • Having trouble using Fog with the new Intel Nuc D54250WYK.

    It will PXE boot to the fog menu, and then no matter which option I choose it stalls about mid way through. I’ve tried registering it, even manually entering it and then trying to image. No luck as it always fails. It’s even stopping in different parts of the process.

    Anyone see this before?



  • I’m having the same issue with the new Intel NUC Kit, they seem to have put in a different mainboard. The NUC’s manufactured in 01/14 worked flawless, while the newer series from 05/14 has some kinks (only accepts 1.35V RAM or 1333MHz 1.5V anything below and it doesn’t even start).
    Anyway, they get stuck on “iPXE initialising devices…”. I’ve already tried every file from the /tftboot folder, no luck so far.
    Maybe Mike has more luck.

    P.S. I’m on 1.1.2



  • I will have to check - headed home for the holiday weekend, Jared will pick this back up on Monday. Are those settings in the dhcpd file?


  • Senior Developer

    Is the dhcp option filename/67 pointing at undionly.kpxe or pxelinux.0?

    Is the dhcp option next-server/66 pointing at the ip of your fog server?



  • I re-ran the FOG install - here is the log file.
    Still will not pxe boot a client.

    [url="/_imported_xf_attachments/1/1100_FOG LOGtext2.txt?:"]FOG LOGtext2.txt[/url]



  • Am a noob to Linux and fog but e may of had a similar experience when I did a fresh install today the first time trying to install MySQL wouldn’t it never prompted were it normally would for the root password to be set I had to rerun the installer second time it worked fine.

    Ps it’s not anything to do with that he’s installed on Ubuntu 14.04 I saw a warning in the wiki that it’s too new and doesn’t work properly and was recommended in my thread on general to use 12.04.4


  • Developer

    when you ran the installer, did you follow the instructions and prompts in the script?


  • Senior Developer

    So it looks like it never got past Mysql password setting. There’s nothing after this point which tells me 1.1.2 is not fully installed.



  • here is the file

    [url="/_imported_xf_attachments/1/1099_FOG LOGtext.txt?:"]FOG LOGtext.txt[/url]


  • Senior Developer

    What’s the contents of your /var/log/installfog.log file?



  • yes, did sudo ./installfog.sh


  • Developer

    when you ran the installer, did you run it with sudo?



  • could this be a rights issue? When I use the file browser I can see the tftpboot folder, but can’t get access to it.

    Tom - this was a brand new install of FOG 1.1.2 on a new Ubuntu 14.04LTS desktop. So when I did’t see the tftpboot folder, I assumed that I had to create the UNDIONLY files and stared following those directions.


  • Developer

    even if the files were for some reason missing, you could just download them from the sourceforge page


  • Senior Developer

    if you installed FOG 1.1.2, you should no longer have the problem where the undionly.kpxe, or undionly.kkpxe do NOT exist.


  • Senior Developer

    So you’re still running 0.32?



  • because when I went to do this, it said it did not exist.
    [FONT=Consolas]cd /tftpboot
    mv undionly.kpxe undionly.kpxe.ORIGINAL
    ln -s undionly.kkpxe undionly.kpxe[/FONT]


  • Developer

    why are you building unidonly.kpxe? one is included with fog, that has fog-specific embedded scripting



  • Update: I have built a new UBUNTU desktop 14.04lts and have installed FOG 1.1.2 and I am to this point from the instructions on Building UNDIONLY.KPXE file (see link above) and I do not understand the “[B][FONT=sans-serif][COLOR=#000000]Remove the {}'s and only apply the file you wish to build if you want only a specific file.” from this part.[/COLOR][/FONT][/B]

    [FONT=sans-serif][COLOR=#000000]Build the undionly/ipxe files.[/COLOR][/FONT]
    [FONT=sans-serif][COLOR=#000000][B]I USE THE FOLLOWING COMMAND TO BUILD ALL FILES AT ONCE.[/B] [B]Remove the {}'s and only apply the file you wish to build if you want only a specific file.[/B][/COLOR][/FONT]
    [COLOR=#000000][FONT=monospace]make bin/{undionly,ipxe}.{,k,kk}pxe EMBED=ipxescript[/FONT][/COLOR]
    [SIZE=5][B][FONT=sans-serif][SIZE=19px][COLOR=#000000]Copy and/or Use your files[/COLOR][/SIZE][/FONT][/B][/SIZE]

    [FONT=sans-serif][COLOR=#000000][B]I USE THE FOLLOWING COMMAND TO COPY ALL FILES AT ONCE. Remove the {}'s and only copy the file you wish to use if you want only a specific file.[/B][/COLOR][/FONT]
    [COLOR=#000000][FONT=monospace]cp bin/{undionly,ipxe}.{,k,kk}pxe /tftpboot/ [/FONT][/COLOR]
    [COLOR=#000000][FONT=monospace]I ran the full command - make bin/{undionly,ipxe}.{,k,kk}pxe EMBED=ipxescript then realized it said to REMOVE the brackets should it be re-run but as[/FONT][/COLOR]
    [FONT=monospace]make bin/undionly,ipxe.,k,kk pxe EMBED=ipxescript[/FONT]
    [COLOR=#000000][FONT=monospace][/FONT][/COLOR]
    [COLOR=#000000][FONT=monospace][/FONT][/COLOR]


  • Developer

    what that’s talking about is not a “risk.” It’s a change in operating procedure. Before, OS was associated with hosts. but the actual operating system resides in the image. so, that’s where that info has been put now.
    you should, of course, be prepared for a catastrophic failure, as you should be at all times, and especially when performing a major upgrade. We recommend that you do a fresh install instead of an upgrade, and migrate your data over to the new server. that is because you’re much less likely to have issues that way. upgrading is, however, supported.


Log in to reply
 

347
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.