FOG Multicasting with a laptop



  • Hi,

    we currently have 2 machines working as a FOG server. One machine works for multicast just fine.
    The one we are currently having issues with is a Fujitsu A512 laptop with 8GB of RAM ([url]http://www.fujitsu.com/uk/products/computing/pc/notebooks/lifebook-a512/http://www.fujitsu.com/uk/products/computing/pc/notebooks/lifebook-a512/[/url]).
    It is running Ubuntu desktop 10.4.4 and FOG 0.32
    This FOG machine works fine for deploying an image to 1 or 2 machines, at most 3. But there seems to be an issue when you try to start imaging a new client, where it hangs at “Loading fog/kernel/bzimage…” and it will do this for quite a while. It can take any amount of time from 2 minutes to ten minutes until it progresses onto “Loading fog/images/init.gz…” and it will do this for quite a while too.

    This is our second day testing this, the first time we had 9 identical computers, and the most we could get at once was 3. Today we are testing it with random computers. The outcome is the same, we can get 3 to work, and it was difficult to even get that. The only way it seems to work is if all 3 boot at the same time. With our other server, you can jump in another computer without any issue.
    The furthest we have gotten is this screen (see photo 10) and if we are very lucky it might get to this screen (see photo 11). But at this screen it just hangs for quite a while, until the computers currently being imaged are done.

    I have changed the kernels around from the default kernel, to 2.6.35.3 PS and other PS versions, and it is still the same issue.
    I am positive that it is not the switch we are using, as I was able to deploy the image to 8 computers on Friday using our inhouse FOG server. I cant see any difference between the inhouse server and the laptop server except for the laptop hardware being the issue. But that is the only thing I can find to be the blame.

    If anyone has any pointers on this that would be great. Or if anyone would have any ideas of other things we could try.

    Greatly appreciated,

    Vinnie

    [url="/_imported_xf_attachments/1/1013_photo (10).JPG?:"]photo (10).JPG[/url][url="/_imported_xf_attachments/1/1014_photo (11).JPG?:"]photo (11).JPG[/url]



  • Sorry, I had left out that part, its an isolated network, so the only machines on it are those waiting to receive the image, and the FOG server.
    It is the same setup as our other FOG server, completely isolated.
    We had tried it on a different network initially and found this problem, so we isolated that network but FOG didn’t like the switch, so we changed over to our switch which we know works.
    Then came back to our Head Office and tested it again, and we had the same issues.

    We do think it could be an issue with the network, but are not sure how to resolve this. The laptop has a Gigabit port, and its connecting to a Gigabit switch.
    We are using a stock version of Ubuntu desktop 10.4.4, with a stock install of FOG. The only configuration I have made on the server was to set static IP for the lan connection.
    Is there anyway to test it against the network? As proof of the network being the issue?


  • Senior Developer

    It sounds, from what I can tell, like your network doesn’t like multicast traffic maybe?


Log in to reply
 

361
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.