Debug mode in 1.1.1



  • Howdy folks,

    Been a long time fog .[23]x user. Today decide to try out fog 1.1.1 with a fresh instal. SL6.5 base OS.

    Installed it, and then created a image. Modified our tftp server for one host (our clonemaster7 server)
    to use:

    next-server x.x.x.x;               // the fog server
    filename "undionly.kpxe";
    

    and finally got that server to boot to pxe menu. (learned a (little) bit about ipxe along the way, kinda cool)

    Oh, and figured out that a kernel download was needed and that if you have a 64 bit machine
    ( cpuid --ext 29 ) you are going to get a 64 bit kernel and (more important if you manually set to a 32 bit kernel that you know used to work fine with .32, then you will get a 64 bit initrd with that 32 bit kernel :)

    But when I tried to upload the image, I wound up having a failure, something about /dev/sda1 not available or some such. It blasted by to quickly.

    With trouble like this in .32 world I would go to “debug” boot to see what the kernel sees and sometimes
    even “run the fog steps” manually till we found the “problem”. But there doesn’t seem to be a debug option anymore. I imagine with some (more) research on ipxe I could find a incantation to have it boot the kernel with init=sh or somesuch, but I thought I would ask here first if there is a “official” way to do this.

    Thanks! Having high hopes for 1.0 branch, and hoping not to have to backport windows 8 crap into 0.32 :)

    E


  • Senior Developer

    Because of potential dangers that could happen while in debug we’ve removed this as a standard selection model. There two methods to still get debug though. First is to schedule a task as simply debug. This is probably easiest. Second method is to enable hidden menu and choose which key sequence you want to get back to menu. At boot it will ask for this key sequence. After pressing that key sequence you will receive a login prompt. Type in a valid fog GUI login and pass and it will display the menu with debug as we are all so used to. Hope this helps.


Log in to reply
 

424
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.