Can't reach domain names after starting dnsmasq



  • Hi,

    I am trying to set up a working fog server with ProxyDHCP. I use this howto: [url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/url]

    My problem is, that I can’t reach any domain names after
    [QUOTE]sudo service dnsmasq restart[/QUOTE]

    I can still reach sites by their ip addresses. For example “ping 193.99.144.80” is working but “ping heise.de” is not.

    I guess I made a simple error since I am not very experienced with linux.

    Here are some technical details:
    [LIST]
    []Kubuntu 12.04 (updated)
    [
    ]Fog 1.1.1
    [/LIST]
    Content of /etc/network/interfaces

    [QUOTE]auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet static
    address 192.168.1.254
    netmask 255.255.255.0
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1[/QUOTE]

    Content of /etc/dnsmasq.d/ltsp.conf

    [QUOTE]# Don’t function as a DNS server:
    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Dnsmasq can also function as a TFTP server. You may uninstall

    tftpd-hpa if you like, and uncomment the next line:

    enable-tftp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address

    dhcp-boot=undionly.kpxe,fog-Aspire-5110,192.168.1.254

    rootpath option, for NFS

    #dhcp-option=17,/images

    kill multicast

    #dhcp-option=vendor:pXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    A boot service type of 0 is special, and will abort the

    net boot procedure and continue booting from local media.

    #pxe-service=X86PC, “Boot from local hard disk”, 0

    If an integer boot service type, rather than a basename is given, then the

    PXE client will search for a suitable boot service for that type on the

    network. This search may be done by multicast or broadcast, or direct to a

    server if its IP address is provided.

    pxe-service=x86PC, “Install windows from RIS server”, 1

    [/QUOTE]

    I am really unsure which settings I should make in this file. According to [url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP#DNSMASQ_settings_for_iPXE[/url] fog >=0.33 needs different settings than earlier versions.

    Could anybody help please?

    Tob



  • [quote=“Tom Elliott, post: 30393, member: 7271”]Based on this is 192.168.1.1 the appropriate DNS Server for your setup?[/quote]

    Yes

    [quote=“Tom Elliott, post: 30393, member: 7271”]
    Is this DNS Server a forwarder or just the DNS Masked from your router?[/quote]

    I think it is just the DNS Masked from my router.

    [quote=“Tom Elliott, post: 30393, member: 7271”]
    Typically 192.168.1.1 is the Gateway address for home routers. This same gateway also translates to your ISP’s DNS Servers, or the DNS Server’s you’ve put in place to override your ISP’s DNS server. Why is this important to know? Most typically, the “Masking” of the DNS to your router’s gate is done via DNSMasq, the same protocol you’re trying to use to PXE boot your servers.

    With that said, you could try commenting out the:
    [code]port=0[/code]

    You do this by making it:
    [code]#port=0[/code]

    Then restart the dnsmasq service.
    [/quote]

    This solved the problem.

    Thank you very much!
    Tob


  • Senior Developer

    [quote=“Tob, post: 30331, member: 24647”]Hi,

    I am trying to set up a working fog server with ProxyDHCP. I use this howto: [url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/url]

    My problem is, that I can’t reach any domain names after

    I can still reach sites by their ip addresses. For example “ping 193.99.144.80” is working but “ping heise.de” is not.[/quote]
    Based on this is 192.168.1.1 the appropriate DNS Server for your setup? Is this DNS Server a forwarder or just the DNS Masked from your router? Typically 192.168.1.1 is the Gateway address for home routers. This same gateway also translates to your ISP’s DNS Servers, or the DNS Server’s you’ve put in place to override your ISP’s DNS server. Why is this important to know? Most typically, the “Masking” of the DNS to your router’s gate is done via DNSMasq, the same protocol you’re trying to use to PXE boot your servers.

    With that said, you could try commenting out the:
    [code]port=0[/code]

    You do this by making it:
    [code]#port=0[/code]

    Then restart the dnsmasq service. I doubt, though, that this will fix anything with your setup. Reason being, because I don’t know at what stage you’re unable to ping domain names such as heise.de.

    Could you give is the output of your /etc/resolv.conf file? This is the file, in linux, that contains the DNS address and search domain settings. Normally it’s in the format of:
    [code]; generated by /sbin/dhclient-script
    ;Commented lines in /etc/resolv.conf are preceded with semicolon
    search localhost.localdomain ;Domain to search within
    nameserver 10.10.10.1 ;Usually only your gateway is listed.
    nameserver 208.67.222.222 ;secondary DNS to look up.
    nameserver 208.67.220.220 ;third dns to look up as needed.[/code]

    [quote=“Tob, post: 30331, member: 24647”]I guess I made a simple error since I am not very experienced with linux.

    Here are some technical details:
    [LIST]
    []Kubuntu 12.04 (updated)
    [
    ]Fog 1.1.1
    [/LIST]
    Content of /etc/network/interfaces

    Content of /etc/dnsmasq.d/ltsp.conf

    I am really unsure which settings I should make in this file. According to [url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP#DNSMASQ_settings_for_iPXE[/url] fog >=0.33 needs different settings than earlier versions.

    Could anybody help please?

    Tob[/quote]



  • [quote=“TheWizardUk, post: 30345, member: 22823”]are you using dnsmasq for a DNS server or just to pick up your fog server on PXE boot without needing to mod you DHCP server?[/quote]

    I just need dnsmasq because it wouldn’t be possible to mod the DHCP server.

    [quote=“TheWizardUk, post: 30345, member: 22823”]
    is that all of your ltsp.conf?
    [/quote]

    Yes.

    [quote=“TheWizardUk, post: 30345, member: 22823”]
    when PXE booting does it redirect to your fog server?[/quote]
    Yes.



  • Hi Tob

    i was running dnsmasq without any issue

    are you using dnsmasq for a DNS server or just to pick up your fog server on PXE boot without needing to mod you DHCP server?

    is that all of your ltsp.conf?

    when PXE booting does it redirect to your fog server?


Log in to reply
 

362
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.