Client can't find the pxelinux.0 file debian squeeze ddwrt dhcp server



  • Hello I’m setting up fog for our tiny computer store and I have done quite a bit of research but I can’t shake this issue out with my own troubleshooting.

    I setup the server with debian squeeze CLI, no GUI, setup mysql and edited the two config files with the root user/password properly. I can access the fog control panel and create the database. No real issues there.

    I setup the ddwrt with the suggested line in the wiki to send clients looking for pxe to my server address.

    The server IP is 192.168.0.155

    I can’t get to the fog menu because it can’t locate the pxelinux.0 file. I loaded up a gpxe boot cd hoping for more info and thankfully was shown a bit more. It seems that the client is looking for the file at the following:

    tftp://192.168.0.155/pxelinux.0

    I may have the tftp:// part wrong as I’m working from memory but I believe that was the beginning of the address. It doesn’t seem to be finding the file or perhaps there is not enough permission for the file. I’ll take that as good news though that the ddwrt is sending my client to the right place and that there may be a path I need to change in one of the configuration files or perhaps a file permission.

    The fog server is not handling DHCP at all. I just want to make that clear. My testbed just consists of a router hooked up to my pxe server and a test machine on the bench right now. I can’t put this live on our own network or the internet until I can make sure it works well and lock down some other potential security issues on the server being that it is a fresh install.

    I searched the forums but was unable to find a string that brought my issue forward. I may just be tired though, actually caused me a bit of grief on valentines day here as I put a little too much extra time in at the shop trying to get it going before I left heheh.



  • I got it working! thanks

    the solution was right on the front page of the fog website for servers running debian



  • Thanks for the input, the file does exist in /tftpboot and the web console looks like this.

    [IMG]http://i.imgur.com/OpiiV.jpg[/IMG]



  • Check that the pxelinux.0 file exists on the server, its stored in /tftpboot and logon to the webconsole and check the tftp server section in fog settings.


Log in to reply
 

418
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.