./default.ipxe Timeout During pxe boot|FOG 1.1.0|Ubuntu 14.04|proxyDNS|Worked on Home Network



  • Before anyone asks, same IP settings at both locations (I build at home cause we have only 2gb data of Internet data at work - sucks to be me)
    Worked on earlier versions no problem
    Here is what I did:
    Installed Ubuntu (no seriously I’m being thorough)
    [CODE]1. Install Ubuntu
    a. Standard Setup – make sure no auto-login
    b. Setup Static IP
    c. Update Ubuntu
    i. sudo –s
    ii. apt-get install aptitude
    iii. aptitude update
    iv. aptitude safe-upgrade
    d. Reboot
    i. shutdown –r now
    [/CODE]
    Enable Root - PLEASE UPDATE THE WIKI ON THIS - the wiki’s instructions are incorrect for 14.04
    [CODE]2. Enable Root
    a. sudo su –
    b. passwd root
    c. nano /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf
    d. add line  greeter-show-manual-login=true
    e. ctrl-x, y, <enter>
    f. shutdown –r now
    [/CODE]
    Next I set up Samba. Not going into the exact settings and shares
    [CODE]1. Install Samba
    a. sudo –s
    b. apt-get install samba samba-common system-config-samba python-glade2 gksu
    c. Open Unity Dash, search for and open Samba
    d. PreferencesServer Settings
    e. Under Basic Tab
    i. Workgroup – Same as your windows workgroup name
    ii. Description – The name of your computer host
    iii. Do not change Security tab
    iv. OK
    f. To share a folder, click the green + (plus) button in Samba Server Configuration tool and you can then easily set the directory, name, read/write permissions and access users.
    g. In terminal  restart smbd && restart nmbd
    [/CODE]
    Now to set up fog. NO I did not use it as a DHCP server, lots of reasons why I won’t get into, so as you will see later I used proxyDHCP:
    [CODE]1. Download FOG
    a. Download fog:
    http://sourceforge.net/projects/freeghost/files/FOG/fog_1.1.0/fog_1.1.0.tar.gz/download
    b. Extract to the Desktop

    1. Install Fog
      a. cd Desktop/
      b. cd fog_1.1.0
      c. cd packsages
      d. wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/udpcast-20120424.tar.gz
      e. rm –f udpcast-20071228.tar.gz
      f. sed – I ‘s:udpcastout=”udpcast-20071228”:udpcastout=”udpcast-20120424.tar.gz …/lib/common/config.sh
      g. sed -i ‘s:udpcastsrc="…/packages/udpcast-20071228.tar.gz":udpcastsrc="…/packages/udpcast-20120424.tar.gz":’ …/lib/common/config.sh
      h. cd …/bin/
      i. sudo ./installfog.sh
      j. Choose “Ubuntu” install
      k. Choose “Normal” install
      l. Verify static address (I know the next steps aren’t precise)
      m. Type N not to set up DHCP
      n. Type N not to set up DNS
      o. Choose Default Network Card (eth0)
      p. Disable DHCP service
      q. Type N to not install Additional Languages
      r. Type Y to start install
      s. When prompted for a MYSQL password, use same password as root
      t. Type N to send install information
      u. ln -s /var/www/fog /var/www/html/fog
      v. nano /var/www/fog/commons/config.php
      i. make sure MySQL password is the root’s password
      w. shutdown –r now
      NOTE: yes the next part is bit puzzling why I had to do it…but yes you have to do it
      x. From a remote box, http://<ip-of-Fog>/fog/management
      y. Go to Fog SettingsTFTP Settings
      i. Note the password (click on icon to see it)
      z. Use ssh client (Putty) to remote in to terminal
      aa. sudo su –
      bb. passwd fog
      i. type in password you noted previously
      cc. nano /var/www/html/fog/commons/config.php
      i. Check the values of TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD
      1. Make sure the passwords match the password previously noted
      dd. shutdown –r now
    2. proxyDNS (use putty to remote in to remote in to terminal)
      a. sudo –s
      b. nano /etc/exports
      i. /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
      ii. /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
      c. apt-get install dnsmasq
      d. nano /etc/dnsmasq.d/ltsp.conf
      i. Code:

    Don’t function as a DNS server:

    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Dnsmasq can also function as a TFTP server. You may uninstall

    tftpd-hpa if you like, and uncomment the next line:

    enable-tftp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address (replace x.x.x.x with static IP)

    dhcp-boot=undionly.kpxe,x.x.x.x

    rootpath option, for NFS

    #dhcp-option=17,/images

    kill multicast

    #dhcp-option=vendor:PXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    A boot service type of 0 is special, and will abort the

    net boot procedure and continue booting from local media.

    #pxe-service=X86PC, “Boot from local hard disk”, 0

    If an integer boot service type, rather than a basename is given, then the

    PXE client will search for a suitable boot service for that type on the

    network. This search may be done by multicast or broadcast, or direct to a

    server if its IP address is provided.

    pxe-service=x86PC, “Install windows from RIS server”, 1

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=10.0.0.10,proxy,255.255.0.0

    This range(s) is for the private network on 2-NIC servers,

    where dnsmasq functions as a normal DHCP server, providing IP leases.

    dhcp-range=192.168.0.20,192.168.0.250,8h

    For static client IPs, and only for the private subnets,

    you may put entries like this:

    dhcp-host=00:20:e0:3b:13:af,10.160.31.111,client111,infinite

                      ii.    cd /tftpboot
                      iii.    ln – undionly.kpxe undionly.0
                      iv.    service tftpd-hpa restart
                      v.    service dnsmasq restart
    

    [/CODE]
    Yea it worked a home, came to work, stopped working
    ./default.ipxe time out
    Help!



  • correct


  • Senior Developer

    That’s of course the regular network is not the same as your DD WRT network


  • Senior Developer

    It would still be



  • yes, but we want to set up as though its on the regular network


  • Senior Developer

    If you’re running DD WRT on the routers couldnt you just use the services Dhcp-boot options to point at TFTP rather than using proxy DHCP?



  • Figured it out. We use dd-wrt on our routers, and someone turned on DNSMasq on the router…so I had 2 DNSMasq running…turned it off on the router…viola.

    Curious though how that wasn’t an issue with previous versions of FOG.



  • Spanning Tree Protocol disabled



  • I know you said that they are identical switch config - but just in case. I was playing with STP and it created some odd issues. Does your work switch have STP enabled?



  • [QUOTE]If you open the file /tftpboot/default.ipxe in a text editor, does the ip information look correct?
    [/QUOTE]
    Yes it does
    [QUOTE]#!ipxe
    cpudi – ext 29 && set arch x86_64 || set arch i386
    params
    param mac ${net0/mac}
    param arch ${arch}
    chain [url]http://192.168.1.108/fog/service/ipxe/boot.php##params[/url]
    [/QUOTE]
    [QUOTE]sudo chown -R fog:root /tftpboot[/QUOTE]
    Done and tested no change
    [QUOTE]sudo ufw disable[/QUOTE]
    Done and tested no change


  • Senior Developer

    If you open the file /tftpboot/default.ipxe in a text editor, does the ip information look correct?

    Is the permissions of the /tftpboot/ folder set properly?

    [code]sudo chown -R fog:root /tftpboot[/code]
    Is the firewall disabled?
    [code]sudo ufw disable[/code]



  • [QUOTE]First, I’m confused by this statement : “we have only 2gb data of Internet data at work - sucks to be me” .[/QUOTE]

    It’s not really the issue here, its a separate test network. Totally isolated from main network. They limit us on Internet so we won’t “play”.

    [QUOTE]At anyrate, the default.ipxe time out issue, what do you mean? You came to work and it stopped working? Are you trying to access your home network to pxe boot? Or are you bringing the system in to your work place? [/QUOTE]

    Not trying to access my home network at all. I built it at home, worked fine. It’s a duplicate network (besides the internet), same router and switch configuration. Testing with previous versions of FOG and Ubuntu (built at home/used at work) had no issue with default.ipxe and went to PXE menus. But we wanted to go with Ubuntu 14.04, company reasons not mine. Now the default.ipxe connection times out.


  • Senior Developer

    [quote=“JoeWagner, post: 30197, member: 24634”]Before anyone asks, same IP settings at both locations (I build at home cause we have only 2gb data of Internet data at work - sucks to be me)
    Worked on earlier versions no problem
    Here is what I did:
    Installed Ubuntu (no seriously I’m being thorough)
    [CODE]1. Install Ubuntu
    a. Standard Setup – make sure no auto-login
    b. Setup Static IP
    c. Update Ubuntu
    i. sudo –s
    ii. apt-get install aptitude
    iii. aptitude update
    iv. aptitude safe-upgrade
    d. Reboot
    i. shutdown –r now
    [/CODE]
    Enable Root - PLEASE UPDATE THE WIKI ON THIS - the wiki’s instructions are incorrect for 14.04
    [CODE]2. Enable Root
    a. sudo su –
    b. passwd root
    c. nano /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf
    d. add line  greeter-show-manual-login=true
    e. ctrl-x, y, <enter>
    f. shutdown –r now
    [/CODE]
    Next I set up Samba. Not going into the exact settings and shares
    [CODE]1. Install Samba
    a. sudo –s
    b. apt-get install samba samba-common system-config-samba python-glade2 gksu
    c. Open Unity Dash, search for and open Samba
    d. PreferencesServer Settings
    e. Under Basic Tab
    i. Workgroup – Same as your windows workgroup name
    ii. Description – The name of your computer host
    iii. Do not change Security tab
    iv. OK
    f. To share a folder, click the green + (plus) button in Samba Server Configuration tool and you can then easily set the directory, name, read/write permissions and access users.
    g. In terminal  restart smbd && restart nmbd
    [/CODE]
    Now to set up fog. NO I did not use it as a DHCP server, lots of reasons why I won’t get into, so as you will see later I used proxyDHCP:
    [CODE]1. Download FOG
    a. Download fog:
    http://sourceforge.net/projects/freeghost/files/FOG/fog_1.1.0/fog_1.1.0.tar.gz/download
    b. Extract to the Desktop

    1. Install Fog
      a. cd Desktop/
      b. cd fog_1.1.0
      c. cd packsages
      d. wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/udpcast-20120424.tar.gz
      e. rm –f udpcast-20071228.tar.gz
      f. sed – I ‘s:udpcastout=”udpcast-20071228”:udpcastout=”udpcast-20120424.tar.gz …/lib/common/config.sh
      g. sed -i ‘s:udpcastsrc="…/packages/udpcast-20071228.tar.gz":udpcastsrc="…/packages/udpcast-20120424.tar.gz":’ …/lib/common/config.sh
      h. cd …/bin/
      i. sudo ./installfog.sh
      j. Choose “Ubuntu” install
      k. Choose “Normal” install
      l. Verify static address (I know the next steps aren’t precise)
      m. Type N not to set up DHCP
      n. Type N not to set up DNS
      o. Choose Default Network Card (eth0)
      p. Disable DHCP service
      q. Type N to not install Additional Languages
      r. Type Y to start install
      s. When prompted for a MYSQL password, use same password as root
      t. Type N to send install information
      u. ln -s /var/www/fog /var/www/html/fog
      v. nano /var/www/fog/commons/config.php
      i. make sure MySQL password is the root’s password
      w. shutdown –r now
      NOTE: yes the next part is bit puzzling why I had to do it…but yes you have to do it
      x. From a remote box, http://<ip-of-Fog>/fog/management
      y. Go to Fog SettingsTFTP Settings
      i. Note the password (click on icon to see it)
      z. Use ssh client (Putty) to remote in to terminal
      aa. sudo su –
      bb. passwd fog
      i. type in password you noted previously
      cc. nano /var/www/html/fog/commons/config.php
      i. Check the values of TFTP_FTP_PASSWORD and STORAGE_FTP_PASSWORD
      1. Make sure the passwords match the password previously noted
      dd. shutdown –r now
    2. proxyDNS (use putty to remote in to remote in to terminal)
      a. sudo –s
      b. nano /etc/exports
      i. /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
      ii. /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
      c. apt-get install dnsmasq
      d. nano /etc/dnsmasq.d/ltsp.conf
      i. Code:

    Don’t function as a DNS server:

    port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Dnsmasq can also function as a TFTP server. You may uninstall

    tftpd-hpa if you like, and uncomment the next line:

    enable-tftp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address (replace x.x.x.x with static IP)

    dhcp-boot=undionly.kpxe,x.x.x.x

    rootpath option, for NFS

    #dhcp-option=17,/images

    kill multicast

    #dhcp-option=vendor:PXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    A boot service type of 0 is special, and will abort the

    net boot procedure and continue booting from local media.

    #pxe-service=X86PC, “Boot from local hard disk”, 0

    If an integer boot service type, rather than a basename is given, then the

    PXE client will search for a suitable boot service for that type on the

    network. This search may be done by multicast or broadcast, or direct to a

    server if its IP address is provided.

    pxe-service=x86PC, “Install windows from RIS server”, 1

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=10.0.0.10,proxy,255.255.0.0

    This range(s) is for the private network on 2-NIC servers,

    where dnsmasq functions as a normal DHCP server, providing IP leases.

    dhcp-range=192.168.0.20,192.168.0.250,8h

    For static client IPs, and only for the private subnets,

    you may put entries like this:

    dhcp-host=00:20:e0:3b:13:af,10.160.31.111,client111,infinite

                      ii.    cd /tftpboot
                      iii.    ln – undionly.kpxe undionly.0
                      iv.    service tftpd-hpa restart
                      v.    service dnsmasq restart
    

    [/CODE]
    Yea it worked a home, came to work, stopped working
    ./default.ipxe time out
    Help![/quote]

    First, I’m confused by this statement : “we have only 2gb data of Internet data at work - sucks to be me” What do you mean you only have 2GB of data, how is your work place even able to operate? I could maybe see this being true if you’re referring to a cell phone data plan, but of “at work” scenarios would seem to be unable to operate in any type of capacity. Or do you mean your Bandwidth cap is at 2GB? Bandwidth and data plans are two completely separate ideas.

    At anyrate, the default.ipxe time out issue, what do you mean? You came to work and it stopped working? Are you trying to access your home network to pxe boot? Or are you bringing the system in to your work place?


Log in to reply
 

858
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.