Setting up and building UDPCast...Failed!



  • I had this problem when upgrading from fog .32 to fog 1.0.1, I was never able to solve it. I am now trying to install fog 1.1.0 and still having the same issue.

    Here is the error:

    Are you sure you wish to continue (Y/N) y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Packages to be installed: httpd php php-cli php-common php-gd php-mysql mysql mysql-server tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ lftp

    • Skipping package: httpd (Already installed)

    • Skipping package: php (Already installed)

    • Skipping package: php-cli (Already installed)

    • Skipping package: php-common (Already installed)

    • Skipping package: php-gd (Already installed)

    • Skipping package: php-mysql (Already installed)

    • Skipping package: mysql (Already installed)

    • Skipping package: mysql-server (Already installed)

    • Skipping package: tftp-server (Already installed)

    • Skipping package: nfs-utils (Already installed)

    • Skipping package: vsftpd (Already installed)

    • Skipping package: net-tools (Already installed)

    • Skipping package: wget (Already installed)

    • Skipping package: xinetd (Already installed)

    • Skipping package: tar (Already installed)

    • Skipping package: gzip (Already installed)

    • Skipping package: make (Already installed)

    • Skipping package: m4 (Already installed)

    • Skipping package: gcc (Already installed)

    • Skipping package: gcc-c++ (Already installed)

    • Skipping package: lftp (Already installed)

    Confirming package installation.

    • Checking package: httpd…OK
    • Checking package: php…OK
    • Checking package: php-cli…OK
    • Checking package: php-common…OK
    • Checking package: php-gd…OK
    • Checking package: php-mysql…OK
    • Checking package: mysql…OK
    • Checking package: mysql-server…OK
    • Checking package: tftp-server…OK
    • Checking package: nfs-utils…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: make…OK
    • Checking package: m4…OK
    • Checking package: gcc…OK
    • Checking package: gcc-c++…OK
    • Checking package: lftp…OK

    Configuring services.

    • Setting up fog user…Exists

    • Setting up and starting MySQL…OK

    • Backing up user reports…OK

    • Did you leave the mysql password blank during install? (Y/n) y

    • Setting up and starting Apache Web Server…OK
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:

      [url]http://10.30.1.31/fog/management[/url]

    Press [Enter] key when database is updated/installed.

    • Configuring Fresh Clam…Skipped (See wiki for installation instructions)
    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…Skipped
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…Failed!

    ./configure failed!

    Script done, file is /var/log/foginstall.log



  • when i try to build udpcast manualy i get the following error’s

    root@fog:/root/udpcast-20120424# ./configure
    checking for gcc… gcc
    checking whether the C compiler works… yes
    checking for C compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… configure: error: in /root/udpcast-20120424': configure: error: cannot run C compiled programs. If you meant to cross compile, use–host’.
    See `config.log’ for more details.



  • Thank you!

    I edited my config and functions files as you suggested, and everything seems to have installed successfully.

    Thanks for your time


  • Senior Developer

    I believe so, but if you’re using /tmp as a mount point for /dev/mapper/VG0-tmp (as I imagine from the second line) you need to give the permissions to write and build. That or you could edit the location for the file to be extracted and built.

    Edit (the installer folder where you cd bin then type ./installfog.sh) fog_1.1.0/lib/common/config.sh

    The line number 37 current reads as:
    [code]udpcasttmp="/tmp/udpcast.tar.gz";[/code]
    Make it somewhere else such as:
    [code]udpcasttmp="/root/udpcast.tar.gz";[/code]
    Then save the file.

    Then in the file fog_1.1.0/lib/common/functions.sh
    The line number 128 currently reads as:
    [code]cd /tmp;[/code]
    Make it in the same location you’re placing the udpcast.tar.gz such as:
    [code]cd /root;[/code]

    Then save the file and try installing again.

    If all is good you should have udp-cast installed successfully.



  • Morning Tom. My tmpfs is not mounted in the /tmp folder. Here is my tmpfs line:
    tmpfs /dev/shm tmpfs defaults 0 0

    I do however, have this line in here as well:
    /dev/mapper/VG0-tmp /tmp ext4 nodev,noexec,nosuid 1 2

    This is the line I was editing yesterday:
    /tmp /var/tmp none rw,bind 0 0

    When I make changes to this file I should be able to just run “mount -a” afterwords, correct?


  • Senior Developer

    Can you try this for your tmp line:
    [code]tmpfs /tmp tmpfs defaults,noatime 0 0[/code]

    And reboot of course.



  • I made the changes as you suggested, then rebooted the server. I see the changes have been made to the fstab file. Still getting the same error, however.


  • Senior Developer

    You’ll have to unmount and remount /tmp, but that can be dangerous. Restart the system and you should be good.



  • I still get the same error: Setting up and building UDPCast…Failed!

    I removed noexec and nosuid from that line.

    Is there another step I need to take? Here is the new line:

    /tmp /var/tmp none rw,bind 0 0

    I really appreciate your help by the way. This has been bothering me for a while and I have done a lot of troubleshooting.


  • Senior Developer

    Yes, that is what I was asking, and that’s why you’re getting that message.

    noexec,nosuid should not be there. UDPcast can’t build the files because it can’t execute the configure script in the /tmp folder.



  • When I open /etc/fstab this is wha the /tmp line looks like:

    /tmp /var/tmp none rw,noexec,nosuid,nodev,bind $

    Is this what you were asking? I am using Centos 6.4 by the way.


  • Senior Developer

    Is your /tmp folder, by chance, not able to be executable?

    For example, in the /etc/fstab for /tmp, is there defaults,noexec?


Log in to reply
 

474
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.