Slow attempting to register host and deployment problems



  • This morning everything was working fine. I have 1.1.0 installed on Ubuntu server 12.04 LTS. I had updated to the latest kernel. Same issue when reverting to an older kernel. Now when performing full host registration it hangs up at

    Attempting to register host…

    This moves slowly up the screen until it can no longer be seen. It never goes on unless the machine is restarted. Looking in the web GUI I can see where the host is registered but it also did not assign an image to it nor did it start imaging as we had selected it to. This is happening on all our clients that we attempt to register now. We are also getting a /default.pxe message on ipxe boot as well on some clients

    Any help would be appreciated greatly


  • Senior Developer

    Okay,

    I found and corrected this bug. It is up in svn at 1862. Thanks for reporting.



  • yes upon asking for image where you can enter an image ID i have been typing one in. but upon it loading into the web GUI it shows no image assigned so then in order to image i have to assign from web GUI and push out from GUI or do a quick image.


  • Senior Developer

    Okay, so how can you tell it to image, but not assign an image to it?

    What I mean, is the fog scripts don’t know that a false or that no image has occurred.

    Are you giving the system, during registration time, an image ID to work.



  • I have found that if I do not tell it that i would like to image the host when performing full host registration, It goes ahead and send inventory and registers but still does not assign an image association. But it most certainly does hang up when telling it to image during that same process. I can image other wise thru the web GUI with no problem, except on some Quad Cores that we possess in our District still giving a dhcp/bootp reply not for us error.



  • bump



  • this is the install log for fog
    Script started on Thu 12 Jun 2014 03:19:26 PM CDT

       ..#######:.    ..,#,..     .::##::.    
    

    .:###### .:;####:…;#;…
    …##… …##;,;##::::.##…
    ,# …##…##:::## …::
    ## .::###,##. . ##.::#.:######::.
    …##:::###::…#. … .#…#. #…#:::.
    …:####:… …##…##::## … #
    # . …##:,;##;:::#: … ##…
    .# . .:;####;::::.##:::;#:…
    # …:;###…

    ###########################################

    FOG

    Free Computer Imaging Solution

    http://www.fogproject.org/

    Developers:

    Chuck Syperski

    Jian Zhang

    Peter Gilchrist

    Tom Elliott

    GNU GPL Version 3

    ###########################################

    Version: 1.1.0 Installer/Updater

    What version of Linux would you like to run the installation for?

          1) Redhat Based Linux (Redhat, CentOS) 
          2) Debian Based Linux (Debian, Ubuntu, Kubuntu, Edubuntu) 
    

    Choice: http://www.fogproject.org/wiki/index.php?title=InstallationModes

    What type of installation would you like to do? http://fogproject.org/?q=cryptocurrency

    Would you like to donate computer resources to the FOG Project? http://www.fogproject.org/wiki

    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 10.10.150.224
    DHCP router Address: 10.10.150.12
    DHCP DNS Address: 10.10.150.12
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0
    Donate: 0

         DHCP will NOT be setup but you must setup your 
         current DHCP server to use FOG for PXE services. 
    
         On a Linux DHCP server you must set: 
             next-server 
    
         On a Windows DHCP server you must set: 
             option 066 & 067 
    
           Option 066 is the IP of the FOG Server: (e.g. 10.10.150.224 
           Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe) 
    

    Are you sure you wish to continue (Y/N) Y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Installing package: apache2

    • Installing package: php5

    • Installing package: php5-json

    • Installing package: php5-gd

    • Installing package: php5-cli

    • Installing package: php5-mysql

    • Installing package: php5-curl

    • Installing package: mysql-server

      We are about to install MySQL Server on
      this server, if MySQL isn’t installed already
      you will be prompted for a root password.

      Press enter to acknowledge this message.

    Reading package lists…
    Building dependency tree…
    Reading state information…
    mysql-server is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

    • Installing package: mysql-client
    • Installing package: tftpd-hpa
    • Installing package: tftp-hpa
    • Installing package: nfs-kernel-server
    • Installing package: vsftpd
    • Installing package: net-tools
    • Installing package: wget
    • Installing package: xinetd
    • Installing package: sysv-rc-conf
    • Installing package: tar
    • Installing package: gzip
    • Installing package: build-essential
    • Installing package: cpp
    • Installing package: gcc
    • Installing package: g++
    • Installing package: m4
    • Installing package: htmldoc
    • Installing package: lftp
    • Installing package: openssh-server
    • Installing package: php-gettext
    • Installing package: clamav-freshclam

    Confirming package installation.

    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-json…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-mysql…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK
    • Checking package: clamav-freshclam…OK

    Configuring services.

    • Setting up fog user…Exists

    • Setting up and starting MySql…OK

    • Backing up user reports…OK

    • Did you leave the mysql password blank during install? (Y/n) N

    • Please enter your mysql password:

    • Please re-enter your mysql password:

    • Setting up and starting Apache Web Server…OK
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:

      http://10.10.150.224/fog/management

    Press http://10.10.150.224/fog/management

      Default User: 
             Username: fog 
             Password: password 
    

    Script done on Thu 12 Jun 2014 03:22:47 PM CDT



  • I tried a fresh install of the server and am still receiving the same error. Here is the log from a recent instance of the registration process

    http://10.10.150.224/fog/management/
    df: `/images’: No such file or directory
    df: no file systems processed
    http://10.10.150.224/fog/management/index.php?node=about&sub=kernel-update
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/index.php?node=about&sub=kernel-update
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/index.php?node=about&sub=settings
    http://10.10.150.224/fog/management/index.php?node=logout
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/css/jquery-ui.css
    http://10.10.150.224/fog/management/index.php?node=about&sub=kernel-update
    http://10.10.150.224/fog/management/index.php?node=about&sub=kernel-update
    [Thu Jun 12 14:57:41 2014] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.11 with Suhosin-Patch configured – resuming normal operations


  • Senior Developer

    So, your config.php file now has a password set in the password field for the db_settings information?

    the /default.ipxe file is not an error, ipxe’s telling you it loaded. You know how you can tell? Because you’re being booted into the FOG OS Layer (the attempting to register host).

    Active Directory Server would not be causing the problems you’re currently seeing. The fact that he host registers, but doesn’t have the image set is telling me something, but I need error logs during the time that this message is repeating. If you type letters on the screen while it’s (eventually going blank) you’ll actually see it’s just in a loop trying to send the data. Why it’s not is at a loss to me at the moment.



  • mysql showed no password for root in settings. But remove mysql totally from ubuntu and reinstalled it. set up a password this time and still having same problem. Is there any chance an Active Directory server could be causing these problems?


  • Senior Developer

    Did you set a password for MySQL? My guess is this is your current issue. Check the /var/www/fog/commons/config.php db_settings and make sure they’re set correctly for your environment.



  • it is /default.ipxe

    Here is a portion of the error log for that day.

    ed Jun 11 08:06:07 2014] http://corefog/fog/management/index.php?node=about&sub=kernel&install=1&file=aHR0cDovL21hc3RhY29udHJvbGEuY29tL2ZvZ2Jvb3Qva2VybmVsL0tlcm5lbC5Ub21FbGxpb3R0LjMuMTAuMS42NA==
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::mysqli(): (HY000/2002): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /var/www/fog/lib/db/MySQL.class.php on line 64
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::select_db(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 165
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/fog/lib/db/MySQL.class.php on line 150
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::mysqli(): (HY000/2002): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) in /var/www/fog/lib/db/MySQL.class.php on line 64
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::select_db(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 165
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/fog/lib/db/MySQL.class.php on line 150
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 89
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247
    [Wed Jun 11 08:09:58 2014] [error] [client 10.10.80.52] PHP Warning: mysqli::escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 247


  • Senior Developer

    You’re seeing /default.pxe or /default.ipxe?

    What are in your error logs? You state that none of your systems are working, this leads me to believe some kind of configuration issue.


Log in to reply
 

350
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.