Fog crashing during image deployment

  • I setup a fog server last year for a school I work at. It worked wonderfully, I started imaging some new laptops the last week of last year. Finally found some time to finish them off but now fog keeps crashing randomely during the deployment. I havn’t touched the fog server or its configuration over the holidays. All i’ve done at this site over the holidays was install a few new cisco switches to get a gigabit link around the whole school. Here are a few screenshots.


    Any thoughts?

  • hey just an update for you guys, I got it working by using a dumb switch the managed cisco I was using as a image station was having issues. Unlike other cisco switches that flood the network when fog multicast my switch (cisco 2960) just stopped broadcasting causing fog to think the imahe ahd finished deploying causing me all sorts of MBR issues etc on the laptops. I’ll have a look in the switches config and see if I can find a fix but for now i’m just happy I can finish this roll out of laptops easily, albeit much slower than the cisco switch but atleast it works!

    Thanks to all!


  • Those were my thoughts but it’s not that simple. I will try the new kernel and see if that fixes it, if not I will diagnose the network and see where my packets are going. I have fog on a hyper-v server along with 3 other windows servers on the same box. I installed 3 new switches at the school (cisco 2960’s). This may be interferring somehow. I need to check out the switch management to see if I can see any settings I need to change to get fog to work correctly. Thanks for the help guys. Will let you know how I go on wednesday as thats when i’m back at that site.

  • Sounds like a network or server problem since you cant reach the website. Does it timeout or give you a error when you try top open it?
    Do other services on the server stop working too? (try ftp & ping).
    If services don’t work does the console work? Can you reach other computers from it?
    Id check the server log files and try plugging the fog server back into the old switch together with a computer that your gonna image and see if that works.

  • it does look like a cooked hdd but it isn’t as this happens on all 10 laptops i’m trying to image. They are brand new. I’ll try the kernel tomorrow as i’m not at the site today, I hope the new kernel fixes my problem but i’m doubtful as this image was working fine a few months ago.

    Is there anyway that moving switches around could have broken fog? Sometimes I can’t get to /fog/management/ without a restart of the server. This has only happened this year.

    Thanks for the help!:)

  • The second screenshot looks like it’s a bad HDD. Have you tried replacing it?

  • Here’s a link for all the Kernels that are available. You’ll have to SFTP the file to the server and put in in “/tftproot/fog/kernels/”. You’ll need to rename the file to “bzImage”. You might also want to ‘chown’ and ‘chgrp’ to the account “fog” as well to make sure permissions are correct. I’m using the latest kernel right now at 3 different sites and not experiencing any issues with it.


    Hope this helps.

  • Thanks for that I went to try that yesterday but I’m behind a proxy which is causing troubles. I don’t have direct access to the proxy server to tweak it either. Is there anywhere else I can grab the new kernel from? Thanks mate.

  • Try upgrading the kernel. This can be done easily from fog settings in web console.