Upload image get's to 99% completion and then fails.



  • Ubuntu 11.10
    FOG 0.32

    Hey guys, I have been been trying to solve this problem for a couple of days now. Basically, I have everything working fine as far as PXE and clients booting and communicating with my FOG server. However, I have been trying to upload my first image to the server and it fails at 99%: Failed to write /images/xxxxxxxxxxxx.000 to /images/BaseXP (this is from my personal memory) and it will continue to repeat this.

    I am doing a single partition NTFS resizable, I have ensured that the client hard drive only has one partition as well. There is unallocated space on the clients hard drive but it is located on the back of the disk, not in front so I’m not sure if this could be causing an issue.

    I have tried to chown -R fog.root /images as well as chmod 777

    I feel like the problem is that the image is initially being sent to a /tmp and when the process finishes, the image is suppose to be moved over to the /images folder but it’s getting caught up here.

    I have also monitored the hard disk space as the client was uploading the image to the server and I can see that something is physically being written to the hard drive in real time… Anyway, was wondering if you guys have seen this type of issue in the past. Let me know if you need any other clarification and I apologize if none of this makes sense. Perhaps I missed something with the initial install. :D

    Thanks in advance.

    EDIT: I have also worked through this but have not had any success: [url]http://fogproject.org/wiki/index.php?title=Images_Directory_Permissions[/url]



  • Fixed: My solution was to remove the /images directory and then make a new one seemed to have done the trick.


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.