Operation Not supported



  • I figured I better start a new thread for this problem.

    Just upgraded to fog 1.1.0 and did it with a fresh database with fresh linux install (14.04 ubuntu). The only thing I carried over was the host. Still getting Operation Not supported. Kind of at a loss. Upgraded bios on 990’s to A18 (most current) didn’t seem to help. Dell 390 doing the same, I was able to get it to work on “e0478-DEFAULT-TEST” ipxe.pxe . Nothing else so far though seems to get them to work.

    ScreenShot534.png



  • For future people with these problems - this worked.



  • Changed the hyper-v network adapter to legacy thinking that just maybe - but nope.



  • Would hyper-v somehow cause this?


  • Senior Developer

    67 is supposed to be undionly.kpxe, I was thinking of default and it just typed it sorry.



  • Ok something new. It appears that non of them are working. They all say operation not supported, but they move past it pretty quickly. Just the 390 and 990 get stuck on it.



  • Opt 66 is set to fog server ip. Opt 67 was not on default.ipxe - I was on undionly.kpxe . If I change over to default.ipxe it hangs after getting gateway ip.

    Will check out the boot disk in the AM.


  • Senior Developer

    Can you try following instructions from here:
    http://ipxe.org/err/3c0920

    Do you have Option 66 set to FOGIP (the pointer to the tftpserver) or Option 67 set to default.ipxe?

    While I realize things are working, for the most part, it may, very well, be an issue with the NIC firmware on that box. While not optimal, you could try booting a copy of the ipxe.iso file from CD or USB Disk and use that to pxe boot. You’d likely need your “default.ipxe” uploaded when building the iso.

    You can build the ipxe.iso from http://rom-o-matic.eu

    Choose Advanced, for experienced users

    Choose ISO bootable image (.iso)

    Leave NIC type on all-drivers.

    COM1-4 checked
    COMCONSOLE: COM!
    COMSPEED: 115200
    COMDATA checked
    COMPARITY 0
    COMSTOP, 1

    None of the PCIAPI Options.

    Console Options
    Only check CONSOLE_VESAFB, VESA framebuffer console

    KEYBOARD_MAP: us

    PCI_SETTINGS Checked
    CPUID_SETTINGS Unchecked
    MEMMAP_SETTINGS Unchecked

    VMware options:
    VMWARE_SETTINGS checked.

    ISA Options:
    none checked

    Leave everything alone in Branding options

    Leave Timer configuration with both options checked.

    Leave only NET_PROTO_IPV4, IPv4 checked in Network Protocols.

    Leave PXE support unchecked.

    Download Protocols check TFTP, HTTP, HTTPS, FTP, NFS

    Leave SAN boot protocols unchecked.

    Uncheck all Wireless Interface options

    Leave Name resolution modules checked.

    Only enable the following in Image Types:
    IMAGE_PXE, IMAGE_BZIMAGE, IMAGE_PNG

    Command-line commands to include check all ([b]EXCEPT[/b] the following)
    IFMGMT_CMD
    IWMGMT_CMD
    PROFSTAT_CMD

    Leave everything else the same.

    In the embedded script:
    Copy and paste the following:

    #!ipxe
    dhcp || reboot
    chain http://<FOG SERVER IP>/fog/service/ipxe/boot.php || reboot
    

    Click proceed.

    Once the iso is downloaded, burn it to a cd and see if it works.



  • Found mass erase here http://fogproject.org/forum/threads/mass-delete-hosts.10396/#post-29140 didn’t seem to have an effect.



  • I took out the one of the problem hosts and it didn’t seem to care.



  • How can I do a mass remove of the hosts?


  • Senior Developer

    Instead of carrying over the host, could you completely delete the host and perform a Full Register, does it work if this method is used?


Log in to reply
 

507
Online

38925
Users

10691
Topics

101434
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.