HP 4530s - PXE-E3B



  • Hello -

    I’m currently trying to image a HP ProBook 3530s with the most recent kernel and FOG 1.1.0 – I’m not sure if it worked with 1.0.1 but did with 0.33b.

    I’m getting a E3B TFTP error when it’s trying to find the file, but a ProBook 4540s works. I’m currently running on a 12.02 environment, fresh install.



  • Yep, noticed that when I edited the original post - back up and running though. I’m still not sure what’s causing the issue with the 4530s. 4520s and 4540s work perfectly.

    I’ll just use a USB until I can figure out what’s causing it -

    Rob


  • Senior Developer

    Reason you’re getting kernel panic:

    Did you download the:
    Kernel - 3.0.1 TomElliott
    Date : June 12, 2014
    Version: 3.0.1
    FOG Type: TomElliott
    Arch Type: (x86)

    AS bzImage? If so this is your problem.

    You copied a 32 bit kernel as if it was your 64 bit kernel.

    bzImage is now the default file used for 64 bit systems.
    init.xz is now the default file used for 64 bit systems.

    bzImage32 is now the default file used for 32 bit systems.
    init_32.xz is now the default file used for 32 bit systems.

    Your configuration, if I’m reading it properly, is:
    bzImage32 -> init.xz pairing which will cause a panic.

    This is why I started putting the arch on the files.



  • I can still boot through the flash drive - yes. As for the connection, no. This is a completely fresh environment. I’m running AD and DHCP services off two domain controllers. Both with split DHCP 50/50. FOG is running on a new 12.04 VM server. Virtual servers are on the same VLAN for testing as the physical laptop.

    Port config (although it shouldn’t matter, works for other models)

    panic.jpg


  • Developer

    is there any difference in the physical connection between the working laptops and the non-working laptops?
    are they connected through the same switches?


  • Senior Developer

    @RLane, post: 30065, member: 23505 said:

    Without any workarounds, I still get the same PXE-E3B error claiming that there is no TFTP file found.

    Okay,

    So you can ipxe boot now? Through the Flash drive of course?



  • Returned the same error. I’ve compared the bios revisions to the working 4540s model and everything is similar.


  • Senior Developer

    Keep this change in place:
    sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0



  • Without any workarounds, I still get the same PXE-E3B error claiming that there is no TFTP file found.

    photo.JPG


  • Senior Developer

    Just try booting your 4530’s without workaround please?

    I added multi mac’s to be sent, hopefully they will send and find the host in either direction.



  • Absolutely, I went ahead and installed the newest SVN. Let me know what you would like me to further troubleshoot.


  • Senior Developer

    RLane,

    Can you try the svn of FOG? I added a couple more "param"s that I’d like to test your scenario with.



  • For what it’s worth - now my problem is very weird. If I register them for the first time, booting from the live USB, it will work every time after that. It is not detected the first boot into the FOG menu, though.



  • @Junkhacker, post: 29715, member: 21583 said:

    will they boot to the network if you disable the wireless in bios?

    That does not unfortunately, without the Clonezilla USB it goes back to the original PXE-E3B error.


  • Developer

    will they boot to the network if you disable the wireless in bios?



  • My hunch was correct… on these 4530s it appears net0 is the wireless --I know this only because

    1. the MAC address 2) wireless subnet is 10.145.x.x

    Oddly enough, this only works when using the Clonezilla live USB. Is there a way to modify something in FOG for these devices specifically to select net1 as the default so it can boot photo 1.JPG



  • I guess my main question to you then would be (disregarding the previous picture) – why would it boot off a flash drive with a Clonezilla to ipxe verse through a network boot? Would this be caused by the wireless interface taking place of net0 instead of net1, thus not allowing the ethernet to actually be bootable? See attached screenshot -

    HP ProBook 4530s:

    http://i.imgur.com/IhRJWOX.jpg


  • Senior Developer

    With the link in place, can you try net booting the systems? It’s most likely attempting to look specifically for the pxelinux.0 which now exists.

    Unfortunately, if this doesn’t fix it, there’s nothing I can really do. Your issues are occurring before the system even boot’s to the kernel.



  • @Tom Elliott, post: 29658, member: 7271 said:

    Do you have multiple TFTP server’s on the same subnet handing out files? It sounds to me like this is the case. That or the firmware for the PXEBoot on those systems is programmed to seek out pxelinux.0 specifically, one way to test that theory would be to create a link to the undionly.kpxe as pxelinux.0

    >sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0
    >```
    
    Strangely enough, no. This is an entire new network structure and this is the only TFTP server on the entire network. With that said, this change did work, perhaps this was a very old model. Question though, we have over 120 HP ProBook 4530s - is there a way to add the driver to the kernel to actually get it working? Using a flash drive is fine, but if there's a better/easier way to make it work, please let me know.
    
    Thanks Tom - Love FOG and the entire project.

  • Senior Developer

    Do you have multiple TFTP server’s on the same subnet handing out files? It sounds to me like this is the case. That or the firmware for the PXEBoot on those systems is programmed to seek out pxelinux.0 specifically, one way to test that theory would be to create a link to the undionly.kpxe as pxelinux.0

    sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0
    

Log in to reply
 

490
Online

38916
Users

10685
Topics

101361
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.