CentOS 6.5 x86_64 Installation process & failure with FOGFTP



  • *Most of this came from [url]http://www.fogproject.org/wiki/index.php/Installation_on_CentOS_6.4[/url] *
    After a Fully updated && upgraded OS.

    *Static IP Address setup:
    system-config-network

    Downloading FOG
    (I like putting everything on my Download folder)
    [code]
    cd /home/user/Downloads/
    svn co https://svn.code.sf.net/p/freeghost/code/tags/1.0.1/ fog_1.0.1
    cd /fog_1.0.1/bin
    ./installfog.sh
    [/code]

    Installing FOG, user appropriate settings.
    If you setup your network configurations with system-config-network you should be able to press enter all the way down.
    Error during installation: (DON’T PANIC YET)
    Don’t close your current terminal
    [code]
    Configuring services.

    • Setting up fog user…OK
    • Setting up and starting MySQL…OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web Server…OK
    • Restoring user reports…OK
    • Configuring Fresh Clam…Skipped (See wiki for installation instructions)
    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…Failed!
      [/code]

    Launch your browser and go to your server IP address
    Then select the “Install/Upgrade Now”
    [code]
    http://YOUR-SERVER-IP/fog/commons/schemaupdater/index.php?redir=1
    [/code]

    Go back to your terminal & relaunch your ./install.sh file.
    Installation should be good after this.
    [code]
    Configuring services.

    • Setting up fog user…Exists
    • Setting up and starting MySQL…OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web Server…OK
    • Restoring user reports…OK
    • Configuring Fresh Clam…Skipped (See wiki for installation instructions)
    • Setting up storage…OK
    • Setting up and starting NFS Server…OK
    • Setting up and starting DHCP Server…OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…OK
    • Starting FOG Task Scheduler Server…OK
    • Setting up FOG Utils…OK

    Would you like to notify the FOG group about this installation?
    * This information is only used to help the FOG group determine
    if FOG is being used. This information helps to let us know
    if we should keep improving this product.

    Send notification? (Y/N)
    [/code]

    Log in to your FOG manager GUI
    Create an image,
    create a host & add to image.

    Another problem that I encounter.

    [ATTACH]897[/ATTACH]

    I tried the following but failed.
    [code]
    chown -R fog:root /tftpboot
    [/code]
    I found this on a website.
    [code]
    [root@localhost bin]# restorecon -Rv /tftpboot
    restorecon reset /tftpboot context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/all-wcprops context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/text-base context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/props context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/entries context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/tmp context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/tmp/text-base context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/tmp/props context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/tmp/prop-base context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/tftpboot/.svn/prop-base context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/default.ipxe context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/vesamenu.c32 context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/boot.txt context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/ipxe.krn context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/undionly.kpxe context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/memdisk context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/snponly.efi context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    restorecon reset /tftpboot/pxelinux.0.old context unconfined_u:object_r:default_t:s0->unconfined_u:object_r:tftpdir_t:s0
    [root@localhost bin]# /etc/init.d/vsftpd restore
    Usage: /etc/init.d/vsftpd {start|stop|restart|try-restart|force-reload|status}
    [root@localhost bin]# /etc/init.d/vsftpd restart
    Shutting down vsftpd: [ OK ]
    Starting vsftpd for vsftpd: [ OK ]
    [/code]
    FOG starts imaging.
    Then it fails, and this is as far as I gone.

    Another error that I found in /var/log/httpd/error_log
    [code]
    [Wed Jun 04 11:55:35 2014] [error] [client 192.168.106.130] PHP Warning: date_default_timezone_get(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘America/Los_Angeles’ for ‘PDT/-7.0/DST’ instead in /var/www/html/fog/commons/system.php on line 11, referer: http://192.168.106.130/fog/management/index.php?node=tasks&sub=active
    [/code]

    [url="/_imported_xf_attachments/0/897_Windows 8-2014-06-02-12-05-42.png?:"]Windows 8-2014-06-02-12-05-42.png[/url][url="/_imported_xf_attachments/0/898_Windows 8-2014-06-03-08-24-36.png?:"]Windows 8-2014-06-03-08-24-36.png[/url]



  • [quote=“Tom Elliott, post: 29258, member: 7271”]The date.timezone error you’re seeing, is this still an issue?

    Edit the php.ini file and place your timezone setting there.[/quote]

    Found the file and edited according & no more errors.
    File path:
    /etc/php.ini

    [code]
    Date]
    ; Defines the default timezone used by the date functions
    ; http://www.php.net/manual/en/datetime.configuration.php#ini.date.timezone
    date.timezone = ‘America/Los_Angeles’
    [/code]



  • [quote=“Tom Elliott, post: 29258, member: 7271”]The date.timezone error you’re seeing, is this still an issue?

    Edit the php.ini file and place your timezone setting there.[/quote]

    I was able to use the following code to address the timezone settings so far tail /var/log/httpd/error_log has reported anything. I’ll keep making notes.
    [code]
    tzselect
    [/code]


  • Senior Developer

    The date.timezone error you’re seeing, is this still an issue?

    Edit the php.ini file and place your timezone setting there.



  • My iptables were disabled before I installed FOG.
    [code]
    [root@localhost drnatas]# /etc/init.d/iptables status
    Table: filter
    Chain INPUT (policy ACCEPT)
    num target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    num target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    num target prot opt source destination
    [/code]


  • Senior Developer

    Normally, selinux isn’t disabled until a reboot, which seems to be the case.

    Is iptables still running?

    [code]service iptables status[/code]

    To disable iptables try:
    [code]chkconfig iptables off
    service iptables stop[/code]

    Then run:
    [code]iptables -L -n[/code]

    The return output should be:
    [code]Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination [/code]



  • [quote=“Tom Elliott, post: 29217, member: 7271”]And this is why we ask you to turn off SElinux[/quote]

    It’s all good I copied and pasted the code to disabled the SELINUX, I assumed it was disabled instead of checking it.
    Once I’m done with perfecting the installation I will love to assist you guys with the wiki. Once again thanks for your enormous support.
    [code]
    [root@localhost drnatas]# sestatus -v
    SELinux status: disabled
    [/code]


  • Senior Developer

    Sorry about the short posts but I’m driving home so I’m restricted to Google voice the other thing want to disable is IP tables


  • Senior Developer

    And this is why we ask you to turn off SElinux


Log in to reply
 

387
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.