Deploy OK, but system won't boot (stays looping in Fog menu)



  • Hello to all of you who are reading this thread.
    After some fighting, I managed to have Fog working: computers can acess and register themselves in Fog, I can upload images, and so on.
    The problem is only in the deployment of images… they are deployed well, but then, when I restart those machines after having their new image, they won’t boot: the Fog menu appears, have a time countdown (3s) and then the menu appears again.
    Can anyone tell me what to do? I read somewhere about some code we could add… but don’t know if that’s for my situation.

    All images are ok, since I made an Acronis image (from the same computer I uploaded the image), and when I deploy this Acronis TrueImage manually, it all goes well: computer starts, name is changed, it’s added to Active Directory… it’s just the Fog deployment that makes this computers not to boot.

    Thank you for all your help.



  • (using latest undionly.kkpxe - with 2 ‘k’ as my undionly.kpxe file since the original does not work in this system - keeps restarting machine)



  • Other thing… updated to last SVN and now cannot upload image in this UEFI machine… stays showing errors (all the steps in the image files)

    2014-06-09 16.27.44.jpg2014-06-09 16.28.54.jpg2014-06-09 16.29.11.jpg2014-06-09 16.29.59.jpg2014-06-09 16.30.16.jpg2014-06-09 16.30.57.jpg2014-06-09 16.31.19.jpg



  • Trying to upload the image gives some warnings:
    (…)
    http://msdn.microsoft.com/en-us/library/windows/hardware/dn640535(v=vs.85).aspx, we can read:
    "The protective MBR area exists on a GPT partition table for backward compatibility with disk management utilities that operate on MBR. The GPT header defines the range of logical block addresses that are usable by partition entries. The GPT header also defines its location on the disk, its GUID, and a 32-bit cyclic redundancy check (CRC32) checksum that is used to verify the integrity of the GPT header. Each entry in the GUID partition table begins with a partition type GUID. The 16-byte partition type GUID, which is similar to a System ID in the partition table of an MBR disk, identifies the type of data that the partition contains and identifies how the partition is used, for example, whether it is a basic disk or a dynamic disk. Note that each GUID partition entry has a backup copy. "

    Can this be related to CRC testing not being properly executed due to this 32-bit / 16-bit ambiguity between GPT and MBR?



  • In Fog 0.32 I used MPI type of imaging to upload images and all went fine. I used that same configuration to upload an image to Fog 1.1.0.
    In Fog 0.32 deployment worked fine… in Fog 1.1.0 does not work.
    I repeat… it’s the same system, the same configuration, the same partitions.



  • Tom:
    Thank you for all your explanations through chat. Decided topost here in case someone else is interested.

    In MPI (“Multiple Partition Image - Single Disk (not resizable)”) type, d1.mbr is 18k in size (meaning is a GPT partition information, as you said).
    In SD (“Single Disk (NTFS only, Resizable)”), there are no d1.mbr files, only rec.img.000 (8.0 or 8.1M) and sys.img.000 (varies according to image) files.

    You understood that I uploaded each type of computer image from the EXACTLY same computer and configuration, once as “Multiple Partition Image - Single Disk (not resizable)” and once as “Single Disk (NTFS only, Resizable)”. And when I deploy this images, MPI does not work and SD works.

    My guess is that Fog does not read the disk information the same way in SD as it does in MPI and somehow it manages SD well but not MPI, regardless it is GPT or MB.



  • (continued from previous post)
    img5.jpgimg6.jpgimg7.jpg



  • (after reading all previous posts and the following thread: http://fogproject.org/forum/threads/clonezilla-works-fog-does-not-both-use-partclone-0-2-69-help-please.10699/)

    I have 35 computers with ASUS B85M-G motherboard. They all have an Intel 4770 processor and 8 GB RAM.
    This board is UEFI, but as a CSM (Compatibility Support Module) with is enabled and all configurations are set to “Legacy OPROM only”. This options I set are:
    img1.jpgimg2.jpgimg3.jpgimg4.jpg


  • Developer

    DISKPART erases partitions, but i don’t think it modifies the boot sector. you didn’t wipe the old gpt data off the drive. you can use gdisk to wipe the boot sector



  • Another message that I’m getting might be important.

    I’ve created a simple image, made sure Windows 7 was on a MBR partition.
    When I made an Upload with Debug, when I execute #gdisk -l /dev/sda, i receive also this information:


    Found invalid GPT and valid MBR; converting MBR to GPT format.


    I guess it’s here the problem… the drive isn’t in GPT before uploading… it’s at that moment that it is converted to GPT.


  • Senior Developer

    That wouldn’t work because the drive partitioning would already be setup in GPT.



  • To bypass this… do you think it is possible to install everything until image is ready, then use older computer to upload image (by older I mean withouth EFI)?

    I mean, install HDD from my new system in a Lagacy computer…


  • Senior Developer

    If everything is Legacy based, the FOG Installer will install it as MBR based image. If the system is in and type of UEFI mode, it will automatically default to GPT.

    My guess is the boards not properly disabling UEFI.



  • Just started a new image… made sure every boot option in BIOS were set to Compatible Mode.
    In WinPE, used DISKPART to clean disk entirely.
    Started Windows Setup from USB flash drive.
    When I got to
    Started setup and created partition for OS. Finished setup and went to Disk Management - Disk 0 - Properties says it’s MBR
    Started Image-Download Debug and run #gdisk -l /dev/sda
    It says:
    Partition table scan:
    [INDENT=1]MBR: MBR only[/INDENT]
    [INDENT=1]BSD: not present[/INDENT]
    [INDENT=1]APM: not present[/INDENT]
    [INDENT=1]GPT: present[/INDENT]

    Founf valid MBR and GPT. Which do you want to use?
    1 - MBR
    2- GPT
    3 -Create blank GPT

    Your answer:_

    So I guess somethings happen when i upload my image. Seems like Fog is converting MBR to Protective MBR the partition where Windows 7 is installed. Maybe it is getting confused about Microsoft Reserved Partition is in GPT format.

    What do you think?



  • Tom:

    Thank you for your patiente…


  • Senior Developer

    They should work for fog but only for imaging. Not currently passing back to Uefi. Meaning to image disable secure boot->net boot->image-> reenable secure boot-> do not NetBoot



  • I guess this might be a BIOS problem… i read (http://technet.microsoft.com/en-us/library/dn336946.aspx) that if I had my BIOS in compatibility mode, the Windows should automatically create partitions in MBR…
    As it is creating them in GPT, I’m assuming that BIOS isn’t passing the right info to Windows. Going to check how to overcome this and get back soon.

    Meanwhile… shouldn’t GPT partitions also work in Fog? Is there any configuration I need to make?



  • Well… this is saying I have GPT partition, right?
    I searched online about what protective MBR is, and it figures out that:
    “You can also see that there is a protective MBR at the first sector of the hard disk. Such hybrid setup is to allow a BIOS-based system to boot from a GPT disk using a boot loader stored in the protective MBR’s code area. In addition, it protects the GPT disk from damage by GPT-unaware disk utilties.”



  • Partition table scan:
    MBR: protective
    BSD: not present
    APM: not present
    GPT: present



  • Well, I checked in the original image… and answered before reading your post… sorry (shame on me).

    When I run your command, I get:
    “Found valid GPT with protective MBR; using GPT.”


Log in to reply
 

391
Online

38920
Users

10688
Topics

101407
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.