Starting FOG Multicast Management Server...Failed!



  • Hello,
    I have tried to install FOG again and I still get this message.
    Centos 6.5
    FOG 1.01

    So far I am still able test to some degree. When I start the service by hand it starts and then PHP barks about time zone which is correct.

    This is repost as this is probably a better spot for the query.
    thanks in advance
    DBA



  • Yes all of this worked I can cd /images create a folder as the user fog and double check by going to images folder and seeing the test folder.



  • Ok off for the weekend, will be back at lab on Monday.
    Have a good weekend and thanks for the help.


  • Senior Developer

    What I need you to do is to cd into /images.

    I’m not worried about the machine you’re trying to upload the image from, rather wanting to see where the actual issue is.

    Do it from the FOG Server.

    open a terminal and run:
    [code]ftp 192.168.247.15[/code]

    It should ask for a username. Enter fog type enter

    It should ask for a password. Enter Welcome1 (or whatever the password is) and type enter.

    It should say something like: cmd successful.

    Exact info may vary but when I succeed I get:
    [code]230 Login successful.
    Remote system type is UNIX.
    Using binary mode to transfer files.[/code]

    Then type
    [code]cd /images[/code]

    It should report back something like:
    [code]250 Directory successfully changed.[/code] If not there’s probably an issue here.

    IF successful type:
    [code]mkdir testMeNow[/code]

    If that’s successful it should report as:
    [code]257 “/images/testMeNow” created[/code]

    Then We’ll know if it’s a user issue, or if it’s a permissions issue.



  • ok
    Yes I am able to ftp to the server using the same credentials from the same machine I am trying to image and create/delete folders.
    I am also able to do it at the command line on the server as well as Mozilla.

    With that said it is creating the folders under /home/fog not under /images/
    I don’t know if that matters or not


  • Senior Developer

    Okay,

    That’s probably correct as, now, I realize I didn’t install an FTP client.

    So you can safely cancel that task.

    So you can FTP from a windows system, but can you FTP from the actual FOG Server?

    The commands I gave above should work on your FOG Server system to test.



  • Thanks for your patience.

    I created a new debug upload task that came to a screen that said "you can reboot, run fog or ifconfig"
    I type fog and it began to run
    When the errors start I clicked ctrl c
    I typed ftp 192.168.247.15
    It said command not found


  • Senior Developer

    no, you chose the wrong task.

    Under advanced options, there’s an upload - debug. Not the pure debug task.



  • Ok I see what you mean now.
    I started in debug, typed fog, it threw error unknown request type null will reboot in 1 minute.
    I hit Ctrl C it returned me back to command prompt
    I typed ftp 192.168.247.15
    it returned “command not found”


  • Senior Developer

    It’s not when you click on upload tasks. Choose the host, go to basic tasks, then choose advanced. In there will be Upload-Debug.



  • for upload tasks
    I have
    schedule shutdown
    schedule instance deployment
    schedule delayed
    schedule cron style

    I don’t see upload-debug task

    Is there a key to hit when the client boots to PXE to get to this information? I am not sure if this is to be run on the client or server.


  • Senior Developer

    Can you create an upload-debug task from the advanced options during task deployment and run fog.

    When at the command prompt, simply type:
    [code]fog[/code]

    When it starts giving you the error, type CTRL+C and it will bring you back to the command prompt.

    Then type:
    [code]ftp 192.168.247.15[/code]

    Then it should ask you for the username to connect as. Type fog.

    Then it should as you to enter the password. Type Welcome1.

    If all connects as expected type:
    [code]cd /images
    mkdir testMe123[/code]

    Does all work?



  • The pictures are in reverse but you get the idea.




  • Developer

    those 2 places in config.php are no longer used
    have you changed the password to match in Fog Settings -> TFTP Server -> FOG_TFTP_FTP_PASSWORD



  • Yes I made the password the same for everything. That is what I am saying I can plug a cross connect in to the machine and use the same client to ftp to the fog server and create/delete a folder.

    So far I have it changed via
    passwd
    login for fog portal
    under storage management
    both places in the html file config.php


  • Developer

    ok, the sandbox thing isn’t relevant for you then. are you certain that the linux user “fog” has it’s password set to the same as is listed in the fog settings?



  • when I added that line to my conf file and restart the service it says unrecognized variable maybe it’s not compiled for that or something. I triple checked the spelling and made sure _ was in there.
    I think I have hit about every road block so far :rolleyes:



  • Ok will try that
    What makes zero sense is I can log in from an alternate Windows machine to that FTP site and create a new folder and delete it with the same credentials.


  • Developer

    if you’re certain your passwords are correct, you might check your vsftpd.conf file to see if there’s a line that says seccomp_sandbox=NO
    if it’s there, try removing it and restarting the vsftpd service
    if it’s not, try adding it and restarting the vsftpd server


Log in to reply
 

439
Online

38947
Users

10698
Topics

101511
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.