"Exec format error"?



  • [COLOR=#141414][FONT=Tahoma]I have a Fog 1.0.1 fresh install on Ubuntu 14.04.[/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma] [/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma]I’m having a problem with booting any machine or VM with PXE boot to the Fog server. I have both 66 and 67 DHCP options set.[/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma] [/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma]When I try to boot an box with PXE boot I’m getting could not boot: Exec format error ([url]http://ipxe.org/2e022001[/url])[/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma] [/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma]I have searched the web and Fog forum for any info that may help me resolve this problem. I have been trying to find a way to resolve this problem with no success. [/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma]Attached is a snapshot of the error: [/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma][ATTACH=full]844[/ATTACH] [/FONT][/COLOR]

    [url="/_imported_xf_attachments/0/844_Fog Error.jpg?:"]Fog Error.jpg[/url]



  • [quote=“Tom Elliott, post: 28467, member: 7271”]Which undionly.kpxe file are you running?[/quote]

    here is the tail of the error.log

    Cannot adopt OID in UCD-SNMP-MIB: laErrMessage ::= { laEntry 101 }
    Cannot adopt OID in UCD-SNMP-MIB: laErrorFlag ::= { laEntry 100 }
    Cannot adopt OID in UCD-SNMP-MIB: laLoadFloat ::= { laEntry 6 }
    Cannot adopt OID in UCD-SNMP-MIB: laLoadInt ::= { laEntry 5 }
    Cannot adopt OID in UCD-SNMP-MIB: laConfig ::= { laEntry 4 }
    Cannot adopt OID in UCD-SNMP-MIB: laLoad ::= { laEntry 3 }
    Cannot adopt OID in UCD-SNMP-MIB: laNames ::= { laEntry 2 }
    Cannot adopt OID in UCD-SNMP-MIB: laIndex ::= { laEntry 1 }
    [Fri May 30 13:22:37.131054 2014] [mpm_prefork:notice] [pid 1702] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured – resuming normal operations
    [Fri May 30 13:22:37.131117 2014] [core:notice] [pid 1702] AH00094: Command line: '/usr/sbin/apache2’
    How do you tell what version of the undionly.kpxe file you have?
    Yes I have searched the forum and the wiki also did the steps from kernel Issues url and no change.


  • Senior Developer

    Which undionly.kpxe file are you running?


 

646
Online

41.5k
Users

12.0k
Topics

113.4k
Posts