Hostname changer



  • [SIZE=13px][FONT=Tahoma][COLOR=#141414]After updating to 1.0.1 (from .32), mostly everything works. I ran into an issue with multiple computers using the hostname changer. [/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414] [/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]What I know…[/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414] [/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]-a computer (I’m using windows 7) will change the hostname and join the domain AFTER I go into services.msc to stop/start or restart the service[/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]-I tried rebooting and that doesnt fix it[/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]-the fog log just shows that it doesn’t see a hostname in the system[/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]-I tried using the old version of fog service (from a previous image) and I have uninstalled/reinstalled the updated fog service client - neither of which made a difference[/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414] [/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]Any help would be greatly appreciated![/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414] [/COLOR][/FONT][/SIZE]
    [SIZE=13px][FONT=Tahoma][COLOR=#141414]Thanks![/COLOR][/FONT][/SIZE]


  • Senior Developer

    If you imported hosts, then it is most likely because the host modules are not set.



  • hey guys,

    same here, update to 1.1.0…

    hostname changer works only when the client get the registration via pxe boot.

    I have imported all clients with csv and made the groups manually! --> none of this clients changed the hostname after the quick image

    the solutions for me is, every clients must be registrated via PXE boot menu.

    raffa


  • Developer

    Junkhacker:

    Thank you very much for the reply. I will dig further to address this.

    Andy


  • Developer

    the fog service has not changed. the computers may not be joining the domain because the active directory username field has changed from “domain\username” to just "username"
    the name not changing may be due to an issue with the computer not being able to communicate with the fog server on startup. the hostname changer service only checks once, on startup. setting the fog service to delayed start has resolved this issue for some people.


  • Developer

    I did a clean install of Ubuntu 13.10 with 1.1.0 and deployed our base image from 0.32 / uploaded to new 1.1.0 installation. Do I need to use an updated FOG Service msi before I sysprep or will the 0.32 image version work as is? The snapins seem to deploy fine - just doesn’t change name or join domain.

    Thanks,

    Andy



  • This post is deleted!


  • That seemed to do the trick! (:

    Thank you!


  • Senior Developer

    Try this,

    Place all hosts in your fog system into a single group, (ODD I KNOW)

    Open a terminal window and ssh to your fog server.

    Run:
    [code]mysql -u root fog[/code]

    If you set a mysql root password run:
    [code]mysql -u root -p fog[/code]

    It should ask for your root password.

    Run the command:
    [code]truncate table moduleStatusByHost;[/code]

    You can close the terminal.

    Go back to your FOG Web GUI.

    Go to Group Management.

    List the group, or search for what ever you named the group.

    Select your group.

    Choose Service Settings.

    Select the Services you want enabled.

    Apply the changes.



  • I’m having the same issue after updating fog version from 0.32 to 1.0.1… I’ve already tried the Tom Elliott’s suggestion but unfortunately it didn’t work…

    04/06/2014 17:02 FOG::HostnameChanger Module is disabled on this host.
    04/06/2014 17:02 FOG::HostnameChanger Host name was not found in the database.



  • I will try that first thing tomorrow and let you know what happens.

    Thanks!


  • Senior Developer

    Quickfix I would think would be to go to make a group of the hosts that were registered before your migration going into that group going to service settings uncheck everything save recheck everything safe



  • I did a lot of testing today and found the problem… not a solution yet.

    To give a brief background… I updated from 0.32 running ubuntu 10.04. I installed 14.04 and installed 1.0.1 -then migrated my fog install (i did this “clean” migration because when I just upgraded on the 10.04, some of my reports werent working -Pending macs, imaging logs, etc)

    My devices change the hostname and join the domain perfectly with…
    -newly added devices and delayed startup
    -devices deleted out of fog and re-added doing the full host registration

    It does not work when…
    -I have a device registered in fog before the migration

    I have tried restarting the service/computer, but that didnt help. I get the same errors as I posted before with…


    5/27/2014 4:19 PM FOG::HostnameChanger Attempting to connect to fog server…
    5/27/2014 4:19 PM FOG::HostnameChanger Module is disabled on this host.
    5/27/2014 4:19 PM FOG::HostnameChanger Host name was not found in the database.

    I have tried running a hardware inventory report on a machine that has been in fog before my migration… that did not help.

    Any ideas? Anyone else seeing this with or without an upgrade to the new 1.0.1 from 0.32?

    Thanks a lot!


  • Developer

    the root of the problem likely has to do with the fact that hostname changer only checks once, on startup. if it does not have a valid network connection at that time, it will not see the server, and won’t change the name, and won’t try again.



  • Update: Setting the service to delayed start works perfectly. Thanks for the idea!



  • Junkhacker - I will try that as well

    Thanks (:



  • GFm - yep, I downloaded the service installer right from the new version of FOG

    Junkhacker - hmm, good suggestion. I will try that and get back to you.


  • Developer

    try setting the fog service to delayed start



  • Do you have the new FOG service running? I’m still having issues and haven’t pinpointed a solution. You can try that?

    I’ve noticed sometimes it automatically renames and joins the domain and sometimes I have to manually restart the computer or the service to get it to rename then join domain.



  • Has anyone else seen this issue or come across an answer? I’m still having to restart the fog service before it will change the hostname.


Log in to reply
 

367
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.